# High CPU utilization by PMM agent

**URL:** <https://forums.percona.com/t/high-cpu-utilization-by-pmm-agent/36638>\
**Category:** PMM 2.x\
**Created:** [February 11, 2025, 10:18am UTC](https://forums.percona.com/t/high-cpu-utilization-by-pmm-agent/36638 "2025-02-11T10:18:35Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![ikon](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/ikon/32/4351_2.png) [@ikon](https://forums.percona.com/u/ikon)\
**Post date:** [February 11, 2025, 10:18am UTC](https://forums.percona.com/t/high-cpu-utilization-by-pmm-agent/36638/1 "2025-02-11T10:18:35Z")

</div>

Description: High CPU utilization by PMM agent  
We observed high CPU utilization by PMM agent in our MongoDB secondary servers.  
After restarting the agent, it was resolved. In the pmm-agent logs we observed below sample logs. Similar logs were observed for multiple namespace and collections. After restart of pmm-agent, these errors are not observed

level=error msg="cannot get $collstats cursor for collection rest.tmp.mrs.logDetails\_1739062843\_1120: (Location40280) Unable to retrieve storageStats in $collStats stage: Collection [rest.tmp.mrs.logDetails\_1739062843\_1120] not found." collector=collstats" agentID=/agent\_id/c16fe8c3-f086-4501-89a6-3fa40aa893fb component=agent-process type=mongodb\_exporter

Version:  
PMM 2.44  
Mongo version: 4.0.28

---

<div class="post-metadata">

**Author:** ![lalit.choudhary](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/lalit.choudhary/32/51_2.png) [@lalit.choudhary](https://forums.percona.com/u/lalit.choudhary)\
**Post date:** [February 12, 2025, 5:43am UTC](https://forums.percona.com/t/high-cpu-utilization-by-pmm-agent/36638/2 "2025-02-12T05:43:48Z")

</div>

Hello @ikon

It’s better to report this as a bug, As it needs more details to confirm the issue.

You can report it here with full details on the issue: [https://perconadev.atlassian.net](https://perconadev.atlassian.net)
