# hi im creating a 5node PXC 5.7 as geo multimaster setup

**URL:** <https://forums.percona.com/t/hi-im-creating-a-5node-pxc-5-7-as-geo-multimaster-setup/7604>\
**Category:** Percona XtraDB Cluster 5.x\
**Created:** [May 7, 2020, 5:03am UTC](https://forums.percona.com/t/hi-im-creating-a-5node-pxc-5-7-as-geo-multimaster-setup/7604 "2020-05-07T05:03:26Z")\
**Posts on this page:** 14\
**Page:** 1

<div class="post-metadata">

**Author:** ![balajisivamani](https://avatars.discourse-cdn.com/v4/letter/b/b9bd4f/32.png) [@balajisivamani](https://forums.percona.com/u/balajisivamani)\
**Post date:** [May 7, 2020, 5:03am UTC](https://forums.percona.com/t/hi-im-creating-a-5node-pxc-5-7-as-geo-multimaster-setup/7604/1 "2020-05-07T05:03:26Z")

</div>

In one location there are 3 PXC nodes all are in synch and working fine,now I’m trying to add two more nodes in different location with IP reachability and 3306 port opening . after configuring the nodes in the 4rth and 5th node in wsrep.cnf file. MySQL is not not starting .giving error-can anyone help me pls.

---

<div class="post-metadata">

**Author:** ![DGB](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/dgb/32/79_2.png) [@DGB](https://forums.percona.com/u/DGB)\
**Post date:** [May 7, 2020, 8:57am UTC](https://forums.percona.com/t/hi-im-creating-a-5node-pxc-5-7-as-geo-multimaster-setup/7604/2 "2020-05-07T08:57:45Z")

</div>

Hi @balajisivamani   
Can you please provide the error log ?  
Also, in the meanwhile: can you check that the Galera required ports are open? 4444 4567 and 4568

---

<div class="post-metadata">

**Author:** ![balajisivamani](https://avatars.discourse-cdn.com/v4/letter/b/b9bd4f/32.png) [@balajisivamani](https://forums.percona.com/u/balajisivamani)\
**Post date:** [May 7, 2020, 9:09am UTC](https://forums.percona.com/t/hi-im-creating-a-5node-pxc-5-7-as-geo-multimaster-setup/7604/3 "2020-05-07T09:09:03Z")

</div>

yep i just opened those ports ,so my scenario is 3 nodes at location A and 2 nodes at location B multimaster setup. yes those ports are opened at both the end FW’s.&nbsp;  
  
systemctl restart mysqlJob for mysql.service failed because the control process exited with error code.See “systemctl status mysql.service” and “journalctl -xe” for details.root@spxc1:~# systemctl status mysql● mysql.service - LSB: Start and stop the mysql (Percona XtraDB Cluster) daemon&nbsp; &nbsp;Loaded: loaded (/etc/init.d/mysql; generated)&nbsp; &nbsp;Active: failed (Result: exit-code) since Thu 2020-05-07 14:36:52 UTC; 17s ago&nbsp; &nbsp; &nbsp;Docs: man:systemd-sysv-generator(8)&nbsp; Process: 27930 ExecStop=/etc/init.d/mysql stop (code=exited, status=0/SUCCESS)&nbsp; Process: 28060 ExecStart=/etc/init.d/mysql start (code=exited, status=1/FAILURE)  
May 07 14:36:12 spxc1 systemd[1]: Starting LSB: Start and stop the mysql (Percona XtraDB Cluster) daemon…May 07 14:36:13 spxc1 mysql[28060]:&nbsp; \* Starting MySQL (Percona XtraDB Cluster) database server mysqldMay 07 14:36:13 spxc1 /etc/init.d/mysql[28129]: MySQL PID not found, pid\_file detected/guessed: /var/run/mysqld/mysqld.pidMay 07 14:36:52 spxc1 mysql[28060]:&nbsp; \* The server quit without updating PID file (/var/run/mysqld/mysqld.pid).May 07 14:36:52 spxc1 mysql[28060]:&nbsp; &nbsp; …fail!May 07 14:36:52 spxc1 systemd[1]: mysql.service: Control process exited, code=exited status=1May 07 14:36:52 spxc1 systemd[1]: mysql.service: Failed with result ‘exit-code’.May 07 14:36:52 spxc1 systemd[1]: Failed to start LSB: Start and stop the mysql (Percona XtraDB Cluster) daemon.

---

<div class="post-metadata">

**Author:** ![balajisivamani](https://avatars.discourse-cdn.com/v4/letter/b/b9bd4f/32.png) [@balajisivamani](https://forums.percona.com/u/balajisivamani)\
**Post date:** [May 7, 2020, 9:18am UTC](https://forums.percona.com/t/hi-im-creating-a-5node-pxc-5-7-as-geo-multimaster-setup/7604/4 "2020-05-07T09:18:20Z")

</div>

and this happens when i give the location A node 1 Ip address in the 4rth node which is in location B .wsrep\_cluster\_address=gcomm

---

<div class="post-metadata">

**Author:** ![DGB](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/dgb/32/79_2.png) [@DGB](https://forums.percona.com/u/DGB)\
**Post date:** [May 7, 2020, 9:45am UTC](https://forums.percona.com/t/hi-im-creating-a-5node-pxc-5-7-as-geo-multimaster-setup/7604/5 "2020-05-07T09:45:18Z")

</div>

Thanks, but could you provide the mysql error log too? and the cnf file for all the nodes as well?&nbsp;

---

<div class="post-metadata">

**Author:** ![balajisivamani](https://avatars.discourse-cdn.com/v4/letter/b/b9bd4f/32.png) [@balajisivamani](https://forums.percona.com/u/balajisivamani)\
**Post date:** [May 7, 2020, 9:58am UTC](https://forums.percona.com/t/hi-im-creating-a-5node-pxc-5-7-as-geo-multimaster-setup/7604/6 "2020-05-07T09:58:27Z")

</div>

in errorlog file nothing is recorded,the file is empty and cnf file you mean wsrep.cnf file&nbsp;  
  
# Path to Galera librarywsrep\_provider=/usr/lib/galera3/libgalera\_smm.so  
# Cluster connection URL contains IPs of nodes#If no IP is found, this implies that a new cluster needs to be created,#in order to do that you need to bootstrap this nodewsrep\_cluster\_address=gcomm://_all the five nodes IPs_  
# In order for Galera to work correctly binlog format should be ROWbinlog\_format=ROW  
# MyISAM storage engine has only experimental supportdefault\_storage\_engine=InnoDB  
# Slave thread to use#wsrep\_slave\_threads= 8  
#wsrep\_log\_conflicts  
# This changes how InnoDB autoincrement locks are managed and is a requirement for Galerainnodb\_autoinc\_lock\_mode=2  
# Node IP address#wsrep\_node\_address=192.168.70.63# Cluster namewsrep\_cluster\_name=pxc-cluster  
#If wsrep\_node\_name is not specified,&nbsp; then system hostname will be usedwsrep\_node\_name=pxc-cluster-node-2wsrep\_node\_address=\*Node IP \*  
#pxc\_strict\_mode allowed values: DISABLED,PERMISSIVE,ENFORCING,MASTERpxc\_strict\_mode=ENFORCING  
# SST methodwsrep\_sst\_method=xtrabackup-v2wsrep\_sst\_auth=sstuser:passw0rd#Authentication for SST method#wsrep\_sst\_auth=“sstuser:s3cretPass”  
  
its the same for all all the nodes except nodeip and name differs. please check and help to resolve

---

<div class="post-metadata">

**Author:** ![balajisivamani](https://avatars.discourse-cdn.com/v4/letter/b/b9bd4f/32.png) [@balajisivamani](https://forums.percona.com/u/balajisivamani)\
**Post date:** [May 8, 2020, 12:10am UTC](https://forums.percona.com/t/hi-im-creating-a-5node-pxc-5-7-as-geo-multimaster-setup/7604/7 "2020-05-08T00:10:03Z")

</div>

hi @DGB any info on this ?

---

<div class="post-metadata">

**Author:** ![DGB](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/dgb/32/79_2.png) [@DGB](https://forums.percona.com/u/DGB)\
**Post date:** [May 8, 2020, 7:26am UTC](https://forums.percona.com/t/hi-im-creating-a-5node-pxc-5-7-as-geo-multimaster-setup/7604/8 "2020-05-08T07:26:58Z")

</div>

Apparently the mysqld process itself cannot start at all, independently of Galera. If you take out or comment the galera-specific configuration variables, does the MySQL start?

---

<div class="post-metadata">

**Author:** ![balajisivamani](https://avatars.discourse-cdn.com/v4/letter/b/b9bd4f/32.png) [@balajisivamani](https://forums.percona.com/u/balajisivamani)\
**Post date:** [May 8, 2020, 7:48am UTC](https://forums.percona.com/t/hi-im-creating-a-5node-pxc-5-7-as-geo-multimaster-setup/7604/9 "2020-05-08T07:48:21Z")

</div>

i will test that ,let me also tell you that ,when I don’t provide the location A primary&nbsp; node address and give the actual node address ,then MySQL process is starting.

---

<div class="post-metadata">

**Author:** ![balajisivamani](https://avatars.discourse-cdn.com/v4/letter/b/b9bd4f/32.png) [@balajisivamani](https://forums.percona.com/u/balajisivamani)\
**Post date:** [May 11, 2020, 12:03am UTC](https://forums.percona.com/t/hi-im-creating-a-5node-pxc-5-7-as-geo-multimaster-setup/7604/10 "2020-05-11T00:03:38Z")

</div>

hey @dgb ya when i comment the galera section the MySQL process is started great. so whats next ?shall I check the replication and other stuff

---

<div class="post-metadata">

**Author:** ![balajisivamani](https://avatars.discourse-cdn.com/v4/letter/b/b9bd4f/32.png) [@balajisivamani](https://forums.percona.com/u/balajisivamani)\
**Post date:** [May 11, 2020, 12:04am UTC](https://forums.percona.com/t/hi-im-creating-a-5node-pxc-5-7-as-geo-multimaster-setup/7604/11 "2020-05-11T00:04:38Z")

</div>

this the output:  
show status like ‘wsrep%’;±-------------------------±---------------------+| Variable\_name&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; | Value&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; |±-------------------------±---------------------+| wsrep\_cluster\_conf\_id&nbsp; &nbsp; | 18446744073709551615 || wsrep\_cluster\_size&nbsp; &nbsp; &nbsp; &nbsp;| 0&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; || wsrep\_cluster\_state\_uuid |&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; || wsrep\_cluster\_status&nbsp; &nbsp; &nbsp;| Disconnected&nbsp; &nbsp; &nbsp; &nbsp; &nbsp;|| wsrep\_connected&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; | OFF&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; || wsrep\_local\_bf\_aborts&nbsp; &nbsp; | 0&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; || wsrep\_local\_index&nbsp; &nbsp; &nbsp; &nbsp; | 18446744073709551615 || wsrep\_provider\_name&nbsp; &nbsp; &nbsp; |&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; || wsrep\_provider\_vendor&nbsp; &nbsp; |&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; || wsrep\_provider\_version&nbsp; &nbsp;|&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; || wsrep\_ready&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; | ON&nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp; &nbsp;|

---

<div class="post-metadata">

**Author:** ![balajisivamani](https://avatars.discourse-cdn.com/v4/letter/b/b9bd4f/32.png) [@balajisivamani](https://forums.percona.com/u/balajisivamani)\
**Post date:** [May 11, 2020, 7:15am UTC](https://forums.percona.com/t/hi-im-creating-a-5node-pxc-5-7-as-geo-multimaster-setup/7604/12 "2020-05-11T07:15:46Z")

</div>

@DGB have you had a chance to see the issue?

---

<div class="post-metadata">

**Author:** ![DGB](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/dgb/32/79_2.png) [@DGB](https://forums.percona.com/u/DGB)\
**Post date:** [May 13, 2020, 7:20pm UTC](https://forums.percona.com/t/hi-im-creating-a-5node-pxc-5-7-as-geo-multimaster-setup/7604/13 "2020-05-13T19:20:19Z")

</div>

I was re reading and i saw that you didn’t provided the output of&nbsp;journalctl -xe when the node fails attempting to join the cluster, can you provide that please?

---

<div class="post-metadata">

**Author:** ![balajisivamani](https://avatars.discourse-cdn.com/v4/letter/b/b9bd4f/32.png) [@balajisivamani](https://forums.percona.com/u/balajisivamani)\
**Post date:** [May 13, 2020, 11:46pm UTC](https://forums.percona.com/t/hi-im-creating-a-5node-pxc-5-7-as-geo-multimaster-setup/7604/14 "2020-05-13T23:46:32Z")

</div>

hi pls find the output:  
  
he start-up result is RESULT.May 14 05:09:50 pxc1 systemd-timesyncd[7519]: Timed out waiting for reply from 91.189.89.199:123 ([ntp.ubuntu.com](http://ntp.ubuntu.com)).May 14 05:10:01 pxc1 systemd-timesyncd[7519]: Timed out waiting for reply from 91.189.89.198:123 ([ntp.ubuntu.com](http://ntp.ubuntu.com)).May 14 05:10:11 pxc1 systemd-timesyncd[7519]: Timed out waiting for reply from 91.189.91.157:123 ([ntp.ubuntu.com](http://ntp.ubuntu.com)).May 14 05:10:17 pxc1 sudo[10216]: pam\_unix(sudo:auth): authentication failure; logname=admin uid=1000 euid=0 tty=/dev/pts/0 ruser=admin rhost=&nbsp; user=mediaMay 14 05:10:21 pxc1 systemd-timesyncd[7519]: Timed out waiting for reply from 91.189.94.4:123 ([ntp.ubuntu.com](http://ntp.ubuntu.com)).May 14 05:10:24 pxc1 sudo[10216]: admin : TTY=pts/0 ; PWD=/home/admin ; USER=root ; COMMAND=/bin/bashMay 14 05:10:24 pxc1 sudo[10216]: pam\_unix(sudo:session): session opened for user root by admin(uid=0)May 14 05:11:27 pxc1 systemd[1]: Starting LSB: Start and stop the mysql (Percona XtraDB Cluster) daemon…-- Subject: Unit mysql.service has begun start-up-- Defined-By: systemd-- Support: [http://www.ubuntu.com/support----](http://www.ubuntu.com/support----) Unit mysql.service has begun starting up.May 14 05:11:27 pxc1 mysql[10240]:&nbsp; \* Starting MySQL (Percona XtraDB Cluster) database server mysqldMay 14 05:11:27 pxc1 /etc/init.d/mysql[10294]: MySQL PID not found, pid\_file detected/guessed: /var/run/mysqld/mysqld.pidMay 14 05:11:29 pxc1 mysql[10240]:&nbsp; &nbsp; …done.May 14 05:11:29 pxc1 systemd[1]: Started LSB: Start and stop the mysql (Percona XtraDB Cluster) daemon.-- Subject: Unit mysql.service has finished start-up-- Defined-By: systemd-- Support: [http://www.ubuntu.com/support----](http://www.ubuntu.com/support----) Unit mysql.service has finished starting up.
