# Graphs not loading after proxysql upgrade

**URL:** <https://forums.percona.com/t/graphs-not-loading-after-proxysql-upgrade/5582>\
**Category:** PMM 1.x\
**Created:** [May 4, 2017, 3:31pm UTC](https://forums.percona.com/t/graphs-not-loading-after-proxysql-upgrade/5582 "2017-05-04T15:31:09Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![Chanakya](https://avatars.discourse-cdn.com/v4/letter/c/cab0a1/32.png) [@Chanakya](https://forums.percona.com/u/Chanakya)\
**Post date:** [May 4, 2017, 3:31pm UTC](https://forums.percona.com/t/graphs-not-loading-after-proxysql-upgrade/5582/1 "2017-05-04T15:31:09Z")

</div>

Proxysql graphs are not loading after upgrading from 1.3.2 to 1.3.5. Here is the error from pmm logs on proxysql server:

level=error msg=“Error scraping for collect.mysql\_connection\_pool: Error 1045: no such column: Latency\_ms” source=“proxysql\_exporter.go:204”

PMM version: 1.1.3

 ![Proxysql_error.PNG](https://us1.discourse-cdn.com/flex019/uploads/percona1/original/2X/3/3f9f1cb2a51f208d73c680166abdb8669a9f2903.png)

---

<div class="post-metadata">

**Author:** ![Michael\_Coburn](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/michael_coburn/32/18_2.png) [@Michael\_Coburn](https://forums.percona.com/u/Michael_Coburn)\
**Post date:** [May 4, 2017, 3:48pm UTC](https://forums.percona.com/t/graphs-not-loading-after-proxysql-upgrade/5582/2 "2017-05-04T15:48:12Z")

</div>

Hi [Chanakya](https://percona.vanillacommunities.com/profile/x/x/37679) , thank you for reporting this issue. This is due to ProxySQL 1.3.5 changing the schema of the stats\_mysql\_connection\_pool table which caused PMM proxysql\_exporter to not be able to read any metrics back from ProxySQL. In our upcoming 1.1.4 release (targeting May 25, 2017) we have fixed this issue. In the meantime the workaround is to downgrade to ProxySQL \< 1.3.5 .

If you want to keep ProxySQL 1.3.5, you can optionally build the proxysql\_exporter from here:  
[url][https://github.com/michaelcoburn/proxysql\_exporter[/url]](https://github.com/michaelcoburn/proxysql_exporter%5B/url%5D)

Replace the binary:

```auto
sudo mv /usr/local/percona/pmm-client/proxysql_exporter /usr/local/percona/pmm-client/proxysql_exporter.orig
sudo mv ~/proxysql_exporter /usr/local/percona/pmm-client/
sudo chown root:root /usr/local/percona/pmm-client/proxysql_exporter
sudo chmod 755 /usr/local/percona/pmm-client/proxysql_exporter
sudo pmm-admin restart proxysql:metrics

```

And then update the Latency graph definition PromQL:

```auto
proxysql_connection_pool_latency_ms

```

to

```auto
proxysql_connection_pool_latency_us

```

I hope this helps,

---

<div class="post-metadata">

**Author:** ![Chanakya](https://avatars.discourse-cdn.com/v4/letter/c/cab0a1/32.png) [@Chanakya](https://forums.percona.com/u/Chanakya)\
**Post date:** [May 24, 2017, 1:36pm UTC](https://forums.percona.com/t/graphs-not-loading-after-proxysql-upgrade/5582/3 "2017-05-24T13:36:01Z")

</div>

Thanks for the info [Michael Coburn](https://percona.vanillacommunities.com/profile/x/x/22577)

---

<div class="post-metadata">

**Author:** ![Chanakya](https://avatars.discourse-cdn.com/v4/letter/c/cab0a1/32.png) [@Chanakya](https://forums.percona.com/u/Chanakya)\
**Post date:** [June 5, 2017, 2:07pm UTC](https://forums.percona.com/t/graphs-not-loading-after-proxysql-upgrade/5582/4 "2017-06-05T14:07:56Z")

</div>

Hi [Michael Coburn](https://percona.vanillacommunities.com/profile/x/x/22577) , I have upgraded to 1.1.4 but graphs are still the same. Please confirm if this is fixed in this release.

---

<div class="post-metadata">

**Author:** ![Mykola](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/mykola/32/30_2.png) [@Mykola](https://forums.percona.com/u/Mykola)\
**Post date:** [June 6, 2017, 11:04pm UTC](https://forums.percona.com/t/graphs-not-loading-after-proxysql-upgrade/5582/5 "2017-06-06T23:04:15Z")

</div>

Hi [Chanakya](https://percona.vanillacommunities.com/profile/x/x/37679),

Is pmm-client is also updated to 1.1.4? (not only PMM Server)

can you share versions of pmm-client, PMM Server, ProxySQL and OS?

---

<div class="post-metadata">

**Author:** ![Chanakya](https://avatars.discourse-cdn.com/v4/letter/c/cab0a1/32.png) [@Chanakya](https://forums.percona.com/u/Chanakya)\
**Post date:** [June 7, 2017, 4:16pm UTC](https://forums.percona.com/t/graphs-not-loading-after-proxysql-upgrade/5582/6 "2017-06-07T16:16:28Z")

</div>

Hi [Mykola](https://percona.vanillacommunities.com/profile/x/x/30783) ,

Graphs came back up after upgrading pmm-client except ‘latency’ graph.  
pmm-server: 1.1.4  
pmm-client: 1.1.4  
OS: Ubuntu 14.04
