# Grafana has failed to load

**URL:** <https://forums.percona.com/t/grafana-has-failed-to-load/13902>\
**Category:** Percona Monitoring and Management (PMM)\
**Created:** [January 13, 2022, 1:10pm UTC](https://forums.percona.com/t/grafana-has-failed-to-load/13902 "2022-01-13T13:10:38Z")\
**Posts on this page:** 20\
**Page:** 1

<div class="post-metadata">

**Author:** ![Jyoti\_Rajai](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/jyoti_rajai/32/4482_2.png) [@Jyoti\_Rajai](https://forums.percona.com/u/Jyoti_Rajai)\
**Post date:** [January 13, 2022, 1:10pm UTC](https://forums.percona.com/t/grafana-has-failed-to-load/13902/1 "2022-01-13T13:10:38Z")

</div>

Hi Team,

Greetings !

I am facing issue depicted in below snapshot frequently on PMM.

 ![Screenshot_2022-01-13_18-33-27](https://us1.discourse-cdn.com/flex019/uploads/percona1/original/2X/5/5c060c92869c954894abed12fcdb58fb4dc3f8e3.png)

Please guide me to fix this issue.

Thank you in advance.

Warm Regards,  
Jyoti Rajai

---

<div class="post-metadata">

**Author:** ![Jyoti\_Rajai](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/jyoti_rajai/32/4482_2.png) [@Jyoti\_Rajai](https://forums.percona.com/u/Jyoti_Rajai)\
**Post date:** [January 13, 2022, 1:12pm UTC](https://forums.percona.com/t/grafana-has-failed-to-load/13902/2 "2022-01-13T13:12:05Z")

</div>

FJYI : I have already tired solution provided on this link: [HTTP Error Bad Gateway when using prometheus · Issue #14629 · grafana/grafana · GitHub](https://github.com/grafana/grafana/issues/14629)

But nothing helps.

---

<div class="post-metadata">

**Author:** ![Naresh9999](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/naresh9999/32/5568_2.png) [@Naresh9999](https://forums.percona.com/u/Naresh9999)\
**Post date:** [January 13, 2022, 3:10pm UTC](https://forums.percona.com/t/grafana-has-failed-to-load/13902/3 "2022-01-13T15:10:36Z")

</div>

Hi @Jyoti_Rajai

What are the system requirements.?

1. Is CPU and RAM are doing good?
2. Check your internet, due to the internet slowness we may get this issue.
3. Did you restarted the pmm server?
4. Check the pmm2 server status weather it is healthy or not? docker ps -a

---

<div class="post-metadata">

**Author:** ![Vadim\_Yalovets](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/vadim_yalovets/32/43_2.png) [@Vadim\_Yalovets](https://forums.percona.com/u/Vadim_Yalovets)\
**Post date:** [January 14, 2022, 10:33am UTC](https://forums.percona.com/t/grafana-has-failed-to-load/13902/4 "2022-01-14T10:33:46Z")

</div>

Hi Jyoti,

Could you check if it’s enough disk space in the container?

---

<div class="post-metadata">

**Author:** ![Jyoti\_Rajai](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/jyoti_rajai/32/4482_2.png) [@Jyoti\_Rajai](https://forums.percona.com/u/Jyoti_Rajai)\
**Post date:** [January 15, 2022, 8:02am UTC](https://forums.percona.com/t/grafana-has-failed-to-load/13902/5 "2022-01-15T08:02:04Z")

</div>

> [@Naresh9999](#):
>
> What are the system requirements.?
> 
> 1. Is CPU and RAM are doing good? CPU - 8 core , 32GB RAM
> 2. Check your internet, due to the internet slowness we may get this issue. – No issue in internet
> 3. Did you restarted the pmm server? – Nope
> 4. Check the pmm2 server status weather it is healthy or not? docker ps -a – Healthy

docker ps -a  
CONTAINER ID IMAGE COMMAND CREATED STATUS PORTS NAMES  
0d3c3316ff30 percona/pmm-server:latest “/opt/entrypoint.sh” 3 weeks ago 3 weeks ago 0.0.0.0:80-\>80/tcp, 0.0.0.0:443-\>443/tcp pmm-server  
9fc459a9fdd6 percona/pmm-server:latest “/bin/true” 3 weeks ago pmm-data

---

<div class="post-metadata">

**Author:** ![Jyoti\_Rajai](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/jyoti_rajai/32/4482_2.png) [@Jyoti\_Rajai](https://forums.percona.com/u/Jyoti_Rajai)\
**Post date:** [January 15, 2022, 8:03am UTC](https://forums.percona.com/t/grafana-has-failed-to-load/13902/6 "2022-01-15T08:03:07Z")

</div>

Could you check if it’s enough disk space in the container? – Yeah, 400+gb free.

---

<div class="post-metadata">

**Author:** ![Naresh9999](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/naresh9999/32/5568_2.png) [@Naresh9999](https://forums.percona.com/u/Naresh9999)\
**Post date:** [January 15, 2022, 9:39am UTC](https://forums.percona.com/t/grafana-has-failed-to-load/13902/7 "2022-01-15T09:39:03Z")

</div>

Hi @Jyoti_Rajai

Seems everything looks good.  
Can you restart the PMM server and try once?

# docker stop 0d3c3316ff30

# docker stop 9fc459a9fdd6

# systemctl restart docker

---

<div class="post-metadata">

**Author:** ![Jyoti\_Rajai](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/jyoti_rajai/32/4482_2.png) [@Jyoti\_Rajai](https://forums.percona.com/u/Jyoti_Rajai)\
**Post date:** [January 15, 2022, 9:48am UTC](https://forums.percona.com/t/grafana-has-failed-to-load/13902/8 "2022-01-15T09:48:31Z")

</div>

docker stop 0d3c3316ff30  
0d3c3316ff30

docker stop 9fc459a9fdd6  
9fc459a9fdd6

systemctl restart docker  
docker ps -a  
CONTAINER ID IMAGE COMMAND CREATED STATUS PORTS NAMES  
0d3c3316ff30 percona/pmm-server:latest “/opt/entrypoint.sh” 3 weeks ago Up 9 seconds 0.0.0.0:80-\>80/tcp, 0.0.0.0:443-\>443/tcp pmm-server  
9fc459a9fdd6 percona/pmm-server:latest “/bin/true” 3 weeks ago pmm-data  
[root@testhodb4node3 ~]#

---

<div class="post-metadata">

**Author:** ![Jyoti\_Rajai](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/jyoti_rajai/32/4482_2.png) [@Jyoti\_Rajai](https://forums.percona.com/u/Jyoti_Rajai)\
**Post date:** [January 15, 2022, 9:49am UTC](https://forums.percona.com/t/grafana-has-failed-to-load/13902/9 "2022-01-15T09:49:15Z")

</div>

It didn’t helped.

Now, URL is giving below error :

# 500 Internal Server Error

nginx

---

<div class="post-metadata">

**Author:** ![Naresh9999](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/naresh9999/32/5568_2.png) [@Naresh9999](https://forums.percona.com/u/Naresh9999)\
**Post date:** [January 16, 2022, 2:41pm UTC](https://forums.percona.com/t/grafana-has-failed-to-load/13902/10 "2022-01-16T14:41:15Z")

</div>

Hi @Jyoti_Rajai

Can you please re-check the PMM serer status, weather it is healthy or not?

---

<div class="post-metadata">

**Author:** ![Jyoti\_Rajai](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/jyoti_rajai/32/4482_2.png) [@Jyoti\_Rajai](https://forums.percona.com/u/Jyoti_Rajai)\
**Post date:** [January 17, 2022, 5:42am UTC](https://forums.percona.com/t/grafana-has-failed-to-load/13902/12 "2022-01-17T05:42:40Z")

</div>

# 500 Internal Server Error

nginx

---

<div class="post-metadata">

**Author:** ![Naresh9999](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/naresh9999/32/5568_2.png) [@Naresh9999](https://forums.percona.com/u/Naresh9999)\
**Post date:** [January 17, 2022, 6:13am UTC](https://forums.percona.com/t/grafana-has-failed-to-load/13902/13 "2022-01-17T06:13:54Z")

</div>

Hi @Jyoti_Rajai

After restarting the PMM server, is it healthy or not?

# docker ps -a

and, can you try to clear the cache or try it in different browser?

---

<div class="post-metadata">

**Author:** ![Jyoti\_Rajai](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/jyoti_rajai/32/4482_2.png) [@Jyoti\_Rajai](https://forums.percona.com/u/Jyoti_Rajai)\
**Post date:** [January 17, 2022, 7:34am UTC](https://forums.percona.com/t/grafana-has-failed-to-load/13902/14 "2022-01-17T07:34:12Z")

</div>

> [@Naresh9999](#):
>
> and, can you try to clear the cache or try it in different browser?

Didn’t helped.

docker ps -a  
CONTAINER ID IMAGE COMMAND CREATED STATUS PORTS NAMES  
0d3c3316ff30 percona/pmm-server:latest “/opt/entrypoint.sh” 3 weeks ago Up 9 seconds 0.0.0.0:80-\>80/tcp, 0.0.0.0:443-\>443/tcp pmm-server  
9fc459a9fdd6 percona/pmm-server:latest “/bin/true” 3 weeks ago pmm-data

---

<div class="post-metadata">

**Author:** ![Naresh9999](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/naresh9999/32/5568_2.png) [@Naresh9999](https://forums.percona.com/u/Naresh9999)\
**Post date:** [January 17, 2022, 8:11am UTC](https://forums.percona.com/t/grafana-has-failed-to-load/13902/15 "2022-01-17T08:11:56Z")

</div>

Hi @Jyoti_Rajai

For me it is showing healthy, but for you its not showing anything either its health/unhealthy in the docker status.

 ![image](https://us1.discourse-cdn.com/flex019/uploads/percona1/original/2X/d/db60e9d1773387460d8582ed2b486bb68a847963.png)

and, can you please check the PMM server container log file.

docker logs --tail=100 be330f386f3f  
docker logs --tail=100

---

<div class="post-metadata">

**Author:** ![Jyoti\_Rajai](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/jyoti_rajai/32/4482_2.png) [@Jyoti\_Rajai](https://forums.percona.com/u/Jyoti_Rajai)\
**Post date:** [February 11, 2022, 11:00am UTC](https://forums.percona.com/t/grafana-has-failed-to-load/13902/16 "2022-02-11T11:00:30Z")

</div>

> [@Naresh9999](#):
>
> docker logs --tail=100

[root@testhodb4node3 ~]# docker logs --tail=20 f6b1ae985878  
2022-02-09 12:53:57,802 INFO exited: postgresql (exit status 1; not expected)  
2022-02-09 12:54:04,359 INFO spawned: ‘postgresql’ with pid 11516  
2022-02-09 12:54:04,372 INFO exited: postgresql (exit status 1; not expected)  
2022-02-09 12:54:11,803 INFO spawned: ‘postgresql’ with pid 11517  
2022-02-09 12:54:11,816 INFO exited: postgresql (exit status 1; not expected)  
2022-02-09 12:54:20,669 INFO spawned: ‘postgresql’ with pid 11518  
2022-02-09 12:54:20,680 INFO exited: postgresql (exit status 1; not expected)  
2022-02-09 12:54:29,819 INFO spawned: ‘postgresql’ with pid 11519  
2022-02-09 12:54:29,829 INFO exited: postgresql (exit status 1; not expected)  
2022-02-09 12:54:40,830 INFO spawned: ‘postgresql’ with pid 11520  
2022-02-09 12:54:40,840 INFO exited: postgresql (exit status 1; not expected)  
2022-02-09 12:54:41,830 INFO gave up: postgresql entered FATAL state, too many start retries too quickly  
2022-02-10 00:01:01,705 INFO reaped unknown pid 11722  
2022-02-10 01:01:01,735 INFO reaped unknown pid 11741  
2022-02-10 02:01:01,764 INFO reaped unknown pid 11760  
2022-02-10 03:32:01,806 INFO reaped unknown pid 11779  
2022-02-11 00:01:01,447 INFO reaped unknown pid 12178  
2022-02-11 01:01:01,476 INFO reaped unknown pid 12197  
2022-02-11 02:01:01,509 INFO reaped unknown pid 12216  
2022-02-11 03:33:01,549 INFO reaped unknown pid 12235

---

<div class="post-metadata">

**Author:** ![Naresh9999](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/naresh9999/32/5568_2.png) [@Naresh9999](https://forums.percona.com/u/Naresh9999)\
**Post date:** [February 11, 2022, 11:19am UTC](https://forums.percona.com/t/grafana-has-failed-to-load/13902/17 "2022-02-11T11:19:34Z")

</div>

Hi @Jyoti_Rajai

Seems postgresql DB has some issue, it did not start properly. Can you download the server Diagnostics and check the details. It may help this issue.

Can you stop the docker service and restart the Linux server node then try once.

 ![image](https://us1.discourse-cdn.com/flex019/uploads/percona1/original/2X/8/88f4bbef480d8b0916b1c99b51fc081d316a20cf.png)

---

<div class="post-metadata">

**Author:** ![Jyoti\_Rajai](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/jyoti_rajai/32/4482_2.png) [@Jyoti\_Rajai](https://forums.percona.com/u/Jyoti_Rajai)\
**Post date:** [February 11, 2022, 12:07pm UTC](https://forums.percona.com/t/grafana-has-failed-to-load/13902/18 "2022-02-11T12:07:57Z")

</div>

> [@Naresh9999](#):
>
> Seems postgresql DB has some issue, it did not start properly. Can you download the server Diagnostics and check the details. It may help this issue.

I am unable to load the page you shown in screenshot.

---

<div class="post-metadata">

**Author:** ![Naresh9999](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/naresh9999/32/5568_2.png) [@Naresh9999](https://forums.percona.com/u/Naresh9999)\
**Post date:** [February 12, 2022, 1:52pm UTC](https://forums.percona.com/t/grafana-has-failed-to-load/13902/19 "2022-02-12T13:52:07Z")

</div>

Hi @Jyoti_Rajai

Can you do the below steps ?

1. docker stop 

2. stop the docker service

3. Reboot the Linux server node then try once.?

---

<div class="post-metadata">

**Author:** ![Jyoti\_Rajai](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/jyoti_rajai/32/4482_2.png) [@Jyoti\_Rajai](https://forums.percona.com/u/Jyoti_Rajai)\
**Post date:** [February 16, 2022, 10:17am UTC](https://forums.percona.com/t/grafana-has-failed-to-load/13902/20 "2022-02-16T10:17:55Z")

</div>

Why to reboot linux server ? That doesn’t sounds proper.

Additionally, what i have found is the docker stores all data in memory instead of given path for volume.

---

<div class="post-metadata">

**Author:** ![alwaysdba](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/alwaysdba/32/17029_2.png) [@alwaysdba](https://forums.percona.com/u/alwaysdba)\
**Post date:** [April 18, 2022, 5:06pm UTC](https://forums.percona.com/t/grafana-has-failed-to-load/13902/21 "2022-04-18T17:06:04Z")

</div>

@Jyoti_Rajai I am also facing similar kind of issue. PMM server is working fine and but grafana is not showing up.

[Next page](https://forums.percona.com/t/grafana-has-failed-to-load/13902.md?page=2)
