# Getting issue where  join with any node when enable keyring plugin in  xtardb cluster 8.0 ?

**URL:** <https://forums.percona.com/t/getting-issue-where-join-with-any-node-when-enable-keyring-plugin-in-xtardb-cluster-8-0/7906>\
**Category:** Percona Server for MySQL 8.0\
**Created:** [August 14, 2020, 5:12am UTC](https://forums.percona.com/t/getting-issue-where-join-with-any-node-when-enable-keyring-plugin-in-xtardb-cluster-8-0/7906 "2020-08-14T05:12:40Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![lokesh123](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/lokesh123/32/5519_2.png) [@lokesh123](https://forums.percona.com/u/lokesh123)\
**Post date:** [August 14, 2020, 5:12am UTC](https://forums.percona.com/t/getting-issue-where-join-with-any-node-when-enable-keyring-plugin-in-xtardb-cluster-8-0/7906/1 "2020-08-14T05:12:40Z")

</div>

early-plugin-load=keyring\_file.sokeyring\_file\_data=/var/lib/mysql/keyring  
  
  
ew ((empty))2020-08-14T09:32:34.194153Z 0 [Note] [MY-000000] [Galera] gcomm: closed2020-08-14T09:32:34.194177Z 0 [Note] [MY-000000] [Galera] Member 0.0 (pxc-cluster-node-2) synced with group.2020-08-14T09:32:34.194192Z 0 [Note] [MY-000000] [Galera] New COMPONENT: primary = no, bootstrap = no, my\_idx = 0, memb\_num = 12020-08-14T09:32:34.194224Z 0 [Note] [MY-000000] [Galera] Flow-control interval: [100, 100]2020-08-14T09:32:34.194234Z 0 [Note] [MY-000000] [Galera] Received NON-PRIMARY.2020-08-14T09:32:34.194244Z 0 [Note] [MY-000000] [Galera] Shifting JOINER -\> OPEN (TO: 8)2020-08-14T09:32:34.194255Z 0 [Note] [MY-000000] [Galera] New SELF-LEAVE.2020-08-14T09:32:34.194270Z 0 [Note] [MY-000000] [Galera] Flow-control interval: [0, 0]2020-08-14T09:32:34.194279Z 0 [Note] [MY-000000] [Galera] Received SELF-LEAVE. Closing connection.2020-08-14T09:32:34.194289Z 0 [Note] [MY-000000] [Galera] Shifting OPEN -\> CLOSED (TO: -1)2020-08-14T09:32:34.194300Z 0 [Note] [MY-000000] [Galera] RECV thread exiting 0: Success2020-08-14T09:34:12.014179Z 0 [ERROR] [MY-000000] [WSREP-SST] \*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\* FATAL ERROR \*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*2020-08-14T09:34:12.014233Z 0 [ERROR] [MY-000000] [WSREP-SST] Possible timeout in receving first data from donor in gtid/keyring stage2020-08-14T09:34:12.014250Z 0 [ERROR] [MY-000000] [WSREP-SST] Line 11082020-08-14T09:34:12.014266Z 0 [ERROR] [MY-000000] [WSREP-SST] \*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*2020-08-14T09:34:12.014348Z 0 [ERROR] [MY-000000] [WSREP-SST] Cleanup after exit with status:322020-08-14T09:34:12.021357Z 0 [ERROR] [MY-000000] [WSREP] Process completed with error: wsrep\_sst\_xtrabackup-v2 --role ‘joiner’ --address ‘192.168.1.129’ --datadir ‘/var/lib/mysql/’ --basedir ‘/usr/’ --plugindir ‘/usr/lib64/mysql/plugin/’ --defaults-file ‘/etc/my.cnf’ --defaults-group-suffix ‘’ --parent ‘18402’ --mysqld-version ‘8.0.19-10’&nbsp; &nbsp;‘’ : 32 (Broken pipe)2020-08-14T09:34:12.021388Z 0 [ERROR] [MY-000000] [WSREP] Failed to read uuid:seqno from joiner script.2020-08-14T09:34:12.021402Z 0 [ERROR] [MY-000000] [WSREP] SST script aborted with error 32 (Broken pipe)2020-08-14T09:34:12.021474Z 3 [Note] [MY-000000] [Galera] Processing SST received2020-08-14T09:34:12.021496Z 3 [Note] [MY-000000] [Galera] SST received: 00000000-0000-0000-0000-000000000000:-12020-08-14T09:34:12.021518Z 3 [System] [MY-000000] [WSREP] SST completed2020-08-14T09:34:12.021549Z 2 [Note] [MY-000000] [Galera]&nbsp; str\_proto\_ver\_: 3 sst\_seqno\_: -1 cc\_seqno: 8 req-\>ist\_len(): 642020-08-14T09:34:12.021576Z 2 [ERROR] [MY-000000] [Galera] Application received wrong state:&nbsp; &nbsp; &nbsp; &nbsp; Received: 00000000-0000-0000-0000-000000000000&nbsp; &nbsp; &nbsp; &nbsp; Required: 8a0c2dfe-de0b-11ea-9075-7a0902ce80f12020-08-14T09:34:12.021593Z 2 [ERROR] [MY-000000] [Galera] Application state transfer failed. This is unrecoverable condition, restart required.2020-08-14T09:34:12.021610Z 2 [Note] [MY-000000] [Galera] ReplicatorSMM::abort()2020-08-14T09:34:12.021635Z 2 [Note] [MY-000000] [Galera] Closing send monitor…2020-08-14T09:34:12.021653Z 2 [Note] [MY-000000] [Galera] Closed send monitor.2020-08-14T09:34:12.021672Z 2 [Note] [MY-000000] [Galera] recv\_thread() joined.2020-08-14T09:34:12.021693Z 2 [Note] [MY-000000] [Galera] Closing replication queue.2020-08-14T09:34:12.021709Z 2 [Note] [MY-000000] [Galera] Closing slave action queue.2020-08-14T09:34:12.021723Z 2 [Note] [MY-000000] [Galera] /usr/sbin/mysqld: Terminated.2020-08-14T09:34:12.021733Z 2 [Note] [MY-000000] [WSREP] Initiating SST cancellation

---

<div class="post-metadata">

**Author:** ![jrivera](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/jrivera/32/13_2.png) [@jrivera](https://forums.percona.com/u/jrivera)\
**Post date:** [August 15, 2020, 5:33am UTC](https://forums.percona.com/t/getting-issue-where-join-with-any-node-when-enable-keyring-plugin-in-xtardb-cluster-8-0/7906/2 "2020-08-15T05:33:25Z")

</div>

Can you share full mysql config file? Did you configure SSL parameters or pxc\_encrypt\_cluster\_traffic and initially copied SSL certificates from bootstrapped node to joiner nodes?

---

<div class="post-metadata">

**Author:** ![lokesh123](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/lokesh123/32/5519_2.png) [@lokesh123](https://forums.percona.com/u/lokesh123)\
**Post date:** [August 15, 2020, 8:33am UTC](https://forums.percona.com/t/getting-issue-where-join-with-any-node-when-enable-keyring-plugin-in-xtardb-cluster-8-0/7906/3 "2020-08-15T08:33:33Z")

</div>

**[client]****socket=/var/lib/mysql/mysql.sock ****ssl-ca=/home/adminuser/srt/ca.pem**** ssl-key=/home/adminuser/srt/client-key.pem ****ssl-cert=/home/adminuser/srt/client-cert.pem**  
**[mysqld]****server-id=1 ****datadir=/var/lib/mysql**** socket=/var/lib/mysql/mysql.sock ****log-error=/var/log/mysqld.log**** pid-file=/var/run/mysqld/mysqld.pid ****# Binary log expiration period is 604800 seconds, which equals 7 days**  
**binlog\_expire\_logs\_seconds=604800**** ######## wsrep ###############**  
**# Path to Galera library**** wsrep\_provider=/usr/lib64/galera4/libgalera\_smm.so ****# Cluster connection URL contains IPs of nodes**  
**#If no IP is found, this implies that a new cluster needs to be created,**** #in order to do that you need to bootstrap this node ****wsrep\_cluster\_address=gcomm://192.168.1.129,192.168.1.157,192.168.1.164**** # In order for Galera to work correctly binlog format should be ROW**  
**binlog\_format=ROW**** # Slave thread to use**  
**wsrep\_slave\_threads=8**** wsrep\_log\_conflicts**  
**# This changes how InnoDB autoincrement locks are managed and is a requirement for Galera**  
**innodb\_autoinc\_lock\_mode=2**** # Node IP address**  
**wsrep\_node\_address=192.168.1.157**** # Cluster name ****wsrep\_cluster\_name=pxc-cluster**** #If wsrep\_node\_name is not specified,&nbsp; then system hostname will be used**  
**wsrep\_node\_name=pxc-cluster-node-2**** #pxc\_strict\_mode allowed values: DISABLED,PERMISSIVE,ENFORCING,MASTER**  
**pxc\_strict\_mode=ENFORCING**** wsrep\_sst\_method=xtrabackup-v2**  
**wsrep\_provider\_options=”socket.ssl\_key=/home/adminuser/srt/server-key.pem;socket.ssl\_cert=/home/adminuser/srt/server-cert.pem;socket.ssl\_ca=/home/adminuser/srt/ca.pem”**  
**[sst]**  
**encrypt=4**** ssl-key=/home/adminuser/srt/server-key.pem ****ssl-ca=/home/adminuser/srt/ca.pem**** ssl-cert=/home/adminuser/srt/server-cert.pem**

---

<div class="post-metadata">

**Author:** ![lokesh123](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/lokesh123/32/5519_2.png) [@lokesh123](https://forums.percona.com/u/lokesh123)\
**Post date:** [August 15, 2020, 3:48pm UTC](https://forums.percona.com/t/getting-issue-where-join-with-any-node-when-enable-keyring-plugin-in-xtardb-cluster-8-0/7906/4 "2020-08-15T15:48:30Z")

</div>

It resolved&nbsp;&nbsp;[jrivera](https://forums.percona.com/profile/jrivera "Link: https://forums.percona.com/profile/jrivera")&nbsp;Thankyou ,so much the issue was with&nbsp;pxc\_encrypt\_cluster\_traffic configuration.

---

<div class="post-metadata">

**Author:** ![jrivera](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/jrivera/32/13_2.png) [@jrivera](https://forums.percona.com/u/jrivera)\
**Post date:** [August 15, 2020, 10:11pm UTC](https://forums.percona.com/t/getting-issue-where-join-with-any-node-when-enable-keyring-plugin-in-xtardb-cluster-8-0/7906/5 "2020-08-15T22:11:07Z")

</div>

Glad that the suggestion worked!
