# Failure to bootstrap node in cluster

**URL:** <https://forums.percona.com/t/failure-to-bootstrap-node-in-cluster/29005>\
**Category:** Uncategorized\
**Created:** [March 7, 2024, 6:02am UTC](https://forums.percona.com/t/failure-to-bootstrap-node-in-cluster/29005 "2024-03-07T06:02:44Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Mathava\_Selvan](https://avatars.discourse-cdn.com/v4/letter/m/ee7513/32.png) [@Mathava\_Selvan](https://forums.percona.com/u/Mathava_Selvan)\
**Post date:** [March 7, 2024, 6:02am UTC](https://forums.percona.com/t/failure-to-bootstrap-node-in-cluster/29005/1 "2024-03-07T06:02:44Z")

</div>

2024-03-07T05:49:07.558915Z 0 [ERROR] WSREP: failed to open gcomm backend connection: 110: failed to reach primary view: 110 (Connection timed out)  
at gcomm/src/pc.cpp:connect():158  
2024-03-07T05:49:07.558943Z 0 [ERROR] WSREP: gcs/src/gcs\_core.cpp:gcs\_core\_open():208: Failed to open backend connection: -110 (Connection timed out)  
2024-03-07T05:49:07.559101Z 0 [ERROR] WSREP: gcs connect failed: Connection timed out

---

<div class="post-metadata">

**Author:** ![Uday\_Kumar\_Rajarapu](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/uday_kumar_rajarapu/32/11637_2.png) [@Uday\_Kumar\_Rajarapu](https://forums.percona.com/u/Uday_Kumar_Rajarapu)\
**Post date:** [March 7, 2024, 6:26am UTC](https://forums.percona.com/t/failure-to-bootstrap-node-in-cluster/29005/2 "2024-03-07T06:26:23Z")

</div>

@Mathava_Selvan HI Selvan… Welcome to the Percona Community.

As per the error log, I see "Connection timed out” is the main error. So, Check firewall connections, se-linux or other networking access.

Also, Please verify that the following ports are open: 3306, 4444, and 4567 which are required for MySQL and PXC cluster connections.

Finally make sure to keep your wsrep parameters / wsrep.cnf to use by PXC.

Refer for similar PXC errors [Getting error after configuration Percona Xtradb 8.0? - #13 by matthewb](https://forums.percona.com/t/getting-error-after-configuration-percona-xtradb-8-0/7894/13)

---

<div class="post-metadata">

**Author:** ![matthewb](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/matthewb/32/34_2.png) [@matthewb](https://forums.percona.com/u/matthewb)\
**Post date:** [March 7, 2024, 5:14pm UTC](https://forums.percona.com/t/failure-to-bootstrap-node-in-cluster/29005/3 "2024-03-07T17:14:54Z")

</div>

@Mathava_Selvan, please show us how you started this node. If this is the first node, did you bootstrap it? The error you showed indicates you did not bootstrap the node.

`systemctl start mysql@bootstrap`
