# Failure on start mysql clustered node

**URL:** <https://forums.percona.com/t/failure-on-start-mysql-clustered-node/3888>\
**Category:** Percona XtraDB Cluster 5.x\
**Created:** [November 17, 2014, 8:15am UTC](https://forums.percona.com/t/failure-on-start-mysql-clustered-node/3888 "2014-11-17T08:15:18Z")\
**Posts on this page:** 1\
**Page:** 1

<div class="post-metadata">

**Author:** ![immortal](https://avatars.discourse-cdn.com/v4/letter/i/f08c70/32.png) [@immortal](https://forums.percona.com/u/immortal)\
**Post date:** [November 17, 2014, 8:15am UTC](https://forums.percona.com/t/failure-on-start-mysql-clustered-node/3888/1 "2014-11-17T08:15:18Z")

</div>

Hi ,

We are having a problem starting mysql on a percona cluster service . The cluster has 4 nodes , 3 of them are running ok but the last one fail to start . Looking at mysql.err log file I can see :

141117 14:04:57 InnoDB: Error: table ‘XXXXXXXX/tmp\_ad\_zone\_impression’  
InnoDB: in InnoDB data dictionary has tablespace id 105964,  
InnoDB: but a tablespace with that id does not exist. There is  
InnoDB: a tablespace of name ./XXXXXXXX/tmp\_ad\_zone\_impression.ibd and id 105957, though. Have  
InnoDB: you deleted or moved .ibd files?  
InnoDB: Please refer to  
InnoDB: [url][http://dev.mysql.com/doc/refman/5.5/en/innodb-troubleshooting-datadict.html[/url]](http://dev.mysql.com/doc/refman/5.5/en/innodb-troubleshooting-datadict.html%5B/url%5D)  
InnoDB: for how to resolve the issue.  
141117 14:04:57 InnoDB: Error: table ‘YYYYYYYYY/\_cc\_tmp’  
InnoDB: in InnoDB data dictionary has tablespace id 105949,  
InnoDB: but a tablespace with that id does not exist. There is  
InnoDB: a tablespace of name ./YYYYYYYYY/\_cc\_tmp.ibd and id 105952, though. Have  
InnoDB: you deleted or moved .ibd files?  
InnoDB: Please refer to  
InnoDB: [url][http://dev.mysql.com/doc/refman/5.5/en/innodb-troubleshooting-datadict.html[/url]](http://dev.mysql.com/doc/refman/5.5/en/innodb-troubleshooting-datadict.html%5B/url%5D)  
InnoDB: for how to resolve the issue.  
141117 14:04:57 InnoDB: Waiting for the background threads to start  
141117 14:04:57 InnoDB: Unable to allocate memory of size 18446744073709544232.  
141117 14:04:57 InnoDB: Assertion failure in thread 139747344623360 in file mem0mem.c line 361  
InnoDB: We intentionally generate a memory trap.  
InnoDB: Submit a detailed bug report to [http://bugs.mysql.com](http://bugs.mysql.com).  
InnoDB: If you get repeated assertion failures or crashes, even  
InnoDB: immediately after the mysqld startup, there may be  
InnoDB: corruption in the InnoDB tablespace. Please refer to  
InnoDB: [url][http://dev.mysql.com/doc/refman/5.5/en/forcing-innodb-recovery.html[/url]](http://dev.mysql.com/doc/refman/5.5/en/forcing-innodb-recovery.html%5B/url%5D)

Looking at the url included at last line , I can see that starting mysql with the innodb\_force\_recovery = 1 option should be tried .  
(I was thinking of starting the mysql as a stand alone service , out of cluster of course) .

If this should not work , what would you recoment to get the server up and running ?

Thank you in advance,  
Nick
