Failed to upload alert panel image.

msg=“Failed to upload alert panel image.” logger=alerting.notifier error=“fork/exec /usr/share/grafana/tools/phantomjs/phantomjs: no such file or directory”

pmm version 1.12.0

[root@023b5832ae0f grafana]# ls
conf public scripts
[root@023b5832ae0f grafana]# pwd
/usr/share/grafana

Enter docker. I don’t see the tool directory.

I copied the missing files(phantomjs and render.js) from the pmm of my company’s 1.4 versions. Then I copied them to the current pmm. Now the alarm has a picture.
But why is this happening? No one has manually deleted this file.

Are you deploying via Docker? Do you see this problem occurring using today’s release of 1.13?

1.deploying via docker yes
2.still have the problem

t=2018-08-02T02:56:53+0000 lvl=info msg=Rendering logger=png-renderer path=“d-solo/LZrx7Qdiz/node008032gao-jing-ye-mian?panelId=97”
t=2018-08-02T02:56:53+0000 lvl=eror msg=“Could not start command” logger=png-renderer LOG15_ERROR= LOG15_ERROR=“Normalized odd number of arguments by adding nil”
t=2018-08-02T02:56:53+0000 lvl=eror msg=“Failed to upload alert panel image.” logger=alerting.notifier error=“fork/exec /usr/share/grafana/tools/phantomjs/phantomjs: no such file or directory”
t=2018-08-02T02:56:53+0000 lvl=info msg=“Sending alert notification to” logger=alerting.notifier.email addresses=[fanboshi@mafengwo.com]
^C
[root@9a80e0f8e9ee grafana]# head -1 /srv/update/main.yml

v1.13.0

[root@9a80e0f8e9ee grafana]# ls
conf public scripts

so? Is it a bug or something?

Has this bug been fixed in 1.14? @Michael Coburn

I have exactly the same issue.

Installed via Docker

PMM version: 1.14.1

Missing phantomjs executable

How is missing executable acceptable in a product?

Hi Fan , lao454490095

Let me see if we can get some QA attention on this thread. Please wait for further information, thanks for details provided so far

Hi Fan , lao454490095

We’ve done some investigation and it appears that PMM Server is missing the PhantomJS library, due to upstream Grafana issue. We’ve filed a PMM bug and we’ll get some developer eyes on it ASAP:
https://jira.percona.com/browse/PMM-3056

Thanks for reporting it !