# Failed to query events statement summary by digest select command denied to user

**URL:** <https://forums.percona.com/t/failed-to-query-events-statement-summary-by-digest-select-command-denied-to-user/23061>\
**Category:** Percona Monitoring and Management (PMM)\
**Tags:** pmm, mysql, percona\
**Created:** [June 23, 2023, 6:47am UTC](https://forums.percona.com/t/failed-to-query-events-statement-summary-by-digest-select-command-denied-to-user/23061 "2023-06-23T06:47:11Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![Arul\_Ferian\_Ramadlon](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/arul_ferian_ramadlon/32/11220_2.png) [@Arul\_Ferian\_Ramadlon](https://forums.percona.com/u/Arul_Ferian_Ramadlon)\
**Post date:** [June 23, 2023, 6:47am UTC](https://forums.percona.com/t/failed-to-query-events-statement-summary-by-digest-select-command-denied-to-user/23061/1 "2023-06-23T06:47:11Z")

</div>

Hello, i am getting error failed to query events\_statements\_summary\_by digest in systemctl status pmm-agent.

- perfschema is not running, QAN cant display the mysql query
- I accidentally closed port 3306 for security reason, (Is this also the cause of this problem?)

failed to query events\_statements\_summary\_by\_digest: Error 1142 (42000): SELECT command denied to user ‘pmm’@‘localhost’ for  
Jun 23 06:34:09 ip-172-31-24-93 pmm-agent[13257]: ERRO[2023-06-23T06:34:09.163+00:00] failed to query events\_statements\_summary\_by\_digest: Error 1142 (42000): SELECT command denied to user ‘pmm’@‘localhost’ for  
Jun 23 06:34:14 ip-172-31-24-93 pmm-agent[13257]: ERRO[2023-06-23T06:34:14.177+00:00] failed to query events\_statements\_summary\_by\_digest: Error 1142 (42000): SELECT command denied to user

 ![image](https://us1.discourse-cdn.com/flex019/uploads/percona1/original/2X/2/22daece75973a1f1a2765457f8ea00e3b372406b.png)

---

<div class="post-metadata">

**Author:** ![kedarpercona](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/kedarpercona/32/809_2.png) [@kedarpercona](https://forums.percona.com/u/kedarpercona)\
**Post date:** [June 23, 2023, 6:52am UTC](https://forums.percona.com/t/failed-to-query-events-statement-summary-by-digest-select-command-denied-to-user/23061/2 "2023-06-23T06:52:31Z")

</div>

Hi @Arul_Ferian_Ramadlon,

As the error here clearly hints for “access denied” errors, I’d like to know if you created users required and provided grants. If “pmm” is the user you wish to use.

Create users as follows and see if that helps:

> **[Percona Monitoring and Management - MySQL](https://docs.percona.com/percona-monitoring-and-management/setting-up/client/mysql.html#create-a-database-account-for-pmm)**
>
> How to set up PMM to monitor a MySQL or MySQL-based database instance.

Thanks,  
K

---

<div class="post-metadata">

**Author:** ![Arul\_Ferian\_Ramadlon](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/arul_ferian_ramadlon/32/11220_2.png) [@Arul\_Ferian\_Ramadlon](https://forums.percona.com/u/Arul_Ferian_Ramadlon)\
**Post date:** [June 23, 2023, 10:23am UTC](https://forums.percona.com/t/failed-to-query-events-statement-summary-by-digest-select-command-denied-to-user/23061/3 "2023-06-23T10:23:28Z")

</div>

Thanks @kedarpercona , Solved 😀
