# Failed to connect to MySQL server: DBI connect

**URL:** <https://forums.percona.com/t/failed-to-connect-to-mysql-server-dbi-connect/4036>\
**Category:** Percona XtraBackup\
**Created:** [February 2, 2015, 9:44am UTC](https://forums.percona.com/t/failed-to-connect-to-mysql-server-dbi-connect/4036 "2015-02-02T09:44:09Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![bsquared](https://avatars.discourse-cdn.com/v4/letter/b/b19c9b/32.png) [@bsquared](https://forums.percona.com/u/bsquared)\
**Post date:** [February 2, 2015, 9:44am UTC](https://forums.percona.com/t/failed-to-connect-to-mysql-server-dbi-connect/4036/1 "2015-02-02T09:44:09Z")

</div>

After upgrading to CentOS 6.6, our extrabackup backup has stopped working. When I attempt to run the backup off the command line, it fails with: “Access denied for user ‘mysql’@‘localhost’ (using password: NO) at /usr/bin/innobackupex line 2978”.

The complete command line and traceback is at: [http://pastebin.com/vEu7jMpR](http://pastebin.com/vEu7jMpR)

Here are a few notes about my setup:

# mysql --version

mysql Ver 14.14 Distrib 5.1.73, for redhat-linux-gnu (x86\_64) using readline 5.1

# uname -a

Linux hostname.domain.tld 2.6.32-504.8.1.el6.x86\_64 #1 SMP Wed Jan 28 21:11:36 UTC 2015 x86\_64 x86\_64 x86\_64 GNU/Linux

# cat /etc/redhat-release

CentOS release 6.6 (Final)

# yum list perl-DBD-MySQL

Loaded plugins: versionlock  
Installed Packages  
perl-DBD-MySQL.x86\_64 4.013-3.el6 @base

Thanks very much for your help.  
-bsquared

---

<div class="post-metadata">

**Author:** ![mirfan](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/mirfan/32/16890_2.png) [@mirfan](https://forums.percona.com/u/mirfan)\
**Post date:** [February 3, 2015, 6:09am UTC](https://forums.percona.com/t/failed-to-connect-to-mysql-server-dbi-connect/4036/2 "2015-02-03T06:09:56Z")

</div>

It’s access problem. Can you please try to connect from mysql user from CLI to check If it connects. Also, share the exact command you used to take backup.

---

<div class="post-metadata">

**Author:** ![bsquared](https://avatars.discourse-cdn.com/v4/letter/b/b19c9b/32.png) [@bsquared](https://forums.percona.com/u/bsquared)\
**Post date:** [February 3, 2015, 7:19am UTC](https://forums.percona.com/t/failed-to-connect-to-mysql-server-dbi-connect/4036/3 "2015-02-03T07:19:29Z")

</div>

Greetings, Mirfan,

I can log into the database as user ‘mysql’. The command line I’m using for the backup is:

Thanks very much for your help,  
-bsquared

---

<div class="post-metadata">

**Author:** ![bsquared](https://avatars.discourse-cdn.com/v4/letter/b/b19c9b/32.png) [@bsquared](https://forums.percona.com/u/bsquared)\
**Post date:** [February 3, 2015, 7:27am UTC](https://forums.percona.com/t/failed-to-connect-to-mysql-server-dbi-connect/4036/4 "2015-02-03T07:27:46Z")

</div>

Ahh! I found the answer. User ‘mysql’ did not have privileges on the database I wanted to back up.

Thanks very much,  
Bruce
