# errors when starting the 2nd node

**URL:** <https://forums.percona.com/t/errors-when-starting-the-2nd-node/3439>\
**Category:** Percona XtraDB Cluster 5.x\
**Created:** [May 1, 2014, 1:06pm UTC](https://forums.percona.com/t/errors-when-starting-the-2nd-node/3439 "2014-05-01T13:06:55Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![madaca](https://avatars.discourse-cdn.com/v4/letter/m/db5fbb/32.png) [@madaca](https://forums.percona.com/u/madaca)\
**Post date:** [May 1, 2014, 1:06pm UTC](https://forums.percona.com/t/errors-when-starting-the-2nd-node/3439/1 "2014-05-01T13:06:55Z")

</div>

I am evaluating percona cluster to see if we should use it, but I have getting the following errors when starting the 2nd node. Please help.

mysql.log  
140501 14:13:19 [Note] WSREP: New cluster view: global state: c9d04a44-d0be-11e3-b9da-ff3aecfc8ed9:23, view# 6: Primary, number of nodes: 2, my index: 0, protocol version 2  
140501 14:13:19 [Warning] WSREP: Gap in state sequence. Need state transfer.  
140501 14:13:21 [Note] WSREP: Running: ‘wsrep\_sst\_xtrabackup --role ‘joiner’ --address ‘dbsmyt03’ --auth ‘sst:secret’ --datadir ‘/var/lib/mysql/’ --defaults-file ‘/etc/my.cnf’ --parent ‘10144’’  
WSREP\_SST: [INFO] Streaming with tar (20140501 14:13:21.971)  
WSREP\_SST: [INFO] Using socat as streamer (20140501 14:13:21.972)  
WSREP\_SST: [INFO] Evaluating socat -u TCP-LISTEN:4444,reuseaddr stdio | tar xfi - --recursive-unlink -h; RC=( ${PIPESTATUS[@]} ) (20140501 14:13:21.979)  
socat: error while loading shared libraries: libreadline.so.5: cannot open shared object file: No such file or directory  
tar: This does not look like a tar archive  
tar: Exiting with failure status due to previous errors  
140501 14:13:32 [Note] WSREP: Prepared SST request: xtrabackup|dbsmyt03:4444/xtrabackup\_sst  
140501 14:13:32 [Note] WSREP: wsrep\_notify\_cmd is not defined, skipping notification.  
140501 14:13:32 [Note] WSREP: Assign initial position for certification: 23, protocol version: 2  
140501 14:13:32 [Warning] WSREP: Failed to prepare for incremental state transfer: Local state UUID (00000000-0000-0000-0000-000000000000) does not match group state UUID (c9d04a44-d0be-11e3-b9da-ff3aecfc8ed9): 1 (Operation not permitted)  
at galera/src/replicator\_str.cpp:prepare\_for\_IST():445. IST will be unavailable.  
140501 14:13:32 [Note] WSREP: Node 0 (dbsmyt03) requested state transfer from ‘_any_’. Selected 1 (dbsmyt01)(SYNCED) as donor.  
140501 14:13:32 [Note] WSREP: Shifting PRIMARY → JOINER (TO: 23)  
140501 14:13:32 [Note] WSREP: Requesting state transfer: success, donor: 1  
WSREP\_SST: [ERROR] Error while getting data from donor node: exit codes: 127 2 (20140501 14:13:32.226)  
WSREP\_SST: [ERROR] Cleanup after exit with status:32 (20140501 14:13:32.227)  
WSREP\_SST: [INFO] Removing the sst\_in\_progress file (20140501 14:13:32.228)  
140501 14:13:32 [ERROR] WSREP: Process completed with error: wsrep\_sst\_xtrabackup --role ‘joiner’ --address ‘dbsmyt03’ --auth ‘sst:secret’ --datadir ‘/var/lib/mysql/’ --defaults-file ‘/etc/my.cnf’ --parent ‘10144’: 32 (Broken pipe)  
140501 14:13:32 [ERROR] WSREP: Failed to read uuid:seqno from joiner script.  
140501 14:13:32 [ERROR] WSREP: SST failed: 32 (Broken pipe)  
140501 14:13:32 [ERROR] Aborting

140501 14:13:32 [Warning] WSREP: 1 (dbsmyt01): State transfer to 0 (dbsmyt03) failed: -1 (Operation not permitted)  
140501 14:13:32 [ERROR] WSREP: gcs/src/gcs\_group.c:gcs\_group\_handle\_join\_msg():719: Will never receive state. Need to abort.  
140501 14:13:32 [Note] WSREP: gcomm: terminating thread  
140501 14:13:32 [Note] WSREP: gcomm: joining thread  
140501 14:13:32 [Note] WSREP: gcomm: closing backend  
140501 14:13:33 [Note] WSREP: view(view\_id(NON\_PRIM,461454d0-d15c-11e3-9324-37342298a57d,6) memb {  
461454d0-d15c-11e3-9324-37342298a57d,  
} joined {  
} left {  
} partitioned {  
bed5f1c5-d15b-11e3-8e95-0e9dd5f855e1,  
})  
140501 14:13:33 [Note] WSREP: view((empty))  
140501 14:13:33 [Note] WSREP: gcomm: closed  
140501 14:13:33 [Note] WSREP: /usr/sbin/mysqld: Terminated.  
140501 14:13:33 mysqld\_safe mysqld from pid file /var/lib/mysql/mysql.pid ended

---

<div class="post-metadata">

**Author:** ![mirfan](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/mirfan/32/16890_2.png) [@mirfan](https://forums.percona.com/u/mirfan)\
**Post date:** [May 4, 2014, 3:58pm UTC](https://forums.percona.com/t/errors-when-starting-the-2nd-node/3439/2 "2014-05-04T15:58:57Z")

</div>

> > WSREP\_SST: [INFO] Evaluating socat -u TCP-LISTEN:4444,reuseaddr stdio | tar xfi - --recursive-unlink -h; RC=( ${PIPESTATUS[@]} ) (20140501 14:13:21.979)  
> > socat: error while loading shared libraries: libreadline.so.5: cannot open shared object file: No such file or directory  
> > tar: This does not look like a tar archive

Look likes netcat is not installed which is required for streaming backups. [http://www.percona.com/doc/percona-xtrabackup/2.1/howtos/recipes\_ibkx\_stream.html](http://www.percona.com/doc/percona-xtrabackup/2.1/howtos/recipes_ibkx_stream.html)  
$ sudo yum install netcat (RHEL/CentOS)  
$ sudo aptitude install netcat (Ubuntu/Debian)

After installing netcat, retry starting node2.

---

<div class="post-metadata">

**Author:** ![madaca](https://avatars.discourse-cdn.com/v4/letter/m/db5fbb/32.png) [@madaca](https://forums.percona.com/u/madaca)\
**Post date:** [May 6, 2014, 8:33am UTC](https://forums.percona.com/t/errors-when-starting-the-2nd-node/3439/3 "2014-05-06T08:33:20Z")

</div>

Hi mifan,  
Is netcat same as nc? I installed that and it didn’t help. I also changed the wsrep\_sst\_method from xtrabackup to rsync, but still having problem starting the 2nd node.  
Thanks,  
Manny
