# errors in the log file

**URL:** https://forums.percona.com/t/errors-in-the-log-file/3327
**Category:** Percona Server for MySQL 5.6
**Created:** [March 10, 2014, 11:00pm UTC](https://forums.percona.com/t/errors-in-the-log-file/3327 "2014-03-10T23:00:12Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![manjulaseneviratne](https://avatars.discourse-cdn.com/v4/letter/m/f14d63/32.png) [@manjulaseneviratne](https://forums.percona.com/u/manjulaseneviratne)
#### Post date: [March 10, 2014, 11:00pm UTC](https://forums.percona.com/t/errors-in-the-log-file/3327/1 "2014-03-10T23:00:12Z")

</div>

Hi All,

I am getting below errors from my Percona 5.6 64bit database. Could you please help me to understand those and take some corrective steps to our come those errors. If you would like have complete error log to analyze that also I can provide it.

Your expert advice is highly appreciated.

Thanks,  
Manjula

2014-03-06 12:37:51 12496 [Note] InnoDB: Database was not shutdown normally!  
2014-03-06 12:37:51 12496 [Note] InnoDB: Starting crash recovery.  
2014-03-06 12:37:51 12496 [Note] InnoDB: Reading tablespace information from the .ibd files…  
2014-03-06 12:37:52 12496 [Note] InnoDB: Restoring possible half-written data pages  
2014-03-06 12:37:52 12496 [Note] InnoDB: from the doublewrite buffer…  
InnoDB: Doing recovery: scanned up to log sequence number 13298995712  
InnoDB: Doing recovery: scanned up to log sequence number 13304238592  
InnoDB: Doing recovery: scanned up to log sequence number 13304945179  
2014-03-06 12:37:53 12496 [Note] InnoDB: Starting an apply batch of log records to the database…  
InnoDB: Progress in percent: 0 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49  
50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99  
InnoDB: Apply batch completed

* * *

2014-03-01 15:19:54 6784 [ERROR] Incorrect definition of table mysql.proc: expected column ‘comment’ at position 15 to have type text, found type char(64).

04:37:51 UTC - mysqld got signal 11 ;  
This could be because you hit a bug. It is also possible that this binary  
or one of the libraries it was linked against is corrupt, improperly built,  
or misconfigured. This error can also be caused by malfunctioning hardware.  
We will try our best to scrape up some info that will hopefully help  
diagnose the problem, but since we have already crashed,  
something is definitely wrong and this may fail.  
Please help us make Percona Server better by reporting any  
bugs at [URL][System Dashboard - Percona JIRA](http://bugs.percona.com/%5B/URL%5D)

* * *

Thread pointer: 0x9e3a670  
Attempting backtrace. You can use the following information to find out  
where mysqld died. If you see no messages after this, something went  
terribly wrong…  
stack\_bottom = 7f0cd655cd48 thread\_stack 0x40000  
/usr/sbin/mysqld(my\_print\_stacktrace+0x35)[0x8e0425]  
/usr/sbin/mysqld(handle\_fatal\_signal+0x4c4)[0x666b94]  
/lib64/libpthread.so.0[0x341c00f710]  
/usr/sbin/mysqld(\_Z9get\_fieldP11st\_mem\_rootP5Field+0x46)[0x77a6d6]  
/usr/sbin/mysqld[0x6812b4]  
/usr/sbin/mysqld(\_Z11mysql\_grantP3THDPKcR4ListI11st\_lex\_userEmbb+0x551)[0x68e991]  
/usr/sbin/mysqld(\_Z21mysql\_execute\_commandP3THD+0x4ac8)[0x6eac68]  
/usr/sbin/mysqld(\_Z11mysql\_parseP3THDPcjP12Parser\_state+0x608)[0x6eb6e8]  
/usr/sbin/mysqld(\_Z16dispatch\_command19enum\_server\_commandP3THDPcj+0x146f)[0x6ecbbf]  
/usr/sbin/mysqld(\_Z24do\_handle\_one\_connectionP3THD+0x16f)[0x6b9b0f]  
/usr/sbin/mysqld(handle\_one\_connection+0x47)[0x6b9be7]  
/usr/sbin/mysqld(pfs\_spawn\_thread+0x12a)[0x91d9ca]  
/lib64/libpthread.so.0[0x341c0079d1]  
/lib64/libc.so.6(clone+0x6d)[0x341bce8b6d]

Trying to get some variables.  
Some pointers may be invalid and cause the dump to abort.  
Query (7f0c84009ae0): is an invalid pointer  
Connection ID (thread ID): 396936  
Status: NOT\_KILLED

* * *

2013-12-10 03:10:16 4224 [Note] Plugin ‘FEDERATED’ is disabled.  
2013-12-10 03:10:16 4224 [Note] InnoDB: The InnoDB memory heap is disabled  
2013-12-10 03:10:16 4224 [Note] InnoDB: Mutexes and rw\_locks use GCC atomic builtins  
2013-12-10 03:10:16 4224 [Note] InnoDB: Compressed tables use zlib 1.2.3  
2013-12-10 03:10:16 4224 [Note] InnoDB: Using Linux native AIO  
2013-12-10 03:10:16 4224 [Note] InnoDB: Using CPU crc32 instructions  
2013-12-10 03:10:16 4224 [Note] InnoDB: Initializing buffer pool, size = 4.0G  
2013-12-10 03:10:17 4224 [Note] InnoDB: Completed initialization of buffer pool  
2013-12-10 03:10:17 4224 [Note] InnoDB: Highest supported file format is Barracuda.  
2013-12-10 03:10:17 4224 [Note] InnoDB: 128 rollback segment(s) are active.  
2013-12-10 03:10:17 4224 [Note] InnoDB: Waiting for purge to start  
2013-12-10 03:10:17 4224 [Note] InnoDB: Percona XtraDB ([http://www.percona.com](http://www.percona.com)) 5.6.14-rel62.0 started; log sequence number 1626154  
2013-12-10 03:10:17 4224 [Note] RSA private key file not found: /var/lib/mysql//private\_key.pem. Some authentication plugins will not work.  
2013-12-10 03:10:17 4224 [Note] RSA public key file not found: /var/lib/mysql//public\_key.pem. Some authentication plugins will not work.

---

<div class="post-metadata">

### Author: ![jagatveer](https://avatars.discourse-cdn.com/v4/letter/j/e36b37/32.png) [@jagatveer](https://forums.percona.com/u/jagatveer)
#### Post date: [March 11, 2014, 5:58am UTC](https://forums.percona.com/t/errors-in-the-log-file/3327/2 "2014-03-11T05:58:33Z")

</div>

I would first need the idea on any changes you might have made on your Percona installation, which caused this issue for you.

---

<div class="post-metadata">

### Author: ![niljoshi](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/niljoshi/32/16889_2.png) [@niljoshi](https://forums.percona.com/u/niljoshi)
#### Post date: [March 13, 2014, 1:51am UTC](https://forums.percona.com/t/errors-in-the-log-file/3327/3 "2014-03-13T01:51:22Z")

</div>

Hi,

Have you recently upgrade Percona Server? This kind of error related to MySQL tables should be resolved by running mysql\_upgrade. Run it and then start server.  
[COLOR=#252C2F]2014-03-01 15:19:54 6784 [ERROR] Incorrect definition of table mysql.proc: expected column ‘comment’ at position 15 to have type text, found type char(64).

---

<div class="post-metadata">

### Author: ![manjulaseneviratne](https://avatars.discourse-cdn.com/v4/letter/m/f14d63/32.png) [@manjulaseneviratne](https://forums.percona.com/u/manjulaseneviratne)
#### Post date: [December 21, 2015, 2:54am UTC](https://forums.percona.com/t/errors-in-the-log-file/3327/4 "2015-12-21T02:54:10Z")

</div>

This is sorted out Joshi … thanks for the update … but I have post new concern appreciate if you could help me on that because no one replied yet.
