# error with innobackupex-1.5.1

**URL:** <https://forums.percona.com/t/error-with-innobackupex-1-5-1/2150>\
**Category:** Percona XtraBackup\
**Created:** [May 26, 2011, 10:27pm UTC](https://forums.percona.com/t/error-with-innobackupex-1-5-1/2150 "2011-05-26T22:27:27Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![rj03hou](https://avatars.discourse-cdn.com/v4/letter/r/51bf81/32.png) [@rj03hou](https://forums.percona.com/u/rj03hou)\
**Post date:** [May 26, 2011, 10:27pm UTC](https://forums.percona.com/t/error-with-innobackupex-1-5-1/2150/1 "2011-05-26T22:27:27Z")

</div>

my script is:  
ssh -o “StrictHostKeyChecking no” host1 ‘innobackupex-1.5.1 --stream=tar --throttle=500 --socket=/data/var/mysql.sock --defaults-file=/root/my.cnf --user=root --password= --slave-info /data/ | nc 10.3.23.55 80’ \< /dev/null \> /data/xtrabackup.log 2\>&1  
the error is:  
innobackupex-1.5.1: Created backup directory /data  
innobackupex-1.5.1: Error: Failed to stream ‘backup-my.cnf’: Inappropriate ioctl for device at /usr/bin/innobackupex-1.5.1 line 542.

sometimes it is right,sometimes this meet this error.  
thank you.

---

<div class="post-metadata">

**Author:** ![xaprb](https://avatars.discourse-cdn.com/v4/letter/x/49beb7/32.png) [@xaprb](https://forums.percona.com/u/xaprb)\
**Post date:** [May 30, 2011, 5:26am UTC](https://forums.percona.com/t/error-with-innobackupex-1-5-1/2150/2 "2011-05-30T05:26:57Z")

</div>

Please file a bug at Launchpad in the percona-xtrabackup project.

---

<div class="post-metadata">

**Author:** ![remi](https://avatars.discourse-cdn.com/v4/letter/r/ed8c4c/32.png) [@remi](https://forums.percona.com/u/remi)\
**Post date:** [June 24, 2011, 8:10am UTC](https://forums.percona.com/t/error-with-innobackupex-1-5-1/2150/3 "2011-06-24T08:10:27Z")

</div>

It looks like this is due to permission problems regarding the destination where innobackupex will write. It solved the problem for me at least running the script in sudo.
