# Error when preparing a full backup

**URL:** <https://forums.percona.com/t/error-when-preparing-a-full-backup/5015>\
**Category:** Percona XtraBackup\
**Created:** [August 3, 2016, 9:59am UTC](https://forums.percona.com/t/error-when-preparing-a-full-backup/5015 "2016-08-03T09:59:07Z")\
**Posts on this page:** 1\
**Page:** 1

<div class="post-metadata">

**Author:** ![Shady](https://avatars.discourse-cdn.com/v4/letter/s/6de8d8/32.png) [@Shady](https://forums.percona.com/u/Shady)\
**Post date:** [August 3, 2016, 9:59am UTC](https://forums.percona.com/t/error-when-preparing-a-full-backup/5015/1 "2016-08-03T09:59:07Z")

</div>

Hello,

A while ago my provider had a power outage which caused a mysql corruption here is what I did to fix it:  
-I was able to start mysql using innodb\_force\_recovery = 2 or 3 can’t really remember  
-I moved my table files somewhere else and deleted all content inside mysql folder  
-I started Mysql service and it create ibdata1 file etc…  
-I then copied back the tables files and I was able to start mysql with innodb\_force\_recovery = 0 and everything seems to be normal.

Today I tried to take a backup of my Database using innobackupex, and it seems to be working as it returned the following  
innobackupex: Connection to database server closed  
innobackupex: completed OK!

However when I tried to prepare the backup that I just took, I got the following error: (using the command innobackupex --apply-log /data/backname/

160803 11:24:28 innobackupex: Starting ibbackup with command: xtrabackup\_56 --defaults-file=“/data/2016-08-03\_11-22-40/backup-my.cnf” --defaults-group=“mysqld” --prepare --target-dir=/data/2016-08-03\_11-22-40 --tmpdir=/tmp

xtrabackup\_56 version 2.1.9 for MySQL server 5.6.17 Linux (i686) (revision id: 746)  
xtrabackup: cd to /data/2016-08-03\_11-22-40  
xtrabackup: This target seems to be not prepared yet.  
xtrabackup: xtrabackup\_logfile detected: size=2097152, start\_lsn=(1369520463)  
xtrabackup: using the following InnoDB configuration for recovery:  
xtrabackup: innodb\_data\_home\_dir = ./  
xtrabackup: innodb\_data\_file\_path = ibdata1:10M:autoextend  
xtrabackup: innodb\_log\_group\_home\_dir = ./  
xtrabackup: innodb\_log\_files\_in\_group = 1  
xtrabackup: innodb\_log\_file\_size = 2097152  
xtrabackup: using the following InnoDB configuration for recovery:  
xtrabackup: innodb\_data\_home\_dir = ./  
xtrabackup: innodb\_data\_file\_path = ibdata1:10M:autoextend  
xtrabackup: innodb\_log\_group\_home\_dir = ./  
xtrabackup: innodb\_log\_files\_in\_group = 1  
xtrabackup: innodb\_log\_file\_size = 2097152  
xtrabackup: Starting InnoDB instance for recovery.  
xtrabackup: Using 104857600 bytes for buffer pool (set by --use-memory parameter)  
InnoDB: Using atomics to ref count buffer pool pages  
InnoDB: The InnoDB memory heap is disabled  
InnoDB: Mutexes and rw\_locks use GCC atomic builtins  
InnoDB: Compressed tables use zlib 1.2.3  
InnoDB: Not using CPU crc32 instructions  
InnoDB: Initializing buffer pool, size = 100.0M  
InnoDB: Completed initialization of buffer pool  
InnoDB: Highest supported file format is Barracuda.  
InnoDB: Log scan progressed past the checkpoint lsn 1369520463  
InnoDB: Database was not shutdown normally!  
InnoDB: Starting crash recovery.  
InnoDB: Reading tablespace information from the .ibd files…  
InnoDB: Restoring possible half-written data pages  
InnoDB: from the doublewrite buffer…  
InnoDB: Doing recovery: scanned up to log sequence number 1369523291 (0%)  
InnoDB: Starting an apply batch of log records to the database…  
InnoDB: Progress in percent: 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 2016-08-03 11:24:28 ad7dfb70 InnoDB: Assertion failure in thread 2910714736 in file log0recv.cc line 1271  
InnoDB: Failing assertion: !page || (ibool)!!page\_is\_comp(page) == dict\_table\_is\_comp(index-\>table)  
InnoDB: We intentionally generate a memory trap.  
InnoDB: Submit a detailed bug report to [http://bugs.mysql.com](http://bugs.mysql.com).  
InnoDB: If you get repeated assertion failures or crashes, even  
InnoDB: immediately after the mysqld startup, there may be  
InnoDB: corruption in the InnoDB tablespace. Please refer to  
InnoDB: [url][http://dev.mysql.com/doc/refman/5.6/en/forcing-innodb-recovery.html[/url]](http://dev.mysql.com/doc/refman/5.6/en/forcing-innodb-recovery.html%5B/url%5D)  
InnoDB: about forcing recovery.  
innobackupex: Error:  
innobackupex: ibbackup failed at /usr/bin/innobackupex line 2560.

Any idea how can I fix this issue?

Thank you
