# Error when MYSQL different version node join Cluster

**URL:** <https://forums.percona.com/t/error-when-mysql-different-version-node-join-cluster/32656>\
**Category:** Percona XtraDB Cluster 5.x\
**Created:** [August 28, 2024, 3:20pm UTC](https://forums.percona.com/t/error-when-mysql-different-version-node-join-cluster/32656 "2024-08-28T15:20:29Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![Omer\_Faruk\_Icen](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/omer_faruk_icen/32/17641_2.png) [@Omer\_Faruk\_Icen](https://forums.percona.com/u/Omer_Faruk_Icen)\
**Post date:** [August 28, 2024, 3:20pm UTC](https://forums.percona.com/t/error-when-mysql-different-version-node-join-cluster/32656/1 "2024-08-28T15:20:29Z")

</div>

We use multi master with percona cluster  
Nodes: Node1-Node2-Node3  
version: MYSQL 5.7.40-43  
Then Node4 join cluster:  
Node4 MySQL Version : 5.7.44-48

Then Node4 Join with user login error:  
native table ‘performance\_schema’.‘session\_variables’ has the wrong structure

How to resolve this problem without another node upgrade?

Thank you

---

<div class="post-metadata">

**Author:** ![matthewb](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/matthewb/32/34_2.png) [@matthewb](https://forums.percona.com/u/matthewb)\
**Post date:** [August 28, 2024, 6:55pm UTC](https://forums.percona.com/t/error-when-mysql-different-version-node-join-cluster/32656/2 "2024-08-28T18:55:21Z")

</div>

You need to run mysql\_upgrade from percona-xtradb-cluster because PXC requires a larger session\_variables column.

---

<div class="post-metadata">

**Author:** ![Omer\_Faruk\_Icen](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/omer_faruk_icen/32/17641_2.png) [@Omer\_Faruk\_Icen](https://forums.percona.com/u/Omer_Faruk_Icen)\
**Post date:** [September 2, 2024, 6:43am UTC](https://forums.percona.com/t/error-when-mysql-different-version-node-join-cluster/32656/3 "2024-09-02T06:43:04Z")

</div>

We have decided to downgrade the Percona MySQL version, so we want to set up a new machine. We have downloaded the packages from external sources, but there are missing dependencies. How can we properly install it? or git project → downgrade for instance

> <https://gist.github.com/acip/43ddf3d672beac7ae22b122cd613d476>

---

<div class="post-metadata">

**Author:** ![matthewb](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/matthewb/32/34_2.png) [@matthewb](https://forums.percona.com/u/matthewb)\
**Post date:** [September 2, 2024, 9:12pm UTC](https://forums.percona.com/t/error-when-mysql-different-version-node-join-cluster/32656/4 "2024-09-02T21:12:44Z")

</div>

You should use our repo manager for maximum compatibility and auto-resolve of any dependencies. [Install percona-release - Percona Software Repositories](https://docs.percona.com/percona-software-repositories/installing.html)

---

<div class="post-metadata">

**Author:** ![Omer\_Faruk\_Icen](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/omer_faruk_icen/32/17641_2.png) [@Omer\_Faruk\_Icen](https://forums.percona.com/u/Omer_Faruk_Icen)\
**Post date:** [September 5, 2024, 7:18pm UTC](https://forums.percona.com/t/error-when-mysql-different-version-node-join-cluster/32656/5 "2024-09-05T19:18:42Z")

</div>

"Yes, running `mysql_upgrade` solved our problem. Thank you!

> **[Percona XtraDB Cluster - Upgrading Percona XtraDB Cluster](https://docs.percona.com/percona-xtradb-cluster/5.7/howtos/upgrade_guide.html)**
>
> This guide describes the procedure for upgrading Percona XtraDB Cluster without downtime
> (rolling upgrade) to the latest 5.7 version. A “rolling upgrade” means
> there is no need to take down the complete cluster during the upgrade.
