# Error The server quit without updating PID file

**URL:** <https://forums.percona.com/t/error-the-server-quit-without-updating-pid-file/3925>\
**Category:** Percona XtraDB Cluster 5.x\
**Created:** [December 2, 2014, 9:59am UTC](https://forums.percona.com/t/error-the-server-quit-without-updating-pid-file/3925 "2014-12-02T09:59:14Z")\
**Posts on this page:** 14\
**Page:** 1

<div class="post-metadata">

**Author:** ![ManuelRighi](https://avatars.discourse-cdn.com/v4/letter/m/db5fbb/32.png) [@ManuelRighi](https://forums.percona.com/u/ManuelRighi)\
**Post date:** [December 2, 2014, 9:59am UTC](https://forums.percona.com/t/error-the-server-quit-without-updating-pid-file/3925/1 "2014-12-02T09:59:14Z")

</div>

Hello,  
I have Percona XtraDB Cluster 5.6 with Ubuntu Server 14.04.1 LTS.  
I have 3 nodes. Everything worked perfectly for 5 months  
Today I find all 3 nodes with mysql server stopped.  
When I try to start mysql service I receive this error:

- Starting MySQL (Percona XtraDB Cluster) database server mysqld
- The server quit without updating PID file (/var/run/mysqld/mysqld.pid).

This error occour on all nodes.  
Can you help me ?

My my.cnf file have this configuration:

# 

# MySQL Configuration

# 

[mysql]

# CLIENT

port = 3306  
socket = /var/run/mysqld/mysqld.sock

[mysqld]

# GENERAL

user = mysql  
default\_storage\_engine = InnoDB  
socket = /var/run/mysqld/mysqld.sock  
pid-file = /var/run/mysqld/mysqld.pid  
bind-address = 0.0.0.0

# MyISAM

key-buffer-size = 32M  
myisam-recover = FORCE,BACKUP

# SAFETY

max-allowed-packet = 16M  
max-connect-errors = 1000000

# DATA STORAGE

#basedir = /usr  
datadir = /var/lib/mysql  
#tmpdir = /tmp

# BINARY LOGGING

log-bin = /var/lib/mysql/mysql-bin  
expire-logs-days = 3  
sync-binlog = 1

# CACHES AND LIMITS

tmp-table-size = 32M  
max-heap-table-size = 32M  
query-cache-type = 0  
query-cache-size = 0  
max-connections = 500  
thread-cache-size = 50  
open-files-limit = 65535  
table-definition-cache = 4096  
table-open-cache = 4096

# INNODB

innodb-flush-method = O\_DIRECT  
innodb-log-files-in-group = 2  
innodb-log-file-size = 256M  
innodb-flush-log-at-trx-commit = 1  
innodb-file-per-table = 1  
innodb-buffer-pool-size = 2G

# LOGGING

log-error = /var/lib/mysql/mysql-error.log  
log-queries-not-using-indexes = 1  
slow-query-log = 1  
slow-query-log-file = /var/lib/mysql/mysql-slow.log

# Percona XtraDB Cluster Settings

wsrep\_provider = /usr/lib/libgalera\_smm.so  
wsrep\_cluster\_address = gcomm://10.11.20.78,10.11.20.79,10.11.20.80  
binlog\_format = ROW  
wsrep\_node\_address = 10.12.20.80  
wsrep\_sst\_method = xtrabackup-v2  
wsrep\_cluster\_name = cluster-mysql  
wsrep\_sst\_auth = “xxxxx”

!includedir /etc/mysql/conf.d/

Tnx  
Manuel

---

<div class="post-metadata">

**Author:** ![jith](https://avatars.discourse-cdn.com/v4/letter/j/ce73a5/32.png) [@jith](https://forums.percona.com/u/jith)\
**Post date:** [December 2, 2014, 1:04pm UTC](https://forums.percona.com/t/error-the-server-quit-without-updating-pid-file/3925/2 "2014-12-02T13:04:51Z")

</div>

This is the same error I get since I installed Percona XtraDB cluster and looking for some useful tips!

---

<div class="post-metadata">

**Author:** ![ManuelRighi](https://avatars.discourse-cdn.com/v4/letter/m/db5fbb/32.png) [@ManuelRighi](https://forums.percona.com/u/ManuelRighi)\
**Post date:** [December 2, 2014, 2:03pm UTC](https://forums.percona.com/t/error-the-server-quit-without-updating-pid-file/3925/3 "2014-12-02T14:03:29Z")

</div>

I move my.cnf to another directory and mysql service start succesfully, but without my configuration, optimization and cluster 😑  
With my.cnf (which worked perfectly for 5 months), mysql not start ☹

Manuel

---

<div class="post-metadata">

**Author:** ![ManuelRighi](https://avatars.discourse-cdn.com/v4/letter/m/db5fbb/32.png) [@ManuelRighi](https://forums.percona.com/u/ManuelRighi)\
**Post date:** [December 6, 2014, 10:10am UTC](https://forums.percona.com/t/error-the-server-quit-without-updating-pid-file/3925/4 "2014-12-06T10:10:04Z")

</div>

I try to reinstall server with fresh ubuntu server 14.04.1 LTS installation.  
I follow this guide: [url][Percona XtraDB Cluster](http://www.percona.com/doc/percona-xtradb-cluster/5.6/howtos/ubuntu_howto.html%5B/url%5D)  
When I try to start first node (/etc/init.d/mysql bootstrap-pxc) for bootstrapping cluster, service not start and I receive this error:

- Bootstrapping Percona XtraDB Cluster database server mysqld
- The server quit without updating PID file (/var/lib/mysql/cls-mysql1-db1.pid).  
[fail]

In servername.err I find many many “[ERROR] InnoDB: Unable to lock ./ibdata1, error: 11”

2014-12-06 16:32:48 3422 [ERROR] InnoDB: Unable to lock ./ibdata1, error: 11  
2014-12-06 16:32:48 3422 [Note] InnoDB: Check that you do not already have another mysqld process using the same InnoDB data or log files.  
2014-12-06 16:32:48 3422 [Note] InnoDB: Retrying to lock the first data file  
2014-12-06 16:32:48 3422 [Note] WSREP: handshake failed, my group: ‘mysql\_cluster’, peer group: ‘cluster-mysql1’  
2014-12-06 16:32:49 3422 [ERROR] InnoDB: Unable to lock ./ibdata1, error: 11  
2014-12-06 16:32:49 3422 [Note] InnoDB: Check that you do not already have another mysqld process using the same InnoDB data or log files.  
2014-12-06 16:32:50 3422 [Note] WSREP: handshake failed, my group: ‘mysql\_cluster’, peer group: ‘cluster-mysql1’  
2014-12-06 16:32:50 3422 [ERROR] InnoDB: Unable to lock ./ibdata1, error: 11  
2014-12-06 16:32:50 3422 [Note] InnoDB: Check that you do not already have another mysqld process using the same InnoDB data or log files.  
2014-12-06 16:32:51 3422 [ERROR] InnoDB: Unable to lock ./ibdata1, error: 11  
2014-12-06 16:32:51 3422 [Note] InnoDB: Check that you do not already have another mysqld process using the same InnoDB data or log files.  
2014-12-06 16:32:51 3422 [Note] WSREP: handshake failed, my group: ‘mysql\_cluster’, peer group: ‘cluster-mysql1’  
2014-12-06 16:32:52 3422 [ERROR] InnoDB: Unable to lock ./ibdata1, error: 11  
2014-12-06 16:32:52 3422 [Note] InnoDB: Check that you do not already have another mysqld process using the same InnoDB data or log files.  
2014-12-06 16:32:53 3422 [Note] WSREP: handshake failed, my group: ‘mysql\_cluster’, peer group: ‘cluster-mysql1’  
2014-12-06 16:32:53 3422 [ERROR] InnoDB: Unable to lock ./ibdata1, error: 11  
2014-12-06 16:32:53 3422 [Note] InnoDB: Check that you do not already have another mysqld process using the same InnoDB data or log files.  
2014-12-06 16:32:54 3422 [ERROR] InnoDB: Unable to lock ./ibdata1, error: 11  
2014-12-06 16:32:54 3422 [Note] InnoDB: Check that you do not already have another mysqld process using the same InnoDB data or log files.  
2014-12-06 16:32:54 3422 [Note] WSREP: handshake failed, my group: ‘mysql\_cluster’, peer group: ‘cluster-mysql1’  
2014-12-06 16:32:55 3422 [ERROR] InnoDB: Unable to lock ./ibdata1, error: 11  
2014-12-06 16:32:55 3422 [Note] InnoDB: Check that you do not already have another mysqld process using the same InnoDB data or log files.  
2014-12-06 16:32:56 3422 [Note] WSREP: handshake failed, my group: ‘mysql\_cluster’, peer group: ‘cluster-mysql1’  
2014-12-06 16:32:56 3422 [ERROR] InnoDB: Unable to lock ./ibdata1, error: 11  
2014-12-06 16:32:56 3422 [Note] InnoDB: Check that you do not already have another mysqld process using the same InnoDB data or log files.

---

<div class="post-metadata">

**Author:** ![ldo](https://avatars.discourse-cdn.com/v4/letter/l/ed8c4c/32.png) [@ldo](https://forums.percona.com/u/ldo)\
**Post date:** [January 7, 2015, 5:11am UTC](https://forums.percona.com/t/error-the-server-quit-without-updating-pid-file/3925/5 "2015-01-07T05:11:59Z")

</div>

I had a similar problem on Ubuntu, which I solved by deleting the /etc/init/mysql.conf upstart script

---

<div class="post-metadata">

**Author:** ![maxpao](https://avatars.discourse-cdn.com/v4/letter/m/7bcc69/32.png) [@maxpao](https://forums.percona.com/u/maxpao)\
**Post date:** [January 13, 2015, 1:36pm UTC](https://forums.percona.com/t/error-the-server-quit-without-updating-pid-file/3925/6 "2015-01-13T13:36:36Z")

</div>

I had the same problem on ubuntu LTS 14.04 server 64 bits, any help with this isue?

Best regards.

---

<div class="post-metadata">

**Author:** ![mirfan](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/mirfan/32/16890_2.png) [@mirfan](https://forums.percona.com/u/mirfan)\
**Post date:** [January 13, 2015, 2:59pm UTC](https://forums.percona.com/t/error-the-server-quit-without-updating-pid-file/3925/7 "2015-01-13T14:59:22Z")

</div>

> > 2014-12-06 16:32:56 3422 [ERROR] InnoDB: Unable to lock ./ibdata1, error: 11

I would like to ask you to check whether there’s any mysql process left running; you can do that with:

$ ps auxww | grep mysql

For that error possible cause is you already have mysqld running. You can kill mysqld process and try to restart.

In scenario, where all galera nodes stopped then try to [bootstrap](http://www.percona.com/doc/percona-xtradb-cluster/5.6/manual/bootstrap.html) first node once it’s up you can restart remaining nodes via calling mysqld daemon script as below:  
$ /etc/init.d/mysql start

I foresee this will start remaining nodes of the cluster via SST/IST.

In case, If it’s gives you error

> > - Starting MySQL (Percona XtraDB Cluster) database server mysqld
> > - The server quit without updating PID file (/var/run/mysqld/mysqld.pid).

Please share the relevant entries from mysql error log to identify what causing the issue. Also, share the installed xtradb cluster packages details from all failed nodes.

$ dpkg -l | grep -i “percona”

And my.cnf from failed node.

Moreover, please refer to [http://www.percona.com/doc/percona-xtradb-cluster/5.6/howtos/ubuntu\_howto.html](http://www.percona.com/doc/percona-xtradb-cluster/5.6/howtos/ubuntu_howto.html)

---

<div class="post-metadata">

**Author:** ![maxpao](https://avatars.discourse-cdn.com/v4/letter/m/7bcc69/32.png) [@maxpao](https://forums.percona.com/u/maxpao)\
**Post date:** [January 14, 2015, 3:44pm UTC](https://forums.percona.com/t/error-the-server-quit-without-updating-pid-file/3925/8 "2015-01-14T15:44:32Z")

</div>

Hello, here the info

Node 1

ps auxww | grep mysql  
root 5598 0.0 0.0 14276 900 pts/0 R+ 17:59 0:00 grep --color=auto mysql

/etc/init.d/mysql bootstrap-pxc

Percona XtraDB Cluster database server mysqld  
[OK]  
root@XtraDB-1:~# ps auxww | grep mysql  
root 5645 0.0 0.0 4444 732 pts/0 S 18:01 0:00 /bin/sh /usr/bin/mysqld\_safe --wsrep-new-cluster  
mysql 6021 1.1 23.8 1726452 489124 pts/0 Sl 18:01 0:00 /usr/sbin/mysqld --basedir=/usr --datadir=/var/lib/mysql --plugin-dir=/usr/lib/mysql/plugin --user=mysql --wsrep-provider=/usr/lib/libgalera\_smm.so --wsrep-new-cluster --log-error=/var/lib/mysql/XtraDB-1.err --pid-file=/var/run/mysqld/mysqld.pid --socket=/var/run/mysqld/mysqld.sock --port=3306 --wsrep\_start\_position=848a69b3-9aa9-11e4-af58-cbd501ad4269:2  
root 6493 0.0 0.0 14276 900 pts/0 R+ 18:02 0:00 grep --color=auto mysql

Type ‘help;’ or ‘\h’ for help. Type ‘\c’ to clear the current input statement.

mysql\> show status like ‘wsrep%’;  
±-----------------------------±-------------------------------------+  
| Variable\_name | Value |  
±-----------------------------±-------------------------------------+  
| wsrep\_local\_state\_uuid | 848a69b3-9aa9-11e4-af58-cbd501ad4269 |  
| wsrep\_protocol\_version | 6 |  
| wsrep\_last\_committed | 2 |  
| wsrep\_replicated | 0 |  
| wsrep\_replicated\_bytes | 0 |  
| wsrep\_repl\_keys | 0 |  
| wsrep\_repl\_keys\_bytes | 0 |  
| wsrep\_repl\_data\_bytes | 0 |  
| wsrep\_repl\_other\_bytes | 0 |  
| wsrep\_received | 7 |  
| wsrep\_received\_bytes | 562 |  
| wsrep\_local\_commits | 0 |  
| wsrep\_local\_cert\_failures | 0 |  
| wsrep\_local\_replays | 0 |  
| wsrep\_local\_send\_queue | 0 |  
| wsrep\_local\_send\_queue\_max | 1 |  
| wsrep\_local\_send\_queue\_min | 0 |  
| wsrep\_local\_send\_queue\_avg | 0.000000 |  
| wsrep\_local\_recv\_queue | 0 |  
| wsrep\_local\_recv\_queue\_max | 2 |  
| wsrep\_local\_recv\_queue\_min | 0 |  
| wsrep\_local\_recv\_queue\_avg | 0.142857 |  
| wsrep\_local\_cached\_downto | 18446744073709551615 |  
| wsrep\_flow\_control\_paused\_ns | 0 |  
| wsrep\_flow\_control\_paused | 0.000000 |  
| wsrep\_flow\_control\_sent | 0 |  
| wsrep\_flow\_control\_recv | 0 |  
| wsrep\_cert\_deps\_distance | 0.000000 |  
| wsrep\_apply\_oooe | 0.000000 |  
| wsrep\_apply\_oool | 0.000000 |  
| wsrep\_apply\_window | 0.000000 |  
| wsrep\_commit\_oooe | 0.000000 |  
| wsrep\_commit\_oool | 0.000000 |  
| wsrep\_commit\_window | 0.000000 |  
| wsrep\_local\_state | 4 |  
| wsrep\_local\_state\_comment | Synced |  
| wsrep\_cert\_index\_size | 0 |  
| wsrep\_causal\_reads | 0 |  
| wsrep\_cert\_interval | 0.000000 |  
| wsrep\_incoming\_addresses | 192.168.2.70:3306 |  
| wsrep\_evs\_delayed | |  
| wsrep\_evs\_evict\_list | |  
| wsrep\_evs\_repl\_latency | 0/0/0/0/0 |  
| wsrep\_evs\_state | OPERATIONAL |  
| wsrep\_gcomm\_uuid | 89754819-9c30-11e4-8d83-2e6a7a990f01 |  
| wsrep\_cluster\_conf\_id | 3 |  
| wsrep\_cluster\_size | 1 |  
| wsrep\_cluster\_state\_uuid | 848a69b3-9aa9-11e4-af58-cbd501ad4269 |  
| wsrep\_cluster\_status | Primary |  
| wsrep\_connected | ON |  
| wsrep\_local\_bf\_aborts | 0 |  
| wsrep\_local\_index | 0 |  
| wsrep\_provider\_name | Galera |  
| wsrep\_provider\_vendor | Codership Oy \<info@codership.com\> |  
| wsrep\_provider\_version | 3.8(rf6147dd) |  
| wsrep\_ready | ON |  
±-----------------------------±-----------

in the 2nd node

[mysqld]

datadir=/var/lib/mysql  
user=mysql

# Path to Galera library

wsrep\_provider=/usr/lib/libgalera\_smm.so

# Cluster connection URL contains the IPs of node#1, node#2 and node#3

wsrep\_cluster\_address=gcomm://192.168.2.70,192.168.2.71,192.168.2.72

# In order for Galera to work correctly binlog format should be ROW

binlog\_format=ROW

# MyISAM storage engine has only experimental support

default\_storage\_engine=InnoDB

# This changes how InnoDB autoincrement locks are managed and is a requirement for Galera

innodb\_autoinc\_lock\_mode=2

# Node #2 address

wsrep\_node\_address=192.168.2.71

# SST method

wsrep\_sst\_method=xtrabackup

# Cluster name

wsrep\_cluster\_name=my\_ubuntu\_cluster

# Authentication for SST method

wsrep\_sst\_auth=“sstuser:s3cretPass”

#user = mysql  
pid-file = /var/run/mysqld/mysqld.pid  
socket = /var/run/mysqld/mysqld.sock  
port = 3306  
basedir = /usr  
datadir = /var/lib/mysql  
tmpdir = /tmp  
lc-messages-dir = /usr/share/mysql  
skip-external-locking

…

ps auxww | grep mysql  
root 2963 0.0 0.0 14276 896 pts/0 R+ 18:09 0:00 grep --color=auto mysql

/etc/init.d/mysql start

- Starting MySQL (Percona XtraDB Cluster) database server mysqld \* State transfer in progress, setting sleep higher mysqld \* The server quit without updating PID file (/var/run/mysqld/mysqld.pid).  
[fail]

dpkg -l | grep -i “percona”  
ii percona-xtrabackup 2.2.7-5050-1.trusty amd64 Open source backup tool for InnoDB and XtraDB  
ii percona-xtradb-cluster-56 5.6.21-25.8-938.trusty amd64 Percona XtraDB Cluster with Galera  
ii percona-xtradb-cluster-client-5.6 5.6.21-25.8-938.trusty amd64 Percona XtraDB Cluster database client binaries  
ii percona-xtradb-cluster-common-5.6 5.6.21-25.8-938.trusty amd64 Percona XtraDB Cluster database common files (e.g. /etc/mysql/my.cnf)  
ii percona-xtradb-cluster-galera-3 3.8.3390.trusty amd64 Metapackage for latest version of galera3.  
ii percona-xtradb-cluster-galera-3.x 3.8.3390.trusty amd64 Galera components of Percona XtraDB Cluster  
ii percona-xtradb-cluster-server-5.6 5.6.21-25.8-938.trusty amd64 Percona XtraDB Cluster database server binaries

syslog

/etc/init.d/mysql[2399]: MySQL PID not found, pid\_file detected/guessed: /var/run/mysqld/mysqld.pid  
Jan 14 18:10:26 XtraDB-2 /etc/init.d/mysql[3006]: MySQL PID not found, pid\_file detected/guessed: /var/run/mysqld/mysqld.pid

thanks!

Best!

---

<div class="post-metadata">

**Author:** ![mirfan](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/mirfan/32/16890_2.png) [@mirfan](https://forums.percona.com/u/mirfan)\
**Post date:** [January 15, 2015, 2:30pm UTC](https://forums.percona.com/t/error-the-server-quit-without-updating-pid-file/3925/9 "2015-01-15T14:30:04Z")

</div>

> > # SST method
> > 
> > wsrep\_sst\_method=xtrabackup

Please update wsrep\_sst\_method to xtrabackup-v2 which is recommended SST method since PXC 5.5 You can read more here [http://www.percona.com/doc/percona-xtradb-cluster/5.6/manual/xtrabackup\_sst.html](http://www.percona.com/doc/percona-xtradb-cluster/5.6/manual/xtrabackup_sst.html)

> > - Starting MySQL (Percona XtraDB Cluster) database server mysqld \* State transfer in progress, setting sleep higher mysqld \* The server quit without updating PID file (/var/run/mysqld/mysqld.pid).

Make sure you have correct ownership/permission on MySQL data directory and on /var/run/mysqld/ directory. Make sure AppArmor disabled as per [http://www.percona.com/blog/2012/12/20/percona-xtradb-cluster-selinux-is-not-always-the-culprit/](http://www.percona.com/blog/2012/12/20/percona-xtradb-cluster-selinux-is-not-always-the-culprit/)  
Further, please share innobackup.backup.log should be in donor datadir (first node of cluster which is running). This post is nice to identify the possible causes for SST [http://www.percona.com/blog/2014/12/30/diagnosing-sst-errors-with-percona-xtradb-cluster-for-mysql/](http://www.percona.com/blog/2014/12/30/diagnosing-sst-errors-with-percona-xtradb-cluster-for-mysql/)

In case, If it still fails to start after above mentioned checklist. Please attach the complete error log from failed node.

---

<div class="post-metadata">

**Author:** ![maxpao](https://avatars.discourse-cdn.com/v4/letter/m/7bcc69/32.png) [@maxpao](https://forums.percona.com/u/maxpao)\
**Post date:** [January 15, 2015, 4:37pm UTC](https://forums.percona.com/t/error-the-server-quit-without-updating-pid-file/3925/10 "2015-01-15T16:37:54Z")

</div>

Hello.

It works! I just change the

# SST method

wsrep\_sst\_method=xtrabackup-v2

But when i reboot the VMs stop working.

apparmor is not installed

and the permissions are ok.

thanks!

---

<div class="post-metadata">

**Author:** ![maxpao](https://avatars.discourse-cdn.com/v4/letter/m/7bcc69/32.png) [@maxpao](https://forums.percona.com/u/maxpao)\
**Post date:** [January 15, 2015, 5:10pm UTC](https://forums.percona.com/t/error-the-server-quit-without-updating-pid-file/3925/11 "2015-01-15T17:10:09Z")

</div>

Hello

When execute

service mysql stop

- Stopping MySQL (Percona XtraDB Cluster) mysqld [OK]

but mysql service still ON ?

root@XtraDB-1:/var/lib/mysql# ps aux | grep mysql  
root 1324 0.0 0.0 4444 728 pts/2 S 19:16 0:00 /bin/sh /usr/bin/mysqld\_safe  
mysql 1648 0.1 22.0 1060292 451380 pts/2 Sl 19:16 0:01 /usr/sbin/mysqld --basedir=/usr --datadir=/var/lib/mysql --plugin-dir=/usr/lib/mysql/plugin --user=mysql --wsrep-provider=/usr/lib/libgalera\_smm.so --log-error=/var/lib/mysql/XtraDB-1.err --pid-file=/var/run/mysqld/mysqld.pid --socket=/var/run/mysqld/mysqld.sock --port=3306 --wsrep\_start\_position=848a69b3-9aa9-11e4-af58-cbd501ad4269:5  
root 2360 0.0 0.0 14276 896 pts/2 S+ 19:39 0:00 grep --color=auto mysql

---

<div class="post-metadata">

**Author:** ![maxpao](https://avatars.discourse-cdn.com/v4/letter/m/7bcc69/32.png) [@maxpao](https://forums.percona.com/u/maxpao)\
**Post date:** [January 19, 2015, 8:57am UTC](https://forums.percona.com/t/error-the-server-quit-without-updating-pid-file/3925/12 "2015-01-19T08:57:48Z")

</div>

Hello

I setup a new test emviroment with ubuntu 12.04 LTS 64 BITS, same error with xtradb 5.6. I follow this [url][Percona XtraDB Cluster](http://www.percona.com/doc/percona-xtradb-cluster/5.6/installation/apt_repo.html%5B/url%5D)

and

[url][Percona XtraDB Cluster](http://www.percona.com/doc/percona-xtradb-cluster/5.5/howtos/ubuntu_howto.html%5B/url%5D)

SAME ERROR !!

best regards.

---

<div class="post-metadata">

**Author:** ![siya](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/siya/32/1085_2.png) [@siya](https://forums.percona.com/u/siya)\
**Post date:** [September 10, 2015, 9:18am UTC](https://forums.percona.com/t/error-the-server-quit-without-updating-pid-file/3925/13 "2015-09-10T09:18:15Z")

</div>

Hello,

You could see the similar problem solved @ [url][https://www.percona.com/forums/questions-discussions/percona-xtradb-cluster/32360-xtradb-cluster-loads-but-no-pid-file-mysql-wont-load[/url]](https://www.percona.com/forums/questions-discussions/percona-xtradb-cluster/32360-xtradb-cluster-loads-but-no-pid-file-mysql-wont-load%5B/url%5D)

I was going through the similar situation on an ubuntu 12.04. Commands followed a) sudo echo “manual” \> /etc/init/mysql.override  
b) sudo reboot  
c) sudo /etc/init.d/mysql bootstrap-pxc

best regards,

---

<div class="post-metadata">

**Author:** ![gaurav](https://avatars.discourse-cdn.com/v4/letter/g/b487fb/32.png) [@gaurav](https://forums.percona.com/u/gaurav)\
**Post date:** [December 30, 2016, 6:39am UTC](https://forums.percona.com/t/error-the-server-quit-without-updating-pid-file/3925/14 "2016-12-30T06:39:26Z")

</div>

Facing same problem while restart mysql service. .

MySQL server PID file could not be found! [FAILED]  
Starting MySQL…The server quit without updating PID file [FAILED]tabase/editorial/primary/xyz.pid).

Can Anyone help me with this.
