# Error starting MySQL (Percona XtraDB Cluster) database server

**URL:** <https://forums.percona.com/t/error-starting-mysql-percona-xtradb-cluster-database-server/6243>\
**Category:** Other MySQL® Questions\
**Created:** [March 11, 2018, 7:14am UTC](https://forums.percona.com/t/error-starting-mysql-percona-xtradb-cluster-database-server/6243 "2018-03-11T07:14:39Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![m.anwar](https://avatars.discourse-cdn.com/v4/letter/m/d26b3c/32.png) [@m.anwar](https://forums.percona.com/u/m.anwar)\
**Post date:** [March 11, 2018, 7:14am UTC](https://forums.percona.com/t/error-starting-mysql-percona-xtradb-cluster-database-server/6243/1 "2018-03-11T07:14:39Z")

</div>

Hello,  
I have MYSQL DB running on cluster along with percona. 2 servers in cluster are working fine except for 3rd one which does not start with MySQL service. When I try to start MySQL service on the server I get the following error.  
Mar 11 13:15:12 dbserver3 mysql[24884]: Starting MySQL (Percona XtraDB Cluster) database server: mysqldStale PID file found: /var/run/mysqld/mysqld.pid with 1800 … (warning).  
Mar 11 13:15:13 dbserver3 /etc/init.d/mysql[25508]: mysql ping failed  
Mar 11 13:15:13 dbserver3 mysql[24884]: Please take a look at the syslog. … failed!  
Mar 11 13:15:13 dbserver3 mysql[24884]: failed!  
Mar 11 13:15:13 dbserver3 systemd[1]: mysql.service: control process exited, code=exited status=1  
Mar 11 13:15:13 dbserver3 systemd[1]: Failed to start LSB: Start and stop the mysql (Percona XtraDB Cluster) daemon.  
Mar 11 13:15:13 dbserver3 systemd[1]: Unit mysql.service entered failed state.  
Any idea what is going wrong would be great support.  
Thanks  
Anwar

---

<div class="post-metadata">

**Author:** ![parth](https://avatars.discourse-cdn.com/v4/letter/p/e56c9b/32.png) [@parth](https://forums.percona.com/u/parth)\
**Post date:** [June 14, 2019, 1:00pm UTC](https://forums.percona.com/t/error-starting-mysql-percona-xtradb-cluster-database-server/6243/2 "2019-06-14T13:00:01Z")

</div>

I am experiencing the same issue with a 3 node cluster which was functioning normally. We had to reboot node 1 for a different reason and since mySQL would not start with the same ‘mysql ping failed’ any one know what this errr means and how to resolve…

● mysql.service - LSB: Start and stop the mysql (Percona XtraDB Cluster) daemon  
Loaded: loaded (/etc/init.d/mysql; bad; vendor preset: enabled)  
Active: failed (Result: exit-code) since Fri 2019-06-14 12:51:47 EDT; 15s ago  
Docs: man:systemd-sysv-generator(8)  
Process: 3990 ExecStart=/etc/init.d/mysql start (code=exited, status=1/FAILURE)  
Tasks: 32  
Memory: 225.1M  
CPU: 161ms  
CGroup: /system.slice/mysql.service  
├─1201 /bin/sh /usr/bin/mysqld\_safe  
└─2089 /usr/sbin/mysqld --basedir=/usr --datadir=/var/lib/mysql --plugin-dir=/usr/lib/mysql/plugin --user=mysql --log-error=PROD-DBNODE1.err --pid-file=PROD-DBNODE1.pid --wsrep\_start\_position=00000000-0000-0000-0

Jun 14 12:51:46 PROD-DBNODE1 mysql[3990]: mysqld: [Warning] World-writable config file ‘/etc/mysql/my.cnf’ is ignored.  
Jun 14 12:51:46 PROD-DBNODE1 mysql[3990]: mysqld: [Warning] World-writable config file ‘/etc/mysql/my.cnf’ is ignored.  
Jun 14 12:51:46 PROD-DBNODE1 mysql[3990]: \* Starting MySQL (Percona XtraDB Cluster) database server mysqld  
Jun 14 12:51:46 PROD-DBNODE1 mysql[3990]: \* Stale PID file found: /var/lib/mysql/DBNODE1.pid with 2089  
Jun 14 12:51:47 PROD-DBNODE1 mysql[3990]: \* Please take a look at the syslog.  
Jun 14 12:51:47 PROD-DBNODE1 mysql[3990]: …fail!  
Jun 14 12:51:47 PROD-DBNODE1 systemd[1]: mysql.service: Control process exited, code=exited status=1  
Jun 14 12:51:47 PROD-DBNODE1 systemd[1]: Failed to start LSB: Start and stop the mysql (Percona XtraDB Cluster) daemon.  
Jun 14 12:51:47 PROD-DBNODE1 systemd[1]: mysql.service: Unit entered failed state.  
Jun 14 12:51:47 PROD-DBNODE1 systemd[1]: mysql.service: Failed with result ‘exit-code’.
