# Error on progess pbm backup

**URL:** <https://forums.percona.com/t/error-on-progess-pbm-backup/25712>\
**Category:** Percona Backup for MongoDB\
**Created:** [October 6, 2023, 9:23am UTC](https://forums.percona.com/t/error-on-progess-pbm-backup/25712 "2023-10-06T09:23:35Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![Natalya](https://avatars.discourse-cdn.com/v4/letter/n/4da419/32.png) [@Natalya](https://forums.percona.com/u/Natalya)\
**Post date:** [October 6, 2023, 9:23am UTC](https://forums.percona.com/t/error-on-progess-pbm-backup/25712/1 "2023-10-06T09:23:35Z")

</div>

Helow.  
I am trying to test MongoDB backup using pbm- backup Backup fails with Error:  
no progress from leader, backup metadata not found.\*  
I see an error message in bpm logs

get balancer status: run mongo command: (Unauthorized) not authorized on admin to execute command { \_configsvrBalancerStatus: 1, lsid: { id: UUID(“2ed94c30-830-4ec8-803 9-e44eecefe182”) }, $clusterTime: { clusterTime: Timestamp(1696497792, 4), signature: { hash: BinData(0, C1D92DCCE1C8C28B991322C4D9D 01FAB41C2127E), keyId: 7246925759086854169 } }, $db: “admin”, $readPreference: { mode: “primary” } }

---

<div class="post-metadata">

**Author:** ![Dmytro\_Zghoba](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/dmytro_zghoba/32/4721_2.png) [@Dmytro\_Zghoba](https://forums.percona.com/u/Dmytro_Zghoba)\
**Post date:** [October 6, 2023, 9:43am UTC](https://forums.percona.com/t/error-on-progess-pbm-backup/25712/2 "2023-10-06T09:43:09Z")

</div>

Hi @Natalya ,

PBM agents use the wrong user credentials or the user does have not enough permissions.

Ensure you have a MongoDB user with the proper roles/permissions for PBM Agent usage.  
[PBM Docs: Configure authentication in MongoDB](https://docs.percona.com/percona-backup-mongodb/install/initial-setup.html#configure-authentication-in-mongodb).

---

<div class="post-metadata">

**Author:** ![Natalya](https://avatars.discourse-cdn.com/v4/letter/n/4da419/32.png) [@Natalya](https://forums.percona.com/u/Natalya)\
**Post date:** [October 6, 2023, 10:39am UTC](https://forums.percona.com/t/error-on-progess-pbm-backup/25712/3 "2023-10-06T10:39:58Z")

</div>

Hi Dmytro,

the role and user pbmuser were created in mongod according [PBM Docs: Configure authentication in MongoDB](https://docs.percona.com/percona-backup-mongodb/install/initial-setup.html#configure-authentication-in-mongodb).

The following checks were performed on all primary nodes

pbm status --mongodb-uri “mongodb://pbmuser:secretpwd@localhost:27018/?ssl=false&authSource=admin”\

mongo -u pbmuser -p secretpwd --host localhost:27018 --authenticationDatabase admin

pbm tables were created in db admin all pramary nodes

pbmAgents  
pbmBackups  
pbmCmd  
pbmConfig  
pbmLock  
pbmLockOp  
pbmLog  
pbmOpLog  
pbmPITRChunks

pbm status  
Cluster:

configRSinMem:

- configRSinMem/mng10:27018 [S]: pbm-agent v2.3.0 OK
- configRSinMem/mng11:27018 [P]: pbm-agent v2.3.0 OK
- configRSinMem/mng12:27018 [S]: pbm-agent v2.3.0 OK  
InMemShard\_1:
- InMemShard\_1/mng7:27018 [S]: pbm-agent v2.3.0 OK
- InMemShard\_1/mng8.27018 [P]: pbm-agent v2.3.0 OK
- InMemShard\_1/mng9:27018 [S]: pbm-agent v2.3.0 OK  
InMemShard\_0:
- InMemShard\_0/mng4:27018 [S]: pbm-agent v2.3.0 OK
- InMemShard\_0/mng5:27018 [S]: pbm-agent v2.3.0 OK
- InMemShard\_0/mng6:27018 [P]: pbm-agent v2.3.0 OK

PITR incremental backup:

Status [OFF]

Currently running:

(none)

Backups:

FS /data/local\_backups  
(none)

---

<div class="post-metadata">

**Author:** ![oleksandr.havryliak](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/oleksandr.havryliak/32/5703_2.png) [@oleksandr.havryliak](https://forums.percona.com/u/oleksandr.havryliak)\
**Post date:** [October 9, 2023, 11:17am UTC](https://forums.percona.com/t/error-on-progess-pbm-backup/25712/4 "2023-10-09T11:17:23Z")

</div>

Hi, @Natalya !  
You’re using FS for the storage ( I suppose that it’s NFS ) so please make sure that this storage is accessible from all of the nodes of the cluster and mongod user has RW access to it
