# Error: no progress from leader, backup metadata not found

**URL:** <https://forums.percona.com/t/error-no-progress-from-leader-backup-metadata-not-found/13460>\
**Category:** Percona Backup for MongoDB\
**Tags:** percona, mongodb\
**Created:** [December 13, 2021, 3:17pm UTC](https://forums.percona.com/t/error-no-progress-from-leader-backup-metadata-not-found/13460 "2021-12-13T15:17:00Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![batuhan\_kircova](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/batuhan_kircova/32/5312_2.png) [@batuhan\_kircova](https://forums.percona.com/u/batuhan_kircova)\
**Post date:** [December 13, 2021, 3:17pm UTC](https://forums.percona.com/t/error-no-progress-from-leader-backup-metadata-not-found/13460/1 "2021-12-13T15:17:00Z")

</div>

Hi,

I installed percona-backup-mongodb-1.6.1-1.el7.x86\_64.rpm rpm in order to take backup for mongo. After that , ı adjust the storage.yaml file and try to start backup process. However , I faced with this error  
Error: no progress from leader, backup metadata not found  
could you help me please ?

Thank you

---

<div class="post-metadata">

**Author:** ![Ivan\_Groenewold](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/ivan_groenewold/32/6299_2.png) [@Ivan\_Groenewold](https://forums.percona.com/u/Ivan_Groenewold)\
**Post date:** [December 15, 2021, 1:33pm UTC](https://forums.percona.com/t/error-no-progress-from-leader-backup-metadata-not-found/13460/2 "2021-12-15T13:33:03Z")

</div>

Hello, have you followed all the [instructions](https://docs.percona.com/percona-backup-mongodb/initial-setup.html) in the documentation? it is not enough to just install the rpm and configure the yaml file. You also have to run pbm config command.

---

<div class="post-metadata">

**Author:** ![Selva1](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/selva1/32/5510_2.png) [@Selva1](https://forums.percona.com/u/Selva1)\
**Post date:** [January 5, 2022, 9:28am UTC](https://forums.percona.com/t/error-no-progress-from-leader-backup-metadata-not-found/13460/3 "2022-01-05T09:28:40Z")

</div>

Hi,

We have configured as per the percona documentations . But still we are getting this error

Also , Set the MongoDB connection URI for `pbm CLI` not working

Only while creating connection using manual process able to take the backup

We are using Ubuntu 16 and environment variables are configured fine

Please help us to troubleshoot this

---

<div class="post-metadata">

**Author:** ![Selva1](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/selva1/32/5510_2.png) [@Selva1](https://forums.percona.com/u/Selva1)\
**Post date:** [January 10, 2022, 4:18am UTC](https://forums.percona.com/t/error-no-progress-from-leader-backup-metadata-not-found/13460/4 "2022-01-10T04:18:43Z")

</div>

Anybody have tried this , only manual process able to take the backup

---

<div class="post-metadata">

**Author:** ![jenunes](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/jenunes/32/9331_2.png) [@jenunes](https://forums.percona.com/u/jenunes)\
**Post date:** [January 12, 2022, 10:55pm UTC](https://forums.percona.com/t/error-no-progress-from-leader-backup-metadata-not-found/13460/5 "2022-01-12T22:55:31Z")

</div>

Hi @Selva1

Could you please elaborate further on what you mean by _manual process_?

Also, it would be nice to get a round of information from PBM to understand the scenario correctly. Please send the last few lines from the PBM log containing the error itself, along with the following outputs:

- pbm version
- pbm status
- pbm config
- echo $PBM\_MONGODB\_URI _(please make sure to redact user, password and hostname)_

Best,

---

<div class="post-metadata">

**Author:** ![Selva1](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/selva1/32/5510_2.png) [@Selva1](https://forums.percona.com/u/Selva1)\
**Post date:** [January 17, 2022, 9:14am UTC](https://forums.percona.com/t/error-no-progress-from-leader-backup-metadata-not-found/13460/6 "2022-01-17T09:14:04Z")

</div>

Which is working fine in UAT , my test environment had the issue [Error: no progress from leader, backup metadata not found](https://forums.percona.com/t/error-no-progress-from-leader-backup-metadata-not-found/13460)

Test environment we have fixed with running nohup file always in background

---

<div class="post-metadata">

**Author:** ![Manganiello](https://avatars.discourse-cdn.com/v4/letter/m/dbc845/32.png) [@Manganiello](https://forums.percona.com/u/Manganiello)\
**Post date:** [February 7, 2022, 11:02am UTC](https://forums.percona.com/t/error-no-progress-from-leader-backup-metadata-not-found/13460/7 "2022-02-07T11:02:32Z")

</div>

Hello @jenunes

Version pbm 1.6.1  
CentOS Linux release 7.9.2009 (Core)  
PBM\_MONGODB\_URI=mongodb://pbmuser:secretpwd@localhost:27017,localhost:27018,localhost:27019/?replicaSet=rs0

1)the agent corresponding to the primary node must be up & running for the backup to work. Without this, the backup does not happen;

2)it would appear that the backup is actually performed by the secondary nodes, as long as the respective agents are also active. And in any case point 1 must be satisfied;

Entering a forced priority seems to work.

In any case, the backup will fail if the primary node agent is not seen.
