# ERROR! MySQL (Percona XtraDB Cluster) server startup failed

**URL:** <https://forums.percona.com/t/error-mysql-percona-xtradb-cluster-server-startup-failed/7311>\
**Category:** Percona XtraDB Cluster 5.x\
**Created:** [November 25, 2019, 2:00pm UTC](https://forums.percona.com/t/error-mysql-percona-xtradb-cluster-server-startup-failed/7311 "2019-11-25T14:00:17Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![NPXDBCls](https://avatars.discourse-cdn.com/v4/letter/n/57b2e6/32.png) [@NPXDBCls](https://forums.percona.com/u/NPXDBCls)\
**Post date:** [November 25, 2019, 2:00pm UTC](https://forums.percona.com/t/error-mysql-percona-xtradb-cluster-server-startup-failed/7311/1 "2019-11-25T14:00:17Z")

</div>

Hello All,  
I am new to Percona XtraDB Cluster, so thank you in advance for any help.  
I have a 3 cluster nodes.  
the 1st node I started with /etc/init.d/mysql bootstrap-pxc  
the 2nd node I tried starting with /etc/init.d/mysql start — this one is failing. ☹  
the 3rd node I started with /etc/init.d/mysql start

Background, All 3 are VM clients, the 3 nodes were moved to a new VM server.  
after the new nodes were started, I am started running rsync on the new nodes to pull the data daily while the cluster is running still on the old VM servers.

to clarify the OLD VM are still live on the old VMWare.

the new VMs are up and running and I am running rsync on the new VM to get the current data from the OLD VMs.

On the new VMs, on the primary node, I am able to start by running bootstrap-pxc, on the 3rd node I am able to start without any problems. The 2nd node is refusing to start.  
191125 13:00:54 mysqld\_safe Starting mysqld daemon with databases from /var/lib/mysql  
191125 13:00:54 mysqld\_safe WSREP: Running position recovery with --log\_error=‘/var/lib/mysql/wsrep\_recovery.7KUYXU’ --pid-file=‘/var/lib/mysql/cgi-dbc2.com-recover.pid’  
2019-11-25 13:00:55 0 [Warning] ‘THREAD\_CONCURRENCY’ is deprecated and will be removed in a future release.  
2019-11-25 13:00:55 0 [Warning] TIMESTAMP with implicit DEFAULT value is deprecated. Please use --explicit\_defaults\_for\_timestamp server option (see documentation for more details).  
191125 13:00:59 mysqld\_safe WSREP: Recovered position a344a92f-65f8-11e4-8105-f7bf7501c52e:84041533  
Log of wsrep recovery (–wsrep-recover):  
2019-11-25 13:00:55 7144 [Note] Plugin ‘FEDERATED’ is disabled.  
2019-11-25 13:00:55 7fc834d147e0 InnoDB: Warning: Using innodb\_locks\_unsafe\_for\_binlog is DEPRECATED. This option may be removed in future releases. Please use READ COMMITTED transaction isolation level instead, see [url][http://dev.mysql.com/doc/refman/5.6/en/set-transaction.html[/url]](http://dev.mysql.com/doc/refman/5.6/en/set-transaction.html%5B/url%5D).  
2019-11-25 13:00:55 7144 [Note] InnoDB: Using atomics to ref count buffer pool pages  
2019-11-25 13:00:55 7144 [Note] InnoDB: The InnoDB memory heap is disabled  
2019-11-25 13:00:55 7144 [Note] InnoDB: Mutexes and rw\_locks use GCC atomic builtins  
2019-11-25 13:00:55 7144 [Note] InnoDB: Memory barrier is not used  
2019-11-25 13:00:55 7144 [Note] InnoDB: Compressed tables use zlib 1.2.3  
2019-11-25 13:00:55 7144 [Note] InnoDB: Using Linux native AIO  
2019-11-25 13:00:55 7144 [Note] InnoDB: Using CPU crc32 instructions  
2019-11-25 13:00:55 7144 [Note] InnoDB: Initializing buffer pool, size = 20.0G  
2019-11-25 13:00:56 7144 [Note] InnoDB: Completed initialization of buffer pool  
2019-11-25 13:00:56 7144 [Note] InnoDB: Highest supported file format is Barracuda.  
2019-11-25 13:00:56 7144 [Note] InnoDB: 128 rollback segment(s) are active.  
2019-11-25 13:00:56 7144 [Note] InnoDB: Waiting for purge to start  
2019-11-25 13:00:56 7fc286bfd700 InnoDB: Error: page 3 log sequence number 272095898921  
InnoDB: is in the future! Current system log sequence number 272094296184.  
InnoDB: Your database may be corrupt or you may have copied the InnoDB  
InnoDB: tablespace but not the InnoDB log files. See  
InnoDB: [url][http://dev.mysql.com/doc/refman/5.6/en/forcing-innodb-recovery.html[/url]](http://dev.mysql.com/doc/refman/5.6/en/forcing-innodb-recovery.html%5B/url%5D)  
InnoDB: for more information.  
2019-11-25 13:00:56 7fc286bfd700 InnoDB: Error: page 290 log sequence number 272095840933  
InnoDB: is in the future! Current system log sequence number 272094296184.  
InnoDB: Your database may be corrupt or you may have copied the InnoDB  
InnoDB: tablespace but not the InnoDB log files. See  
InnoDB: [url][http://dev.mysql.com/doc/refman/5.6/en/forcing-innodb-recovery.html[/url]](http://dev.mysql.com/doc/refman/5.6/en/forcing-innodb-recovery.html%5B/url%5D)  
InnoDB: for more information.  
… snipped

Help me, please

---

<div class="post-metadata">

**Author:** ![tsvenbla](https://avatars.discourse-cdn.com/v4/letter/t/ea666f/32.png) [@tsvenbla](https://forums.percona.com/u/tsvenbla)\
**Post date:** [December 2, 2019, 2:22am UTC](https://forums.percona.com/t/error-mysql-percona-xtradb-cluster-server-startup-failed/7311/2 "2019-12-02T02:22:15Z")

</div>

Hi!

Have you tried to just delete all contents under on node 2 and start it up again? That way, SST should kick in and copy everything from node 1 or 3.

---

<div class="post-metadata">

**Author:** ![NPXDBCls](https://avatars.discourse-cdn.com/v4/letter/n/57b2e6/32.png) [@NPXDBCls](https://forums.percona.com/u/NPXDBCls)\
**Post date:** [December 2, 2019, 1:46pm UTC](https://forums.percona.com/t/error-mysql-percona-xtradb-cluster-server-startup-failed/7311/3 "2019-12-02T13:46:26Z")

</div>

After removing /var/lib/mysql/grastate.dat, then I was able to start mysql, ty

---

<div class="post-metadata">

**Author:** ![Bruno\_Campos](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/bruno_campos/32/6469_2.png) [@Bruno\_Campos](https://forums.percona.com/u/Bruno_Campos)\
**Post date:** [May 2, 2022, 4:33pm UTC](https://forums.percona.com/t/error-mysql-percona-xtradb-cluster-server-startup-failed/7311/4 "2022-05-02T16:33:35Z")

</div>

Thank you, man!!! You´re a great man!

---

<div class="post-metadata">

**Author:** ![C\_ng\_D\_ng\_Qu\_c](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/c_ng_d_ng_qu_c/32/16781_2.png) [@C\_ng\_D\_ng\_Qu\_c](https://forums.percona.com/u/C_ng_D_ng_Qu_c)\
**Post date:** [June 6, 2024, 6:54am UTC](https://forums.percona.com/t/error-mysql-percona-xtradb-cluster-server-startup-failed/7311/5 "2024-06-06T06:54:01Z")

</div>

Guys, after 5 years of your comment, you save my life!
