# \[ERROR\] \[MY-013709\] \[Server\] Received an error while processing components from manifest file: Failed to load components from manifest file

**URL:** <https://forums.percona.com/t/error-my-013709-server-received-an-error-while-processing-components-from-manifest-file-failed-to-load-components-from-manifest-file/40561>\
**Category:** Percona XtraDB Cluster 8.x\
**Created:** [April 4, 2026, 8:38am UTC](https://forums.percona.com/t/error-my-013709-server-received-an-error-while-processing-components-from-manifest-file-failed-to-load-components-from-manifest-file/40561 "2026-04-04T08:38:41Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![pkm2112](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/pkm2112/32/21433_2.png) [@pkm2112](https://forums.percona.com/u/pkm2112)\
**Post date:** [April 4, 2026, 8:38am UTC](https://forums.percona.com/t/error-my-013709-server-received-an-error-while-processing-components-from-manifest-file-failed-to-load-components-from-manifest-file/40561/1 "2026-04-04T08:38:41Z")

</div>

[node1\_config.txt](https://forums.percona.com/uploads/short-url/mhj5uT1heAl83OuVI95ZBZznEWW.txt) (1.4 KB)

[node2\_config .txt](https://forums.percona.com/uploads/short-url/fyrh36XXAR0v71wYIZPe5VJhZjB.txt) (1.4 KB)

OS version: rhel 9.6  
xtradb version: 8.4.6  
xtrabackup version 8.4.0-4

Keyring Encryption :  
/appsSW/PerconaMYSQL/Percona-XtraDB-Cluster\_8.4.6-6.1\_Linux.x86\_64.glibc2.34/bin/mysqld.my  
{  
“components”: “file://component\_keyring\_file”  
}

/appsSW/PerconaMYSQL/Percona-XtraDB-Cluster\_8.4.6-6.1\_Linux.x86\_64.glibc2.34/lib/plugin/component\_keyring\_file.cnf  
{  
“path”: “/appsDATA/PerconaMYSQL/eK/keyStore”,  
“read\_only”: false  
}

ls -ld /appsDATA/PerconaMYSQL/eK/\*  
-rw-r-----. 1 mysql mysql 210 Apr 4 15:43 /appsDATA/PerconaMYSQL/eK/keyStore

I’m in the process of configuring 3 node cluster. Completed 1st node, cluster instance is up .

In 2nd node when I start Instance, it fails . I see following errors in log

2026-04-04T08:01:41.770066Z 1 [ERROR] [MY-012592] [InnoDB] Operating system error number 2 in a file operation.  
2026-04-04T08:01:41.770114Z 1 [ERROR] [MY-012593] [InnoDB] The error means the system cannot find the path specified.  
2026-04-04T08:01:41.770120Z 1 [ERROR] [MY-012594] [InnoDB] If you are installing InnoDB, remember that you must create directories yourself, InnoDB does not create them.  
2026-04-04T08:01:41.770126Z 1 [ERROR] [MY-012646] [InnoDB] File ./ibdata1: ‘open’ returned OS error 71. Cannot continue operation  
2026-04-04T08:01:41.770158Z 1 [ERROR] [MY-012981] [InnoDB] Cannot continue operation.  
2026-04-04T08:01:57.639228Z 0 [ERROR] [MY-000000] [WSREP-SST] \*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\* FATAL ERROR \*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*  
2026-04-04T08:01:57.639259Z 0 [ERROR] [MY-000000] [WSREP-SST] xtrabackup\_checkpoints missing. xtrabackup/SST failed on DONOR. Check DONOR log  
2026-04-04T08:01:57.639265Z 0 [ERROR] [MY-000000] [WSREP-SST] Line 2430  
2026-04-04T08:01:57.639269Z 0 [ERROR] [MY-000000] [WSREP-SST] \*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*\*  
2026-04-04T08:01:57.639272Z 0 [ERROR] [MY-000000] [WSREP-SST] Cleanup after exit with status:2  
2026-04-04T08:01:57.648888Z 0 [ERROR] [MY-000000] [Galera] ../../../../../percona-xtradb-cluster-galera/gcs/src/gcs\_group.cpp:gcs\_group\_handle\_join\_msg():1346: Will never receive state. Need to abort.

Donor log from 1st node :  
/appsDATA/PerconaMYSQL/data/innobackup.backup.log  
2026-04-04T16:01:57.750519+08:00 0 [Note] [MY-011825] [Xtrabackup] recognized server arguments: --server-id=101 --datadir=/appsDATA/PerconaMYSQL/data --innodb\_buffer\_pool\_size=1073741824 --defaults\_group=mysqld  
2026-04-04T16:01:57.750658+08:00 0 [Note] [MY-011825] [Xtrabackup] recognized client arguments: --no-version-check=1 --parallel=4 --user=mysql.pxc.sst.user --password=\* --socket=/appsDATA/PerconaMYSQL/sockets/pmysql.s0ckeT --lock-ddl --backup=1 --galera-info=1 --transition-key=\* --stream=xbstream --xtrabackup-plugin-dir=/appsSW/PerconaMYSQL/Percona-XtraDB-Cluster\_8.4.6-6.1\_Linux.x86\_64.glibc2.34/bin/pxc\_extra/pxb-8.4/lib/plugin --target-dir=/tmp/pxc\_sst\_L3YP/donor\_xb\_Zk2s  
/appsSW/PerconaMYSQL/Percona-XtraDB-Cluster\_8.4.6-6.1\_Linux.x86\_64.glibc2.34/bin/pxc\_extra/pxb-8.4/bin/xtrabackup version 8.4.0-4 based on MySQL server 8.4.0 Linux (x86\_64) (revision id: c584cb20)  
2026-04-04T16:01:57.750671+08:00 0 [Warning] [MY-011825] [Xtrabackup] version check is removed and --no-version-check is deprecated.  
2026-04-04T16:01:57.750694+08:00 0 [Note] [MY-011825] [Xtrabackup] Connecting to MySQL server host: localhost, user: mysql.pxc.sst.user, password: set, port: not set, socket: /appsDATA/PerconaMYSQL/sockets/pmysql.s0ckeT  
2026-04-04T16:01:57.837764+08:00 0 [Note] [MY-011825] [Xtrabackup] Using server version 8.4.6-6.1  
2026-04-04T16:01:57.857981+08:00 0 [Note] [MY-011825] [Xtrabackup] Executing LOCK TABLES FOR BACKUP …  
2026-04-04T16:01:57.859831+08:00 0 [Note] [MY-011825] [Xtrabackup] uses posix\_fadvise().  
2026-04-04T16:01:57.859874+08:00 0 [Note] [MY-011825] [Xtrabackup] cd to /appsDATA/PerconaMYSQL/data  
2026-04-04T16:01:57.859891+08:00 0 [Note] [MY-011825] [Xtrabackup] open files limit requested 0, set to 8161  
2026-04-04T16:01:57.860435+08:00 0 [Note] [MY-011825] [Xtrabackup] using the following InnoDB configuration:  
2026-04-04T16:01:57.860447+08:00 0 [Note] [MY-011825] [Xtrabackup] innodb\_data\_home\_dir = .  
2026-04-04T16:01:57.860453+08:00 0 [Note] [MY-011825] [Xtrabackup] innodb\_data\_file\_path = ibdata1:12M:autoextend  
2026-04-04T16:01:57.860470+08:00 0 [Note] [MY-011825] [Xtrabackup] innodb\_log\_group\_home\_dir = ./  
2026-04-04T16:01:57.860476+08:00 0 [Note] [MY-011825] [Xtrabackup] innodb\_log\_files\_in\_group = 2  
2026-04-04T16:01:57.860483+08:00 0 [Note] [MY-011825] [Xtrabackup] innodb\_log\_file\_size = 50331648  
xtrabackup: Unknown error 1126  
xtrabackup: Unknown error 3529  
2026-04-04T16:01:57.861217+08:00 0 [ERROR] [MY-013709] [Server] Received an error while processing components from manifest file: Failed to load components from manifest file  
2026-04-04T16:01:57.861262+08:00 0 [ERROR] [MY-011825] [Xtrabackup] failed to init keyring component

I’m able manually run xtrabackup successfully in node1 with additional cmd line argument :

‘–xtrabackup-plugin-dir’.

Is there an option to include this argument for wsrep\_sst\_method=‘xtrabackup-v2’

---

<div class="post-metadata">

**Author:** ![matthewb](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/matthewb/32/34_2.png) [@matthewb](https://forums.percona.com/u/matthewb)\
**Post date:** [April 6, 2026, 3:31pm UTC](https://forums.percona.com/t/error-my-013709-server-received-an-error-while-processing-components-from-manifest-file-failed-to-load-components-from-manifest-file/40561/2 "2026-04-06T15:31:20Z")

</div>

Check SELinux and change to permissive mode: `getenforce`

---

<div class="post-metadata">

**Author:** ![hai.nguyen](https://avatars.discourse-cdn.com/v4/letter/h/41988e/32.png) [@hai.nguyen](https://forums.percona.com/u/hai.nguyen)\
**Post date:** [April 7, 2026, 1:05am UTC](https://forums.percona.com/t/error-my-013709-server-received-an-error-while-processing-components-from-manifest-file-failed-to-load-components-from-manifest-file/40561/3 "2026-04-07T01:05:59Z")

</div>

Hi. You’re hitting this bug [Jira](https://perconadev.atlassian.net/browse/PKG-501) . The plugin directory for PXB 8.4 is not in the correct path as the SST script expected, so xtrabackup fails to initialize the component. This bug has been fixed for RPM package in 8.4.6, but not for generic binary builds.

xtrabackup is expecting the plugin directory in this path:

```auto
--xtrabackup-plugin-dir=/appsSW/PerconaMYSQL/Percona-XtraDB-Cluster_8.4.6-6.1_Linux.x86_64.glibc2.34/bin/pxc_extra/pxb-8.4/lib/plugin

```

However, you should see that this directory doesn’t exist and the plugin directory is actually in this path:

```auto
/appsSW/PerconaMYSQL/Percona-XtraDB-Cluster_8.4.6-6.1_Linux.x86_64.glibc2.34/bin/pxc_extra/pxb-8.4/lib/lib64/xtrabackup/plugin

```

Until this is fixed for the binary builds, a quick workaround is to copy the plugin directory to the correct path:

```auto
cp -ar /appsSW/PerconaMYSQL/Percona-XtraDB-Cluster_8.4.6-6.1_Linux.x86_64.glibc2.34/bin/pxc_extra/pxb-8.4/lib/lib64/xtrabackup/plugin /appsSW/PerconaMYSQL/Percona-XtraDB-Cluster_8.4.6-6.1_Linux.x86_64.glibc2.34/bin/pxc_extra/pxb-8.4/lib

```

---

<div class="post-metadata">

**Author:** ![pkm2112](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/pkm2112/32/21433_2.png) [@pkm2112](https://forums.percona.com/u/pkm2112)\
**Post date:** [April 8, 2026, 4:06am UTC](https://forums.percona.com/t/error-my-013709-server-received-an-error-while-processing-components-from-manifest-file-failed-to-load-components-from-manifest-file/40561/4 "2026-04-08T04:06:57Z")

</div>

I could do that in testing/dev env. In production, I doubt.. compliance dept wouldnt accept

---

<div class="post-metadata">

**Author:** ![pkm2112](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/pkm2112/32/21433_2.png) [@pkm2112](https://forums.percona.com/u/pkm2112)\
**Post date:** [April 11, 2026, 9:01am UTC](https://forums.percona.com/t/error-my-013709-server-received-an-error-while-processing-components-from-manifest-file-failed-to-load-components-from-manifest-file/40561/5 "2026-04-11T09:01:56Z")

</div>

Hi @hai.nguyen

Thanx a lot for your help. What I did was slightly different. Approach is same as your

I copied plugin from xtrabackup

ls -ldt /appsSW/PerconaMYSQL/percona-xtrabackup-8.4.0-4-Linux-x86\_64.glibc2.34/lib/plugin/\*  
-rwxr-xr-x. 1 mysql mysql 7552752 Aug 10 2025 /appsSW/PerconaMYSQL/percona-xtrabackup-8.4.0-4-Linux-x86\_64.glibc2.34/lib/plugin/component\_keyring\_file.so  
-rwxr-xr-x. 1 mysql mysql 5743904 Aug 10 2025 /appsSW/PerconaMYSQL/percona-xtrabackup-8.4.0-4-Linux-x86\_64.glibc2.34/lib/plugin/component\_keyring\_kmip.so  
-rwxr-xr-x. 1 mysql mysql 8749216 Aug 10 2025 /appsSW/PerconaMYSQL/percona-xtrabackup-8.4.0-4-Linux-x86\_64.glibc2.34/lib/plugin/component\_keyring\_kms.so  
-rwxr-xr-x. 1 mysql mysql 5568576 Aug 10 2025 /appsSW/PerconaMYSQL/percona-xtrabackup-8.4.0-4-Linux-x86\_64.glibc2.34/lib/plugin/component\_keyring\_vault.so

Workin as expected . Thanx again

Cheers

---

<div class="post-metadata">

**Author:** ![hai.nguyen](https://avatars.discourse-cdn.com/v4/letter/h/41988e/32.png) [@hai.nguyen](https://forums.percona.com/u/hai.nguyen)\
**Post date:** [April 17, 2026, 4:58am UTC](https://forums.percona.com/t/error-my-013709-server-received-an-error-while-processing-components-from-manifest-file-failed-to-load-components-from-manifest-file/40561/6 "2026-04-17T04:58:23Z")

</div>

Glad I could help. Just a note, to be safe, make sure that you copy the plugin from the same xtrabackup version that is bundled with PXC.

PXC 8.4.6-6 uses xtrabackup version 8.4.0-4, so what you did should be fine.

```auto
# Percona-XtraDB-Cluster_8.4.6-6.1_Linux.x86_64.glibc2.28/bin/pxc_extra/pxb-8.4/bin/xtrabackup --version
Percona-XtraDB-Cluster_8.4.6-6.1_Linux.x86_64.glibc2.28/bin/pxc_extra/pxb-8.4/bin/xtrabackup version 8.4.0-4 based on MySQL server 8.4.0 Linux (x86_64) (revision id: c584cb20)

```

Copying the plugin from a different xtrabackup version could potentially cause issues if there are changes to the plugin between releases.
