# Error in xtrabackup incremental backup

**URL:** <https://forums.percona.com/t/error-in-xtrabackup-incremental-backup/6683>\
**Category:** Percona XtraBackup\
**Created:** [November 14, 2018, 7:38am UTC](https://forums.percona.com/t/error-in-xtrabackup-incremental-backup/6683 "2018-11-14T07:38:51Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![simtardif](https://avatars.discourse-cdn.com/v4/letter/s/6de8d8/32.png) [@simtardif](https://forums.percona.com/u/simtardif)\
**Post date:** [November 14, 2018, 7:38am UTC](https://forums.percona.com/t/error-in-xtrabackup-incremental-backup/6683/1 "2018-11-14T07:38:51Z")

</div>

Hi i’m using xtrabackup for full and incremental backup of my pxc cluster. For some days incremental backup fails on a table (not always the same) with those message :

181114 08:02:19 [01] Copying ./ul@002dbsw@002ddv@002ddrupal/ul\_cache\_container.ibd to /bkpinc/ul@002dbsw@002ddv@002ddrupal/ul\_cache\_container.ibd.delta  
InnoDB: 622592 bytes should have been read. Only 524288 bytes read. Retrying for the remaining bytes.  
InnoDB: 622592 bytes should have been read. Only 524288 bytes read. Retrying for the remaining bytes.  
InnoDB: 622592 bytes should have been read. Only 524288 bytes read. Retrying for the remaining bytes.  
InnoDB: 622592 bytes should have been read. Only 524288 bytes read. Retrying for the remaining bytes.  
InnoDB: 622592 bytes should have been read. Only 524288 bytes read. Retrying for the remaining bytes.  
InnoDB: 622592 bytes should have been read. Only 524288 bytes read. Retrying for the remaining bytes.  
InnoDB: 622592 bytes should have been read. Only 524288 bytes read. Retrying for the remaining bytes.  
InnoDB: 622592 bytes should have been read. Only 524288 bytes read. Retrying for the remaining bytes.  
InnoDB: 622592 bytes should have been read. Only 524288 bytes read. Retrying for the remaining bytes.  
InnoDB: 622592 bytes should have been read. Only 524288 bytes read. Retrying for the remaining bytes.  
InnoDB: Retry attempts for reading partial data failed.  
InnoDB: Tried to read 622592 bytes at offset 0, but was only able to read 524288  
[FATAL] InnoDB: Cannot read from file. OS error number 17.  
2018-11-14 08:02:19 0x7fceff4f3700 InnoDB: Assertion failure in thread 140527023372032 in file ut0ut.cc line 914  
InnoDB: We intentionally generate a memory trap.  
InnoDB: Submit a detailed bug report to [http://bugs.mysql.com](http://bugs.mysql.com).  
InnoDB: If you get repeated assertion failures or crashes, even  
InnoDB: immediately after the mysqld startup, there may be  
InnoDB: corruption in the InnoDB tablespace. Please refer to  
InnoDB: [url][http://dev.mysql.com/doc/refman/5.7/en/forcing-innodb-recovery.html[/url]](http://dev.mysql.com/doc/refman/5.7/en/forcing-innodb-recovery.html%5B/url%5D)  
InnoDB: about forcing recovery.  
13:02:19 UTC - xtrabackup got signal 6 ;  
This could be because you hit a bug or data is corrupted.  
This error can also be caused by malfunctioning hardware.  
Attempting to collect some information that could help diagnose the problem.  
As this is a crash and something is definitely wrong, the information  
collection process might fail.

Thread pointer: 0x0  
Attempting backtrace. You can use the following information to find out  
where mysqld died. If you see no messages after this, something went  
terribly wrong…  
stack\_bottom = 0 thread\_stack 0x10000  
/bin/xtrabackup(my\_print\_stacktrace+0x2c)[0xe627fc]  
/bin/xtrabackup(handle\_fatal\_signal+0x262)[0x9e27e2]  
/lib64/libpthread.so.0(+0xf6d0)[0x7fcf081c76d0]  
/lib64/libc.so.6(gsignal+0x37)[0x7fcf05e42277]  
/lib64/libc.so.6(abort+0x148)[0x7fcf05e43968]  
/bin/xtrabackup[0x6f9cd9]  
/bin/xtrabackup(\_ZN2ib5fatalD1Ev+0xee)[0x8675ce]  
/bin/xtrabackup[0x86170f]  
/bin/xtrabackup(\_Z17os\_file\_read\_funcR9IORequestiPvmm+0x17)[0x861817]  
/bin/xtrabackup(\_Z15xb\_fil\_cur\_readP12xb\_fil\_cur\_t+0x1e5)[0x73ae75]  
/bin/xtrabackup[0x7269e7]  
/bin/xtrabackup[0x72ae78]  
/lib64/libpthread.so.0(+0x7e25)[0x7fcf081bfe25]  
/lib64/libc.so.6(clone+0x6d)[0x7fcf05f0abad]

Full backup is working. Any Idea why it fail ?

---

<div class="post-metadata">

**Author:** ![simtardif](https://avatars.discourse-cdn.com/v4/letter/s/6de8d8/32.png) [@simtardif](https://forums.percona.com/u/simtardif)\
**Post date:** [November 14, 2018, 9:32am UTC](https://forums.percona.com/t/error-in-xtrabackup-incremental-backup/6683/2 "2018-11-14T09:32:13Z")

</div>

I think I found the bug who cause my problems : [url][[PXB-514] LP #1731260: xtrabackup 2.4 incremental crashes with MySQL 5.7 when changed page tracking is used and mix of insert and truncate is executed - Percona JIRA](https://jira.percona.com/browse/PXB-514%5B/url%5D)
