# error in sst xtrabackup

**URL:** <https://forums.percona.com/t/error-in-sst-xtrabackup/3641>\
**Category:** Percona XtraDB Cluster 5.x\
**Created:** [July 28, 2014, 7:50am UTC](https://forums.percona.com/t/error-in-sst-xtrabackup/3641 "2014-07-28T07:50:44Z")\
**Posts on this page:** 4\
**Page:** 1

<div class="post-metadata">

**Author:** ![pathet](https://avatars.discourse-cdn.com/v4/letter/p/b4bc9f/32.png) [@pathet](https://forums.percona.com/u/pathet)\
**Post date:** [July 28, 2014, 7:50am UTC](https://forums.percona.com/t/error-in-sst-xtrabackup/3641/1 "2014-07-28T07:50:44Z")

</div>

Hello,

I get some strange message when I want to perform a sst with xtrabackup.  
The sst failes.

> [@](#):
>
> Get the latest version of Percona XtraBackup, documentation, and help resources:  
> [http://www.percona.com/xb/ubuntu](http://www.percona.com/xb/ubuntu)
> 
> 140728 15:09:23 innobackupex: Connecting to MySQL server with DSN ‘dbi:mysql:;mysql\_read\_default\_file=/etc/mysql/my.cnf;mysql\_read\_default\_group=xtrabackup’ as ‘sst’ (using password: YES).  
> 140728 15:09:23 innobackupex: Connected to MySQL server  
> 140728 15:09:23 innobackupex: Executing a version check against the server…  
> 140728 15:09:23 innobackupex: Done.  
> IMPORTANT: Please check that the backup run completes successfully.  
> At the end of a successful backup run innobackupex  
> prints “completed OK!”.
> 
> innobackupex: Using mysql server version 5.5.34
> 
> innobackupex: Created backup directory /tmp
> 
> 140728 15:09:23 innobackupex: Starting ibbackup with command: xtrabackup\_55 --defaults-file=“/etc/mysql/my.c  
> nf” --defaults-group=“mysqld” --backup --suspend-at-end --target-dir=/mnt/ramdisk --tmpdir=/mnt/ramdisk --stream=tar  
> innobackupex: Waiting for ibbackup (pid=31739) to suspend  
> innobackupex: Suspend file ‘/mnt/ramdisk/xtrabackup\_suspended\_2’
> 
> xtrabackup\_55 version 2.1.8 for Percona Server 5.5.35 Linux (x86\_64) (revision id: undefined)  
> xtrabackup: uses posix\_fadvise().  
> xtrabackup: cd to /var/lib/mysql  
> xtrabackup: using the following InnoDB configuration:  
> xtrabackup: innodb\_data\_home\_dir = ./  
> xtrabackup: innodb\_data\_file\_path = ibdata1:10M:autoextend  
> xtrabackup: innodb\_log\_group\_home\_dir = ./  
> xtrabackup: innodb\_log\_files\_in\_group = 2  
> xtrabackup: innodb\_log\_file\_size = 209715200  
> xtrabackup: using O\_DIRECT
> 
> > > log scanned up to (4370789295766)  
> > > 140728 15:09:23 InnoDB: Operating system error number 24 in a file operation.  
> > > InnoDB: Error number 24 means ‘Too many open files’.  
> > > InnoDB: Some operating system error numbers are described at  
> > > InnoDB: [http://dev.mysql.com/doc/refman/5.5/en/operating-system-error-codes.html](http://dev.mysql.com/doc/refman/5.5/en/operating-system-error-codes.html)  
> > > InnoDB: Error: could not open single-table tablespace file  
> > > InnoDB: ./aswoconfig/sphinx\_config\_types.ibd!  
> > > InnoDB: We do not continue the crash recovery, because the table may become  
> > > InnoDB: corrupt if we cannot apply the log records in the InnoDB log to it.  
> > > InnoDB: To fix the problem and start mysqld:  
> > > InnoDB: 1) If there is a permission problem in the file and mysqld cannot  
> > > InnoDB: open the file, you should modify the permissions.  
> > > InnoDB: 2) If the table is not needed, or you can restore it from a backup,  
> > > InnoDB: then you can remove the .ibd file, and InnoDB will do a normal  
> > > InnoDB: crash recovery and ignore that table.  
> > > InnoDB: 3) If the file system or the disk is broken, and you cannot remove  
> > > InnoDB: the .ibd file, you can set innodb\_force\_recovery \> 0 in my.cnf  
> > > InnoDB: and force InnoDB to continue crash recovery here.  
> > > innobackupex: Error: The xtrabackup child process has died at /usr//bin/innobackupex line 2622.  
> > > ~  
> > > ~  
> > > ~

Have someone a idea for me ?

regards  
Patrick

---

<div class="post-metadata">

**Author:** ![taka-h](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/taka-h/32/1023_2.png) [@taka-h](https://forums.percona.com/u/taka-h)\
**Post date:** [July 28, 2014, 6:16pm UTC](https://forums.percona.com/t/error-in-sst-xtrabackup/3641/2 "2014-07-28T18:16:53Z")

</div>

Have you tried xtrabackup itself only by donner node?

> InnoDB: Error number 24 means ‘Too many open files’.

---

<div class="post-metadata">

**Author:** ![pathet](https://avatars.discourse-cdn.com/v4/letter/p/b4bc9f/32.png) [@pathet](https://forums.percona.com/u/pathet)\
**Post date:** [July 29, 2014, 12:35am UTC](https://forums.percona.com/t/error-in-sst-xtrabackup/3641/3 "2014-07-29T00:35:09Z")

</div>

I tried it by donor mode.  
But I solved it. I set the sst session to

```auto
ulimit -n 1048576

```

---

<div class="post-metadata">

**Author:** ![taka-h](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/taka-h/32/1023_2.png) [@taka-h](https://forums.percona.com/u/taka-h)\
**Post date:** [July 29, 2014, 6:28am UTC](https://forums.percona.com/t/error-in-sst-xtrabackup/3641/4 "2014-07-29T06:28:02Z")

</div>

Hi,

Would you confirm 2 more configuration?

1. open-files-limit (my.cnf)  
[url][MySQL :: MySQL 8.0 Reference Manual :: 5.1.7 Server Command Options](http://dev.mysql.com/doc/refman/5.5/en/server-options.html#option_mysqld_open-files-limit%5B/url%5D)

2. please confirm my.cnf configuration of wsrep\_sst\_method (should be xtrabackup-v2)  
[url][Percona XtraDB Cluster](http://www.percona.com/doc/percona-xtradb-cluster/5.5/manual/xtrabackup_sst.html%5B/url%5D)

If following is repeatable I don’t have any idea.  
[LIST]  
[_]manual back up on donor node by xtrabackup succeed  
[_]sst fail by ‘Too many open files’ error while backing up  
[/LIST] thank you
