# Error in percona logs - pg\_stat\_monitor: pg: out of memory

**URL:** <https://forums.percona.com/t/error-in-percona-logs-pg-stat-monitor-pg-out-of-memory/39083>\
**Category:** PostgreSQL\
**Created:** [August 12, 2025, 6:01am UTC](https://forums.percona.com/t/error-in-percona-logs-pg-stat-monitor-pg-out-of-memory/39083 "2025-08-12T06:01:49Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![ANDiv1976](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/andiv1976/32/20170_2.png) [@ANDiv1976](https://forums.percona.com/u/ANDiv1976)\
**Post date:** [August 12, 2025, 6:01am UTC](https://forums.percona.com/t/error-in-percona-logs-pg-stat-monitor-pg-out-of-memory/39083/1 "2025-08-12T06:01:49Z")

</div>

in the pmm-agent log, we get this error: “pmm-agent: time=“2025-08-12T04:08:25.731+00:00” level=error msg=“getNewBuckets failed: failed to query pg\_stat\_monitor: pq: out of memory” AgentID=daf6b1e1-8cec-4f84-a85b-e6d2f3d346f1 component=agent-builtin type=qan\_postgresql\_pgstatmonitor\_agent”

huge\_pages is enabled in postgresql. the system has huge pages configured based on postgresql memory usage.

when the agent issues this error, metrics from PostgreSQL to Percona stop being received.

pg\_stat\_monitor settings (2.2.0): name | setting ----------------------------------------------±-------- pg\_stat\_monitor.pgsm\_bucket\_time | 60 pg\_stat\_monitor.pgsm\_enable\_overflow | about pg\_stat\_monitor.pgsm\_enable\_pgsm\_query\_id | about pg\_stat\_monitor.pgsm\_enable\_query\_plan | off pg\_stat\_monitor.pgsm\_extract\_comments | off pg\_stat\_monitor.pgsm\_histogram\_buckets | 20 pg\_stat\_monitor.pgsm\_histogram\_max | 30000 pg\_stat\_monitor.pgsm\_histogram\_min | 50 pg\_stat\_monitor.pgsm\_max | 256 pg\_stat\_monitor.pgsm\_max\_buckets | 10 pg\_stat\_monitor.pgsm\_normalized\_query | pg\_stat\_monitor is enabled .pgsm\_overflow\_target | 1 pg\_stat\_monitor.pgsm\_query\_max\_len | 2048 pg\_stat\_monitor.pgsm\_query\_shared\_buffer | 20 pg\_stat\_monitor.pgsm\_track | Top application names pg\_stat\_monitor.pgsm\_track\_ | disabled pg\_stat\_monitor.pgsm\_track\_planning | disabled pg\_stat\_monitor.pgsm\_track\_utility / enabled

pmm-agent version 3.3.0

pg\_stat\_monitor version 2.2.0

---

<div class="post-metadata">

**Author:** ![Agustin\_G](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/agustin_g/32/14111_2.png) [@Agustin\_G](https://forums.percona.com/u/Agustin_G)\
**Post date:** [August 18, 2025, 10:13pm UTC](https://forums.percona.com/t/error-in-percona-logs-pg-stat-monitor-pg-out-of-memory/39083/2 "2025-08-18T22:13:17Z")

</div>

Hi @ANDiv1976,

Have you checked the PostgreSQL and system/OS logs also? Have you checked the memory graphs for that server under PMM?

---

<div class="post-metadata">

**Author:** ![ANDiv1976](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/andiv1976/32/20170_2.png) [@ANDiv1976](https://forums.percona.com/u/ANDiv1976)\
**Post date:** [November 21, 2025, 11:09am UTC](https://forums.percona.com/t/error-in-percona-logs-pg-stat-monitor-pg-out-of-memory/39083/3 "2025-11-21T11:09:38Z")

</div>

The problem of running out of memory is due to the fact that pg\_stat\_monitor does not collapse the same type of queries.

> [@Pg\_stat\_monitor 2.2 - Collapsing similar queries](https://forums.percona.com/t/pg-stat-monitor-2-2-collapsing-similar-queries/39763):
>
> Why doesn’t pg\_stat\_monitor 2.2 collapse such similar queries? Under high TPS, all buckets get filled with identical queries. As a result, it starts consuming more shared memory. It can collapse similar queries. In pg\_stat\_monitor, during just a few seconds of testing, there are 47,000 rows, with a limit of 20 buckets and pgsm\_max of 192MB. Is there a way to collapse similar queries? Which parameter in pg\_stat\_monitor is needed for this? I couldn’t find it in the documentation. …
