# Error in Operator after cluster restore

**URL:** <https://forums.percona.com/t/error-in-operator-after-cluster-restore/14059>\
**Category:** Percona Operator for MySQL\
**Created:** [January 23, 2022, 9:23pm UTC](https://forums.percona.com/t/error-in-operator-after-cluster-restore/14059 "2022-01-23T21:23:35Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![rtanner](https://avatars.discourse-cdn.com/v4/letter/r/f6c823/32.png) [@rtanner](https://forums.percona.com/u/rtanner)\
**Post date:** [January 23, 2022, 9:23pm UTC](https://forums.percona.com/t/error-in-operator-after-cluster-restore/14059/1 "2022-01-23T21:23:35Z")

</div>

After doing a cluster restore, the following error message is repeating in the operator log:

{“level”:“info”,“ts”:1642972814.348997,“caller”:“pxc/controller.go:465”,“msg”:“reconcile replication error”,“err”:“failed to connect to pod ssg-db-pxc-0: Error 1045: Access denied for user ‘operator’@‘10-200-110-218.percona-xtradb-cluster-operator.ssg-db.svc.cluste’ (using password: YES)”}  
The cluster is responding and working as expected, but I’m not sure why this message is repeating as I can access the cluster and I did not change any passwords.

---

<div class="post-metadata">

**Author:** ![rtanner](https://avatars.discourse-cdn.com/v4/letter/r/f6c823/32.png) [@rtanner](https://forums.percona.com/u/rtanner)\
**Post date:** [January 23, 2022, 10:32pm UTC](https://forums.percona.com/t/error-in-operator-after-cluster-restore/14059/2 "2022-01-23T22:32:50Z")

</div>

Figured out that Helm chart was not setup correctly and caused an issue with the operator setup. closing this.

---

<div class="post-metadata">

**Author:** ![Sergey\_Pronin](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/sergey_pronin/32/14887_2.png) [@Sergey\_Pronin](https://forums.percona.com/u/Sergey_Pronin)\
**Post date:** [January 27, 2022, 12:32pm UTC](https://forums.percona.com/t/error-in-operator-after-cluster-restore/14059/3 "2022-01-27T12:32:15Z")

</div>


