# Error - Failed to connect to MySQL server

**URL:** https://forums.percona.com/t/error-failed-to-connect-to-mysql-server/4733
**Category:** Percona XtraBackup
**Created:** [February 18, 2016, 2:46pm UTC](https://forums.percona.com/t/error-failed-to-connect-to-mysql-server/4733 "2016-02-18T14:46:16Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![stevejohnson](https://avatars.discourse-cdn.com/v4/letter/s/a698b9/32.png) [@stevejohnson](https://forums.percona.com/u/stevejohnson)
#### Post date: [February 18, 2016, 2:46pm UTC](https://forums.percona.com/t/error-failed-to-connect-to-mysql-server/4733/1 "2016-02-18T14:46:16Z")

</div>

Hi,  
I have been trying to use the XtraBackup to perform backup on my Percona server (5.5). I’m using Ubuntu 14.04 LTS.  
When i run this command - xtrabackup --backup --datadir=/var/lib/mysql/ --target-dir=/  
data/backups/mysql/

…i get the following error.  
root@mysite:~# xtrabackup --backup --datadir=/var/lib/mysql/ --target-dir=/  
data/backups/mysql/  
160218 14:57:16 version\_check Connecting to MySQL server with DSN ‘dbi:mysql:;m  
ysql\_read\_default\_group=xtrabackup;port=3306;mysql\_socket=/var/run/mysqld/mysqld  
.sock’ as ‘mysql’ (using password: NO).  
Failed to connect to MySQL server: DBI connect(‘;mysql\_read\_default\_group=xtraba  
ckup;port=3306;mysql\_socket=/var/run/mysqld/mysqld.sock’,‘mysql’,…) failed: Ac  
cess denied for user ‘mysql’@‘localhost’ (using password: NO) at - line 1314.  
160218 14:57:16 Connecting to MySQL server host: localhost, user: mysql, passwor  
d: not set, port: 3306, socket: /var/run/mysqld/mysqld.sock  
Failed to connect to MySQL server: Access denied for user ‘mysql’@‘localhost’ (u  
sing password: NO).

Any ideas?  
Thanks.

---

<div class="post-metadata">

### Author: ![apple0315](https://avatars.discourse-cdn.com/v4/letter/a/b19c9b/32.png) [@apple0315](https://forums.percona.com/u/apple0315)
#### Post date: [February 18, 2016, 3:24pm UTC](https://forums.percona.com/t/error-failed-to-connect-to-mysql-server/4733/2 "2016-02-18T15:24:07Z")

</div>

You need to use --user=username --password=password to pass credential

---

<div class="post-metadata">

### Author: ![stevejohnson](https://avatars.discourse-cdn.com/v4/letter/s/a698b9/32.png) [@stevejohnson](https://forums.percona.com/u/stevejohnson)
#### Post date: [February 19, 2016, 12:03pm UTC](https://forums.percona.com/t/error-failed-to-connect-to-mysql-server/4733/3 "2016-02-19T12:03:53Z")

</div>

…thanks, works perfect now!

---

<div class="post-metadata">

### Author: ![Mkdbaeasy](https://avatars.discourse-cdn.com/v4/letter/m/49beb7/32.png) [@Mkdbaeasy](https://forums.percona.com/u/Mkdbaeasy)
#### Post date: [October 11, 2016, 1:29am UTC](https://forums.percona.com/t/error-failed-to-connect-to-mysql-server/4733/4 "2016-10-11T01:29:17Z")

</div>

Hi I’m new to mysql and am trying to follow this approach here is the error am getting:

root@Testserver02# innobackupex --user=bkuser --password=wxcvter --no-timestamp /data/backups/new\_backup  
161011 02:14:38 innobackupex: Starting the backup operation

IMPORTANT: Please check that the backup run completes successfully.  
At the end of a successful backup run innobackupex  
prints “completed OK!”.

161011 02:14:39 version\_check Connecting to MySQL server with DSN ‘dbi:mysql:;mysql\_read\_default\_group=xtrabackup’ as ‘bkuser’ (using password: YES).  
161011 02:14:39 version\_check Connected to MySQL server  
161011 02:14:39 version\_check Executing a version check against the server…  
161011 02:14:40 version\_check Done.  
161011 02:14:40 Connecting to MySQL server host: localhost, user: bkuser, password: set, port: 0, socket: (null)  
Failed to connect to MySQL server: Can’t connect to local MySQL server through socket ‘/tmp/mysql.sock’ ( 2).

Any help or suggestions would be appreciated.

Thanks
