# Empty data on home-dashboard

**URL:** https://forums.percona.com/t/empty-data-on-home-dashboard/6230
**Category:** PMM 1.x
**Created:** [March 5, 2018, 5:17am UTC](https://forums.percona.com/t/empty-data-on-home-dashboard/6230 "2018-03-05T05:17:29Z")
**Posts on this page:** 10
**Page:** 1

<div class="post-metadata">

### Author: ![Myles](https://avatars.discourse-cdn.com/v4/letter/m/779978/32.png) [@Myles](https://forums.percona.com/u/Myles)
#### Post date: [March 5, 2018, 5:17am UTC](https://forums.percona.com/t/empty-data-on-home-dashboard/6230/1 "2018-03-05T05:17:29Z")

</div>

Hi I’m new to PMM. I just setup to monitor two MySQL servers following the same installation process. One machine works well, but the other one has no data at all for the whole row on the home-dashboard page. On other pages like “mysql-overview”, data is complete for both MySQL instances.

I’ve checked “check-network” and everything is OK with latencies \<10ms. Also I checked the log files “pmm-\*.log” on the client machine, as well as the log files on the PMM server inside the docker. The only suspicious thing is in the “prometheus.log” file on the server docker, as following:

[HTML]

```auto

time="2018-03-05T10:41:45Z" level=warning msg="Error on ingesting out-of-order samples" numDropped=42 source="scrape.go:534" 

time="2018-03-05T10:41:45Z" level=warning msg="Scrape health sample discarded" error="sample timestamp out of order" sample=up{instance="db-dedicated.ff.digital", job="mysql"} => 1 &#64;[1520246504.445] source="scrape.go:587" 

time="2018-03-05T10:41:45Z" level=warning msg="Scrape duration sample discarded" error="sample timestamp out of order" sample=scrape_duration_seconds{instance="db-dedicated.ff.digital", job="mysql"} => 1.441987055 &#64;[1520246504.445] source="scrape.go:590" 

time="2018-03-05T10:41:45Z" level=warning msg="Scrape sample count sample discarded" error="sample timestamp out of order" sample=scrape_duration_seconds{instance="db-dedicated.ff.digital", job="mysql"} => 1.441987055 &#64;[1520246504.445] source="scrape.go:593" 

time="2018-03-05T10:41:45Z" level=warning msg="Scrape sample count post-relabeling sample discarded" error="sample timestamp out of order" sample=scrape_duration_seconds{instance="db-dedicated.ff.digital", job="mysql"} => 1.441987055 &#64;[1520246504.445] source="scrape.go:596" 

time="2018-03-05T10:41:46Z" level=warning msg="Error on ingesting out-of-order samples" numDropped=42 source="scrape.go:534" 

time="2018-03-05T10:41:46Z" level=warning msg="Scrape health sample discarded" error="sample timestamp out of order" sample=up{instance="db-dedicated.ff.digital", job="mysql"} => 1 &#64;[1520246506.364] source="scrape.go:587" 

time="2018-03-05T10:41:46Z" level=warning msg="Scrape duration sample discarded" error="sample timestamp out of order" sample=scrape_duration_seconds{instance="db-dedicated.ff.digital", job="mysql"} => 0.625042525 &#64;[1520246506.364] source="scrape.go:590" 

time="2018-03-05T10:41:46Z" level=warning msg="Scrape sample count sample discarded" error="sample timestamp out of order" sample=scrape_duration_seconds{instance="db-dedicated.ff.digital", job="mysql"} => 0.625042525 &#64;[1520246506.364] source="scrape.go:593" 

time="2018-03-05T10:41:46Z" level=warning msg="Scrape sample count post-relabeling sample discarded" error="sample timestamp out of order" sample=scrape_duration_seconds{instance="db-dedicated.ff.digital", job="mysql"} => 0.625042525 &#64;[1520246506.364] source="scrape.go:596" 

time="2018-03-05T10:41:51Z" level=warning msg="Error on ingesting out-of-order samples" numDropped=42 source="scrape.go:534" 

time="2018-03-05T10:41:51Z" level=warning msg="Scrape health sample discarded" error="sample timestamp out of order" sample=up{instance="db-dedicated.ff.digital", job="mysql"} => 1 &#64;[1520246511.373] source="scrape.go:587" 

time="2018-03-05T10:41:51Z" level=warning msg="Scrape duration sample discarded" error="sample timestamp out of order" sample=scrape_duration_seconds{instance="db-dedicated.ff.digital", job="mysql"} => 0.45708211 &#64;[1520246511.373] source="scrape.go:590" 

time="2018-03-05T10:41:51Z" level=warning msg="Scrape sample count sample discarded" error="sample timestamp out of order" sample=scrape_duration_seconds{instance="db-dedicated.ff.digital", job="mysql"} => 0.45708211 &#64;[1520246511.373] source="scrape.go:593" 

time="2018-03-05T10:41:51Z" level=warning msg="Scrape sample count post-relabeling sample discarded" error="sample timestamp out of order" sample=scrape_duration_seconds{instance="db-dedicated.ff.digital", job="mysql"} => 0.45708211 &#64;[1520246511.373] source="scrape.go:596"

```

[/HTML]

But when I checked system time on all MySQL servers, the PMM server docker and the docker host machine, they are all correct. Does any one have an idea?

AFAIK, the only differences between the two MySQL servers are the networks. One is within the same internal network as the PMM server, while the other (the one with no data) is not with slightly different firewall config. But I’m sure all required ports are open.

---

<div class="post-metadata">

### Author: ![lorraine.pocklington](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/lorraine.pocklington/32/37_2.png) [@lorraine.pocklington](https://forums.percona.com/u/lorraine.pocklington)
#### Post date: [March 15, 2018, 3:48am UTC](https://forums.percona.com/t/empty-data-on-home-dashboard/6230/2 "2018-03-15T03:48:06Z")

</div>

Hi there, sorry for the delay, are you still having this problem?

Can I just check you ran through the troubleshooting advice [URL=“[Troubleshooting Percona Monitoring and Management (PMM) Metrics - Percona Database Performance Blog](https://www.percona.com/blog/2018/01/17/troubleshooting-percona-monitoring-and-management-pmm-metrics/)”][https://www.percona.com/blog/2018/01...t-pmm-metrics/[/URL]](https://www.percona.com/blog/2018/01...t-pmm-metrics/%5B/URL%5D) ?  
There’s also a section on checking network here [url][Percona Monitoring and Management](https://www.percona.com/doc/percona-monitoring-and-management/faq.html%5B/url%5D)

Meanwhile I will see if I can find any other information for you.

---

<div class="post-metadata">

### Author: ![Roma\_Novikov](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/roma_novikov/32/1161_2.png) [@Roma\_Novikov](https://forums.percona.com/u/Roma_Novikov)
#### Post date: [March 15, 2018, 5:11am UTC](https://forums.percona.com/t/empty-data-on-home-dashboard/6230/3 "2018-03-15T05:11:58Z")

</div>

[Myles](https://percona.vanillacommunities.com/profile/x/x/41860) , it looks like some problem with Date - time. so better check and runtime sync on your server and client  
Also pls, check the [url][https://YOURSERVER/prometheus/targets[/url]](https://YOURSERVER/prometheus/targets%5B/url%5D) page, is there any errors?  
and [url][https://YOURSERVER/graph/dashboard/db/prometheus[/url]](https://YOURSERVER/graph/dashboard/db/prometheus%5B/url%5D) can also provide some info about the problem

---

<div class="post-metadata">

### Author: ![Myles](https://avatars.discourse-cdn.com/v4/letter/m/779978/32.png) [@Myles](https://forums.percona.com/u/Myles)
#### Post date: [March 16, 2018, 12:31am UTC](https://forums.percona.com/t/empty-data-on-home-dashboard/6230/4 "2018-03-16T00:31:56Z")

</div>

> [@lorraine.pocklington;51093](#):
>
> Hi there, sorry for the delay, are you still having this problem?
> 
> Can I just check you ran through the troubleshooting advice [https://www.percona.com/blog/2018/01…t-pmm-metrics/](https://www.percona.com/blog/2018/01/17/troubleshooting-percona-monitoring-and-management-pmm-metrics/) ?  
> There’s also a section on checking network here [https://www.percona.com/doc/percona-monitoring-and-management/faq.html](https://www.percona.com/doc/percona-monitoring-and-management/faq.html)
> 
> Meanwhile I will see if I can find any other information for you.

Thank you but I’m afraid it does not solve the problem. I followed the troubleshooting and everything seems good.

---

<div class="post-metadata">

### Author: ![Myles](https://avatars.discourse-cdn.com/v4/letter/m/779978/32.png) [@Myles](https://forums.percona.com/u/Myles)
#### Post date: [March 16, 2018, 12:45am UTC](https://forums.percona.com/t/empty-data-on-home-dashboard/6230/5 "2018-03-16T00:45:58Z")

</div>

> [@roma.novikov;51097](#):
>
> [Myles](https://percona.vanillacommunities.com/profile/x/x/41860) , it looks like some problem with Date - time. so better check and runtime sync on your server and client  
> Also pls, check the [https://YOURSERVER/prometheus/targets](https://YOURSERVER/prometheus/targets) page, is there any errors?  
> and [https://YOURSERVER/graph/dashboard/db/prometheus](https://YOURSERVER/graph/dashboard/db/prometheus) can also provide some info about the problem

Hi Roma,

I re-checked the servers and they both have time in sync.  
All prometheus targets `UP` and “last scrape” for 2 “linux” targets are within 3 seconds.  
Prometheus graph shows it’s using very low percentage of resources (\<10% CPU & mem, etc.), everything looks good.

I can also see the following when I visit https://\<PMM\_client\_ip\>:42000/metrics, which means the client is providing Linux related metrics correctly.

> [@](#):
>
> …
> 
> # TYPE node\_cpu counter node\_cpu{cpu=“cpu0”,mode=“guest”} 0 node\_cpu{cpu=“cpu0”,mode=“idle”} 5.589322065e+07 node\_cpu{cpu=“cpu0”,mode=“iowait”} 2.85612548e+06 node\_cpu{cpu=“cpu0”,mode=“irq”} 1112.9 node\_cpu{cpu=“cpu0”,mode=“nice”} 1129.16 node\_cpu{cpu=“cpu0”,mode=“softirq”} 30628.39 node\_cpu{cpu=“cpu0”,mode=“steal”} 0 node\_cpu{cpu=“cpu0”,mode=“system”} 149943.6 node\_cpu{cpu=“cpu0”,mode=“user”} 2.1839946e+06 node\_cpu{cpu=“cpu1”,mode=“guest”} 0 node\_cpu{cpu=“cpu1”,mode=“idle”} 5.618002032e+07 node\_cpu{cpu=“cpu1”,mode=“iowait”} 2.57305446e+06 node\_cpu{cpu=“cpu1”,mode=“irq”} 1115.82 node\_cpu{cpu=“cpu1”,mode=“nice”} 1070.64 node\_cpu{cpu=“cpu1”,mode=“softirq”} 28261.28 node\_cpu{cpu=“cpu1”,mode=“steal”} 0 node\_cpu{cpu=“cpu1”,mode=“system”} 150987.33 node\_cpu{cpu=“cpu1”,mode=“user”} 2.18997028e+06 node\_cpu{cpu=“cpu2”,mode=“guest”} 0 node\_cpu{cpu=“cpu2”,mode=“idle”} 5.854144019e+07 node\_cpu{cpu=“cpu2”,mode=“iowait”} 459594.04 node\_cpu{cpu=“cpu2”,mode=“irq”} 1125.94 node\_cpu{cpu=“cpu2”,mode=“nice”} 475.36 node\_cpu{cpu=“cpu2”,mode=“softirq”} 21815.05 node\_cpu{cpu=“cpu2”,mode=“steal”} 0 node\_cpu{cpu=“cpu2”,mode=“system”} 130786.26 node\_cpu{cpu=“cpu2”,mode=“user”} 2.00093037e+06 node\_cpu{cpu=“cpu3”,mode=“guest”} 0 node\_cpu{cpu=“cpu3”,mode=“idle”} 5.861535097e+07 node\_cpu{cpu=“cpu3”,mode=“iowait”} 403150.54 node\_cpu{cpu=“cpu3”,mode=“irq”} 1122.46 node\_cpu{cpu=“cpu3”,mode=“nice”} 587.5 node\_cpu{cpu=“cpu3”,mode=“softirq”} 21959.08 node\_cpu{cpu=“cpu3”,mode=“steal”} 0 node\_cpu{cpu=“cpu3”,mode=“system”} 124979.33 …

---

<div class="post-metadata">

### Author: ![Myles](https://avatars.discourse-cdn.com/v4/letter/m/779978/32.png) [@Myles](https://forums.percona.com/u/Myles)
#### Post date: [March 16, 2018, 1:12am UTC](https://forums.percona.com/t/empty-data-on-home-dashboard/6230/6 "2018-03-16T01:12:28Z")

</div>

I think I found my own answer, which looks like a bug. The following is the problematic part of page I see at http:///graph/dashboard/db/home-dashboard?orgId=1, and it is the only page I found with problem. Nothing else is wrong. And when I click on the big “no value” box, it takes me to http:///graph/dashboard/db/system-overview?from=now-12h&to=now&var-interval=$\_\_auto\_interval&var-host=All&orgId=1 with no value displaying too.  
The thing I noticed is “var-host=All” in the second URL, which means no specific host is selected. Thus the second page I believe is intended behaviour.  
And finally I solved my problem by changing the “client\_name” value in pmm.yml at client machine, like in the screenshot attached. “db-0.fake.domain” is the old name, and I changed it to “db-dedicated”.

Conclusion: I believe it is a bug that when client\_name(host) contains dot (.) the dashboard landing page will not recognise it as “var-host” value when fetching data from webpage backend, thus displaying “no value” and providing a wrong link.

 ![Screen Shot 2018-03-16 at 14.29.39.png](https://us1.discourse-cdn.com/flex019/uploads/percona1/original/2X/3/355be13560898759ba479ab491a6e6858ad0b672.png)

---

<div class="post-metadata">

### Author: ![jpage](https://avatars.discourse-cdn.com/v4/letter/j/96bed5/32.png) [@jpage](https://forums.percona.com/u/jpage)
#### Post date: [March 16, 2018, 2:58am UTC](https://forums.percona.com/t/empty-data-on-home-dashboard/6230/7 "2018-03-16T02:58:02Z")

</div>

Same problem here with a client with a dot (.) in its name.

---

<div class="post-metadata">

### Author: ![lorraine.pocklington](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/lorraine.pocklington/32/37_2.png) [@lorraine.pocklington](https://forums.percona.com/u/lorraine.pocklington)
#### Post date: [March 16, 2018, 5:33am UTC](https://forums.percona.com/t/empty-data-on-home-dashboard/6230/8 "2018-03-16T05:33:35Z")

</div>

Hi there, thanks for this input, I am just going to bring it to the attention of the PMM team so they can check it out.  
Appreciated!

---

<div class="post-metadata">

### Author: ![vvsaxena](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/vvsaxena/32/1179_2.png) [@vvsaxena](https://forums.percona.com/u/vvsaxena)
#### Post date: [March 16, 2018, 8:34am UTC](https://forums.percona.com/t/empty-data-on-home-dashboard/6230/9 "2018-03-16T08:34:19Z")

</div>

Yeah , its a bug. I also tested and it works fine as far as FQDN does not have dot “.” in between them as “client\_name” in pmm.yml file on pmm client machine. Re-install everything with this fix , it should work.

---

<div class="post-metadata">

### Author: ![lorraine.pocklington](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/lorraine.pocklington/32/37_2.png) [@lorraine.pocklington](https://forums.percona.com/u/lorraine.pocklington)
#### Post date: [March 16, 2018, 8:53am UTC](https://forums.percona.com/t/empty-data-on-home-dashboard/6230/10 "2018-03-16T08:53:03Z")

</div>

Hi all thanks for all your input, this has been registered as a bug, and I’ll update as soon as there’s a status change
