# E \[agentCheckup\] check storage connection: storage check failed with: get S3 object header: NoCredentialProviders: no valid providers in chain. Deprecated. 	For verbose messaging see aws.Config.CredentialsChainVerboseErrors

**URL:** <https://forums.percona.com/t/e-agentcheckup-check-storage-connection-storage-check-failed-with-get-s3-object-header-nocredentialproviders-no-valid-providers-in-chain-deprecated-for-verbose-messaging-see-aws-config-credentialschainverboseerrors/24657>\
**Category:** Percona Operator for MongoDB\
**Tags:** closed-no-reply\
**Created:** [August 24, 2023, 10:52am UTC](https://forums.percona.com/t/e-agentcheckup-check-storage-connection-storage-check-failed-with-get-s3-object-header-nocredentialproviders-no-valid-providers-in-chain-deprecated-for-verbose-messaging-see-aws-config-credentialschainverboseerrors/24657 "2023-08-24T10:52:20Z")\
**Posts on this page:** 1\
**Page:** 1

<div class="post-metadata">

**Author:** ![taglas\_tamas](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/taglas_tamas/32/12172_2.png) [@taglas\_tamas](https://forums.percona.com/u/taglas_tamas)\
**Post date:** [August 24, 2023, 10:52am UTC](https://forums.percona.com/t/e-agentcheckup-check-storage-connection-storage-check-failed-with-get-s3-object-header-nocredentialproviders-no-valid-providers-in-chain-deprecated-for-verbose-messaging-see-aws-config-credentialschainverboseerrors/24657/1 "2023-08-24T10:52:20Z")

</div>

Hello All!

I’ve mentioned this error in my other issue, but the original question on that post was answered, so I marked it resolved and made this post.

I’m using percona operator with percona server ( mongodb ) and trying to save backups to a minio tenant, everything is deployen on my kubernetes cluster.

After I configured the backup provided by the github page of the cr.yaml I’ve discovered that the backup agent gives this error constantly (every 5-7 seconds).

`E [agentCheckup] check storage connection: storage check failed with: get S3 object header: NoCredentialProviders: no valid providers in chain. Deprecated. For verbose messaging see aws.Config.CredentialsChainVerboseErrors`

I’ve tried to give it other secrets e.g. creating users, or api keys. I tried to give different port or protocol to the endpoint, but anytime the backup is enabled on the server, the error is present.

When I connected to the backup-agent to use the pbm cli tool, the same error was present in the status, and in the logs too.

Here are some of the configurations used in my deployment:

```auto
      storages:
        minio:
          type: s3
          s3:
            bucket: test-bucket
            region: test-region
            credentialsSecret: s3-secret
            endpointUrl: https://192.168.0.112:443 # minio tenant endpoint provided on operator console
            insecureSkipTLSVerify: true

```

I’ve tried endpont with http/https and 443/9443/9000 but nothing worked.

Here is the backup I tried to test with, which gives context deadline exceeded, as the backup itself could not be started in 120 seconds:

```auto
apiVersion: psmdb.percona.com/v1
kind: PerconaServerMongoDBBackup
metadata:
  finalizers:
  - delete-backup
  name: backup1
spec:
  clusterName: percona-mongo
  storageName: minio

```

In the referred s3 secret I’ve used the one minio gave me after I created the tenant.

Any help would be appreciated because I’ve looked into the source code of the backup agent , and couldn’t yet found where the error is originating, probably has some issues with the certificates ( possibly ).
