# Downgrade Persona 5.6 to 5.5 failed

**URL:** https://forums.percona.com/t/downgrade-persona-5-6-to-5-5-failed/3315
**Category:** Other MySQL® Questions
**Created:** [March 5, 2014, 5:10am UTC](https://forums.percona.com/t/downgrade-persona-5-6-to-5-5-failed/3315 "2014-03-05T05:10:21Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![Sarge](https://avatars.discourse-cdn.com/v4/letter/s/f475e1/32.png) [@Sarge](https://forums.percona.com/u/Sarge)
#### Post date: [March 5, 2014, 5:10am UTC](https://forums.percona.com/t/downgrade-persona-5-6-to-5-5-failed/3315/1 "2014-03-05T05:10:21Z")

</div>

Hello to everyone !  
Due to some reasons (Handlersocket for Percona 5.6 is not implemented and no any information when it will happen) I’ve tried to downgrade from Percona 5.6 to Percona 5.5 - IT FAILED.  
Step-by step downgrade

Step 1)  
service mysql stop // OK

Step 2)  
[root@falcon238]# rpm -qa | grep Percona-Server  
Percona-Server-shared-compat-5.5.35-rel33.0.611.rhel6.x86\_64  
Percona-Server-shared-56-5.6.15-rel63.0.519.rhel6.x86\_64  
Percona-Server-server-56-5.6.15-rel63.0.519.rhel6.x86\_64  
Percona-Server-devel-56-5.6.15-rel63.0.519.rhel6.x86\_64  
Percona-Server-client-56-5.6.15-rel63.0.519.rhel6.x86\_64

Step 3)  
rpm -qa | grep Percona-Server | xargs rpm -e --nodeps // OK

Step 4)  
yum install Percona-Server-server-55 Percona-Server-client-55 Percona-Server-shared-55 Percona-Server-devel-55 Percona-Server-shared-compat percona-toolkit xtrabackup perl-DBD-MySQL php-mysql MySQL-python  
\*\* Found 3 pre-existing rpmdb problem(s), ‘yum check’ output follows: //not too good…  
percona-xtrabackup-20-2.0.8-587.rhel6.x86\_64 has missing requires of /usr/bin/mysql  
perl-DBD-MySQL-4.022-1.el6.rfx.x86\_64 has missing requires of mysql  
2 : postfix-2.6.6-6.el6\_5.x86\_64 has missing requires of mysql-libs  
Installing : Percona-Server-shared-55-5.5.35-rel33.0.611.rhel6.x86\_64 1/5  
Installing : Percona-Server-client-55-5.5.35-rel33.0.611.rhel6.x86\_64 2/5  
Installing : Percona-Server-server-55-5.5.35-rel33.0.611.rhel6.x86\_64 3/5  
Percona Server is distributed with several useful UDF (User Defined Function) from Maatkit.  
Run the following commands to create these functions:  
mysql -e “CREATE FUNCTION fnv1a\_64 RETURNS INTEGER SONAME ‘libfnv1a\_udf.so’”  
mysql -e “CREATE FUNCTION fnv\_64 RETURNS INTEGER SONAME ‘libfnv\_udf.so’”  
mysql -e “CREATE FUNCTION murmur\_hash RETURNS INTEGER SONAME ‘libmurmur\_udf.so’”  
See [URL=“[Google Code Archive - Long-term storage for Google Code Project Hosting.](http://code.google.com/p/maatkit/source/browse/trunk/udf)”][Google Code Archive - Long-term storage for Google Code Project Hosting.](http://code.google.com/p/maatkit/sou...owse/trunk/udf%5B/URL%5D) for more details  
Installing : Percona-Server-devel-55-5.5.35-rel33.0.611.rhel6.x86\_64 4/5  
Installing : Percona-Server-shared-compat-5.5.35-rel33.0.611.rhel6.x86\_64 5/5  
Verifying : Percona-Server-server-55-5.5.35-rel33.0.611.rhel6.x86\_64 1/5  
Verifying : Percona-Server-shared-55-5.5.35-rel33.0.611.rhel6.x86\_64 2/5  
Verifying : Percona-Server-shared-compat-5.5.35-rel33.0.611.rhel6.x86\_64 3/5  
Verifying : Percona-Server-client-55-5.5.35-rel33.0.611.rhel6.x86\_64 4/5  
Verifying : Percona-Server-devel-55-5.5.35-rel33.0.611.rhel6.x86\_64 5/5

Installed:  
Percona-Server-client-55.x86\_64 0:5.5.35-rel33.0.611.rhel6 Percona-Server-devel-55.x86\_64 0:5.5.35-rel33.0.611.rhel6  
Percona-Server-server-55.x86\_64 0:5.5.35-rel33.0.611.rhel6 Percona-Server-shared-55.x86\_64 0:5.5.35-rel33.0.611.rhel6  
Percona-Server-shared-compat.x86\_64 0:5.5.35-rel33.0.611.rhel6

Complete!

// LOOKS OK more or less - BUT AFTER

Step 5)  
[root@falcon238 imdb]# /usr/sbin/mysqld --skip-grant-tables --user=mysql &  
[1] 19820  
[root@falcon238 imdb]# 140305 10:48:22 [Note] Plugin ‘FEDERATED’ is disabled.  
140305 10:48:22 InnoDB: The InnoDB memory heap is disabled  
140305 10:48:22 InnoDB: Mutexes and rw\_locks use GCC atomic builtins  
140305 10:48:22 InnoDB: Compressed tables use zlib 1.2.3  
140305 10:48:22 InnoDB: Using Linux native AIO  
140305 10:48:22 InnoDB: Initializing buffer pool, size = 128.0M  
140305 10:48:22 InnoDB: Completed initialization of buffer pool  
InnoDB: Error: log file ./ib\_logfile0 is of different size 0 50331648 bytes  
InnoDB: than specified in the .cnf file 0 5242880 bytes!  
140305 10:48:22 [ERROR] Plugin ‘InnoDB’ init function returned error.  
140305 10:48:22 [ERROR] Plugin ‘InnoDB’ registration as a STORAGE ENGINE failed.  
140305 10:48:22 [ERROR] Unknown/unsupported storage engine: InnoDB  
140305 10:48:22 [ERROR] Aborting

140305 10:48:22 [Note] /usr/sbin/mysqld: Shutdown complete

mysql\_upgrade  
Looking for ‘mysql’ as: mysql  
Looking for ‘mysqlcheck’ as: mysqlcheck  
FATAL ERROR: Upgrade failed  
#################################################

Have anybody an advice what to try for proper downgrade ?

Best regards  
Serge

---

<div class="post-metadata">

### Author: ![niljoshi](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/niljoshi/32/16889_2.png) [@niljoshi](https://forums.percona.com/u/niljoshi)
#### Post date: [March 13, 2014, 2:08am UTC](https://forums.percona.com/t/downgrade-persona-5-6-to-5-5-failed/3315/2 "2014-03-13T02:08:04Z")

</div>

Hi,

It seems, this is the main error.

[COLOR=#252C2F]140305 10:48:22 InnoDB: Completed initialization of buffer pool  
[COLOR=#252C2F]InnoDB: Error: log file ./ib\_logfile0 is of different size 0 50331648 bytes  
[COLOR=#252C2F]InnoDB: than specified in the .cnf file 0 5242880 bytes!

If you have properly shutdown MySQL server before downgrade then all changes should have written into disk. In this case, Can you remove logfiles and try to restart MySQL again? MySQL will create new files when logfiles are not in datadir.

---

<div class="post-metadata">

### Author: ![Sarge](https://avatars.discourse-cdn.com/v4/letter/s/f475e1/32.png) [@Sarge](https://forums.percona.com/u/Sarge)
#### Post date: [March 14, 2014, 1:42am UTC](https://forums.percona.com/t/downgrade-persona-5-6-to-5-5-failed/3315/3 "2014-03-14T01:42:46Z")

</div>

Hi and thank you for the hint.  
Before  
/usr/sbin/mysqld --skip-grant-tables --user=mysql &  
I’ve deleted two log files - /var/lib/mysql/ib\_logfile0 & /var/lib/mysql/ib\_logfile1  
and it helped -

but during next stage  
mysql\_upgrade  
I’ve met the following errors

Running ‘mysql\_fix\_privilege\_tables’…  
140314 8:02:32 [ERROR] /usr/sbin/mysqld: Incorrect information in file: ‘./mysql/procs\_priv.frm’  
140314 8:02:32 [ERROR] /usr/sbin/mysqld: Incorrect information in file: ‘./mysql/general\_log.frm’  
140314 8:02:32 [ERROR] /usr/sbin/mysqld: Incorrect information in file: ‘./mysql/slow\_log.frm’  
140314 8:02:32 [ERROR] /usr/sbin/mysqld: Incorrect information in file: ‘./performance\_schema/events\_statements\_summary\_by\_digest.frm’  
140314 8:02:32 [ERROR] /usr/sbin/mysqld: Incorrect information in file: ‘./performance\_schema/host\_cache.frm’  
140314 8:02:32 [ERROR] /usr/sbin/mysqld: Incorrect information in file: ‘./performance\_schema/events\_statements\_summary\_by\_digest.frm’  
140314 8:02:32 [ERROR] /usr/sbin/mysqld: Incorrect information in file: ‘./performance\_schema/host\_cache.frm’  
140314 8:02:33 [ERROR] /usr/sbin/mysqld: Incorrect information in file: ‘./mysql/general\_log.frm’  
140314 8:02:33 [ERROR] /usr/sbin/mysqld: Incorrect information in file: ‘./mysql/slow\_log.frm’  
140314 8:02:34 [ERROR] /usr/sbin/mysqld: Incorrect information in file: ‘./mysql/procs\_priv.frm’  
140314 8:02:34 [ERROR] /usr/sbin/mysqld: Incorrect information in file: ‘./mysql/procs\_priv.frm’  
140314 8:02:34 [ERROR] /usr/sbin/mysqld: Incorrect information in file: ‘./mysql/procs\_priv.frm’  
140314 8:02:34 [ERROR] /usr/sbin/mysqld: Incorrect information in file: ‘./mysql/procs\_priv.frm’  
140314 8:02:34 [ERROR] /usr/sbin/mysqld: Incorrect information in file: ‘./mysql/procs\_priv.frm’  
140314 8:02:36 [ERROR] /usr/sbin/mysqld: Incorrect information in file: ‘./mysql/procs\_priv.frm’  
ERROR 1033 (HY000) at line 80: Incorrect information in file: ‘./mysql/procs\_priv.frm’  
ERROR 1033 (HY000) at line 86: Incorrect information in file: ‘./mysql/general\_log.frm’  
ERROR 1243 (HY000) at line 87: Unknown prepared statement handler (stmt) given to EXECUTE  
ERROR 1243 (HY000) at line 88: Unknown prepared statement handler (stmt) given to DEALLOCATE PREPARE  
ERROR 1033 (HY000) at line 94: Incorrect information in file: ‘./mysql/slow\_log.frm’  
ERROR 1243 (HY000) at line 95: Unknown prepared statement handler (stmt) given to EXECUTE  
ERROR 1243 (HY000) at line 96: Unknown prepared statement handler (stmt) given to DEALLOCATE PREPARE  
ERROR 1033 (HY000) at line 719: Incorrect information in file: ‘./mysql/general\_log.frm’  
ERROR 1033 (HY000) at line 730: Incorrect information in file: ‘./mysql/slow\_log.frm’  
ERROR 1033 (HY000) at line 849: Incorrect information in file: ‘./mysql/procs\_priv.frm’  
ERROR 1033 (HY000) at line 853: Incorrect information in file: ‘./mysql/procs\_priv.frm’  
ERROR 1033 (HY000) at line 857: Incorrect information in file: ‘./mysql/procs\_priv.frm’  
ERROR 1033 (HY000) at line 861: Incorrect information in file: ‘./mysql/procs\_priv.frm’  
ERROR 1033 (HY000) at line 865: Incorrect information in file: ‘./mysql/procs\_priv.frm’  
ERROR 1033 (HY000) at line 1146: Incorrect information in file: ‘./mysql/procs\_priv.frm’  
FATAL ERROR: Upgrade failed

* * *

So that, please, let me know one more hint how to go through  
mysql\_upgrade  
without the errors.

Waiting for your reply,

---

<div class="post-metadata">

### Author: ![niljoshi](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/niljoshi/32/16889_2.png) [@niljoshi](https://forums.percona.com/u/niljoshi)
#### Post date: [March 18, 2014, 4:43am UTC](https://forums.percona.com/t/downgrade-persona-5-6-to-5-5-failed/3315/4 "2014-03-18T04:43:40Z")

</div>

Hi,

I hope you have checked this before downgrade. [url][https://dev.mysql.com/doc/refman/5.6/en/downgrading-to-previous-series.html[/url]](https://dev.mysql.com/doc/refman/5.6/en/downgrading-to-previous-series.html%5B/url%5D)  
Generally, for this kind of error for mysql tables solved by creating mysql db from scratch. If you have old backup (of 5.5) then you can also restore those files for specific tables. Something like this [url][innodb - Cannot open table mysql/innodb\_index\_stats - Database Administrators Stack Exchange](http://dba.stackexchange.com/questions/48166/cannot-open-table-mysql-innodb-index-stats%5B/url%5D) and check.
