# Disable InnoDB in 5.6

**URL:** <https://forums.percona.com/t/disable-innodb-in-5-6/1726>\
**Category:** Other MySQL® Questions\
**Created:** [December 21, 2011, 4:20pm UTC](https://forums.percona.com/t/disable-innodb-in-5-6/1726 "2011-12-21T16:20:42Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![LarryDavid](https://avatars.discourse-cdn.com/v4/letter/l/c89c15/32.png) [@LarryDavid](https://forums.percona.com/u/LarryDavid)\
**Post date:** [December 21, 2011, 4:20pm UTC](https://forums.percona.com/t/disable-innodb-in-5-6/1726/1 "2011-12-21T16:20:42Z")

</div>

Previous versions I could disable InnoDB with a simple

skip-innodb

in my.cnf

With version 5.6x there seems to be some confusion on how to do this.

I have tried various options such as:

ignore\_builtin\_innodb  
ignore-builtin-innodb

None work and mysql will always fail to start with

[ERROR] Unknown/unsupported storage engine: InnoDB

I believe this is because those statements force MySQL to use the InnoDB plugin instead and as I don’t specify where to find it, it fails.

The only thing I can do is this:

default\_storage\_engine = MyISAM

That works in that all tables used are MyISAM (which is what I want). But InnoDB is still used and it seems a waste considering it takes up so much memory.

There are around 40 MyISAM tables using a total diskspace of 4Mb. Yet MySQL is using up 640Mb - the bulk of which is probably being allocated to InnoDB.

I know that InnoDB is the engine of choice now but why can I not run MySQL with it totally disabled and not using memory like in previous versions?

Is it because I’m using the non production / development version 5.6.x ? I think I had similar problems with 5.5.x

If InnoDB can not be disabled what can I do to set it’s memory footprint to near zero?

---

<div class="post-metadata">

**Author:** ![LarryDavid](https://avatars.discourse-cdn.com/v4/letter/l/c89c15/32.png) [@LarryDavid](https://forums.percona.com/u/LarryDavid)\
**Post date:** [December 26, 2011, 2:01pm UTC](https://forums.percona.com/t/disable-innodb-in-5-6/1726/2 "2011-12-26T14:01:20Z")

</div>

Could not find a solution anywhere so dropped back down to 5.5x

skip-innodb in my.cnf

did the trick. innodb not loading as requested and not using up memory.

---

<div class="post-metadata">

**Author:** ![sterin71](https://avatars.discourse-cdn.com/v4/letter/s/5e9695/32.png) [@sterin71](https://forums.percona.com/u/sterin71)\
**Post date:** [December 26, 2011, 4:55pm UTC](https://forums.percona.com/t/disable-innodb-in-5-6/1726/3 "2011-12-26T16:55:33Z")

</div>

(Although you have already downgraded and solved it that way)  
LarryDavid wrote on Wed, 21 December 2011 22:50

> [@](#):
>
> If InnoDB can not be disabled what can I do to set it’s memory footprint to near zero?

Something like:

innodb\_buffer\_pool\_size = 8M

Which was the previous default value is probably a good start.
