# Data replication

**URL:** <https://forums.percona.com/t/data-replication/2418>\
**Category:** Percona XtraDB Cluster 5.x\
**Created:** [May 1, 2012, 3:26am UTC](https://forums.percona.com/t/data-replication/2418 "2012-05-01T03:26:47Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![HTF1](https://avatars.discourse-cdn.com/v4/letter/h/df788c/32.png) [@HTF1](https://forums.percona.com/u/HTF1)\
**Post date:** [May 1, 2012, 3:26am UTC](https://forums.percona.com/t/data-replication/2418/1 "2012-05-01T03:26:47Z")

</div>

Hi,

I would like to ask about data replication on the node that has been re-joined to the cluster after failure. What happens if someone queries a table that hasn’t yet been synced? Will they get old stale data, or does the cluster wait until it is in sync before replying? Essentially, is it possible to get inconsistent results from different nodes?

Regards

---

<div class="post-metadata">

**Author:** ![ayurchen](https://avatars.discourse-cdn.com/v4/letter/a/35a633/32.png) [@ayurchen](https://forums.percona.com/u/ayurchen)\
**Post date:** [May 1, 2012, 11:19am UTC](https://forums.percona.com/t/data-replication/2418/2 "2012-05-01T11:19:13Z")

</div>

The node will reject all commands except SHOW/SET until it catches up with the cluster.

However even when the node is in the SYNCED state, if you try hard enough you can still read stale data. To avoid that you can set wsrep\_causal\_reads session variable, it will guarantee that the client read will happen after all writes that it saw at the cost of some additional latency. CAUTION: you should set it only per session!
