# Crash of mysql@bootstrap

**URL:** https://forums.percona.com/t/crash-of-mysql-bootstrap/16002
**Category:** Percona XtraDB Cluster 8.x
**Created:** [June 6, 2022, 6:24pm UTC](https://forums.percona.com/t/crash-of-mysql-bootstrap/16002 "2022-06-06T18:24:34Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![sadhpuxguru](https://avatars.discourse-cdn.com/v4/letter/s/a4c791/32.png) [@sadhpuxguru](https://forums.percona.com/u/sadhpuxguru)
#### Post date: [June 6, 2022, 6:24pm UTC](https://forums.percona.com/t/crash-of-mysql-bootstrap/16002/1 "2022-06-06T18:24:34Z")

</div>

I have a one-node Xtra DB cluster running and it will occasionally crash and needs to be restarted.

Here’s what journalctl -xe shows:

Jun 06 17:44:48 hb-db-masking systemd[1]: mysql@bootstrap.service: Main process exited, code=exited, status=2/INVALIDARGUMENT  
Jun 06 17:44:48 hb-db-masking mysql-systemd[10396]: /usr/bin/mysql-systemd: line 233: kill: (6908) - No such process  
Jun 06 17:44:48 hb-db-masking mysql-systemd[10396]: WARNING: mysql already dead  
Jun 06 17:44:48 hb-db-masking mysql-systemd[10396]: ERROR! Stale PID file: /var/run/mysqld/mysqld.pid  
Jun 06 17:44:48 hb-db-masking systemd[1]: mysql@bootstrap.service: Control process exited, code=exited status=3  
Jun 06 17:44:48 hb-db-masking systemd[1]: mysql@bootstrap.service: Failed with result ‘exit-code’.

from /var/log/mysql/error.log:  
2022-06-06T17:44:46.871719Z 0 [Warning] [MY-000000] [Galera] Handshake failed: peer did not return a certificate  
2022-06-06T17:44:46.959719Z 0 [Warning] [MY-000000] [Galera] Handshake failed: peer did not return a certificate  
2022-06-06T17:44:47.988049Z 0 [Warning] [MY-000000] [Galera] Handshake failed: http request  
terminate called after throwing an instance of ‘boost::exception\_detail::clone\_impl\<boost::exception\_detail::error\_info\_injectorstd::system\_error \>’  
what(): remote\_endpoint: Transport endpoint is not connected  
2022-06-06T17:44:48.045571Z 0 [Note] [MY-000000] [WSREP] Initiating SST cancellation  
17:44:48 UTC - mysqld got signal 6 ;  
Most likely, you have hit a bug, but this error can also be caused by malfunctioning hardware.

Build ID: 712cedd01992d40a9e0f9779e6425e7089c32870  
Server Version: 8.0.27-18.1 Percona XtraDB Cluster (GPL), Release rel18, Revision ac35177, WSREP version 26.4.3, wsrep\_26.4.3

Thread pointer: 0x0  
Attempting backtrace. You can use the following information to find out  
where mysqld died. If you see no messages after this, something went  
terribly wrong…  
stack\_bottom = 0 thread\_stack 0x100000  
/usr/sbin/mysqld(my\_print\_stacktrace(unsigned char const\*, unsigned long)+0x3d) [0x55ca77ff922d]  
/usr/sbin/mysqld(handle\_fatal\_signal+0x3c3) [0x55ca77201063]  
/lib/x86\_64-linux-gnu/libpthread.so.0(+0x12980) [0x7fd35b97e980]  
/lib/x86\_64-linux-gnu/libc.so.6(gsignal+0xc7) [0x7fd359a83e87]  
/lib/x86\_64-linux-gnu/libc.so.6(abort+0x141) [0x7fd359a857f1]  
/usr/lib/x86\_64-linux-gnu/libstdc++.so.6(+0x8c957) [0x7fd35a478957]  
/usr/lib/x86\_64-linux-gnu/libstdc++.so.6(+0x92ae6) [0x7fd35a47eae6]  
/usr/lib/x86\_64-linux-gnu/libstdc++.so.6(+0x92b21) [0x7fd35a47eb21]  
/usr/lib/x86\_64-linux-gnu/libstdc++.so.6(+0x92d54) [0x7fd35a47ed54]  
/usr/lib/galera4/libgalera\_smm.so(+0x6fd79) [0x7fd34d7d3d79]  
/usr/lib/galera4/libgalera\_smm.so(+0x6fe97) [0x7fd34d7d3e97]  
/usr/lib/galera4/libgalera\_smm.so(+0x7f481) [0x7fd34d7e3481]  
/usr/lib/galera4/libgalera\_smm.so(+0x82991) [0x7fd34d7e6991]  
/usr/lib/galera4/libgalera\_smm.so(+0x89759) [0x7fd34d7ed759]  
/usr/lib/galera4/libgalera\_smm.so(+0x79324) [0x7fd34d7dd324]  
/usr/lib/galera4/libgalera\_smm.so(+0x683ad) [0x7fd34d7cc3ad]  
/usr/lib/galera4/libgalera\_smm.so(+0x16e988) [0x7fd34d8d2988]  
/usr/lib/galera4/libgalera\_smm.so(+0x19deca) [0x7fd34d901eca]  
/usr/lib/galera4/libgalera\_smm.so(+0x19e1d2) [0x7fd34d9021d2]  
/lib/x86\_64-linux-gnu/libpthread.so.0(+0x76db) [0x7fd35b9736db]  
/lib/x86\_64-linux-gnu/libc.so.6(clone+0x3f) [0x7fd359b6661f]  
You may download the Percona XtraDB Cluster operations manual by visiting  
[Percona XtraDB Cluster – The MySQL Clustering Solution](http://www.percona.com/software/percona-xtradb-cluster/). You may find information  
in the manual which will help you identify the cause of the crash.  
Log of wsrep recovery (–wsrep-recover):  
INFO: WSREP: Running position recovery with --log\_error=‘/var/lib/mysql/wsrep\_recovery\_verbose.q2XKMm’ --pid-file=‘/var/lib/mysql/hb-db-masking-recover.pid’  
INFO: WSREP: Recovered position a34b8e50-cc71-11ec-adbc-0f55e3e4c669:897772

Not sure where to look next?

---

<div class="post-metadata">

### Author: ![matthewb](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/matthewb/32/34_2.png) [@matthewb](https://forums.percona.com/u/matthewb)
#### Post date: [June 6, 2022, 6:40pm UTC](https://forums.percona.com/t/crash-of-mysql-bootstrap/16002/2 "2022-06-06T18:40:04Z")

</div>

Was this a brand new node, initialized from scratch? Or are your converting/upgrading? What does your hardware and mysql config look like?

---

<div class="post-metadata">

### Author: ![sadhpuxguru](https://avatars.discourse-cdn.com/v4/letter/s/a4c791/32.png) [@sadhpuxguru](https://forums.percona.com/u/sadhpuxguru)
#### Post date: [June 6, 2022, 10:48pm UTC](https://forums.percona.com/t/crash-of-mysql-bootstrap/16002/3 "2022-06-06T22:48:52Z")

</div>

Yes, brand new node, initialized from scratch.

It’s a Ubuntu 18.04 on VMware. 4GB ram, 3GB free. 4 CPUs.  
I can try to post the whole thing if that’s helpful, but it’s mainly defaults in mysql.cnf, with the addition of the first node changed:  
cat /etc/mysql/mysql.conf.d/mysqld.cnf  
'# Template my.cnf for PXC  
'# Edit to your requirements.  
wsrep\_provider\_options=”socket.ssl\_key=server-key.pem;socket.ssl\_cert=server-cert.pem;socket.ssl\_ca=ca.pem”
