# Change of InnoDB page size at XtraDB Cluster 5.7.18

**URL:** <https://forums.percona.com/t/change-of-innodb-page-size-at-xtradb-cluster-5-7-18/5746>\
**Category:** Percona XtraDB Cluster 5.x\
**Created:** [July 19, 2017, 3:40am UTC](https://forums.percona.com/t/change-of-innodb-page-size-at-xtradb-cluster-5-7-18/5746 "2017-07-19T03:40:07Z")\
**Posts on this page:** 1\
**Page:** 1

<div class="post-metadata">

**Author:** ![sigim](https://avatars.discourse-cdn.com/v4/letter/s/bbe5ce/32.png) [@sigim](https://forums.percona.com/u/sigim)\
**Post date:** [July 19, 2017, 3:40am UTC](https://forums.percona.com/t/change-of-innodb-page-size-at-xtradb-cluster-5-7-18/5746/1 "2017-07-19T03:40:07Z")

</div>

Hi,

as our servers (Ubuntu 16.04.1) run on SSDs with 4k blocks (ext4), I tried to change the InnoDB page size from 16K to 4K as suggested in several performance guides. As this is a new server, there is no data which can get lost. I tried it this way:

1. Install XtraDB Cluster ([https://www.percona.com/doc/percona-xtradb-cluster/LATEST/install/apt.html](https://www.percona.com/doc/percona-xtradb-cluster/LATEST/install/apt.html)) and run

> [@](#):
>
> service mysql stop

1. Created an own my.cnf with

```auto
[mysqld]
innodb-page-size=4k

```

1. Delete MySQL data with

> [@](#):
>
> rm /var/lib/mysql/\* -R

1. Initialize new MySQL Instance

> [@](#):
>
> mysqld --defaults-file=my.cnf --initialize --user=mysql

This fails with the following error:

[ERROR] InnoDB: Invalid page size=4096

Is there another way to change the innodb-page-size for the XtraDB Cluster? I’m just curious, because this works for Standard MySQL 5.7 Server.

Thanks.
