# can't start percona cluster 8.019 for the first time.

**URL:** <https://forums.percona.com/t/cant-start-percona-cluster-8-019-for-the-first-time/7844>\
**Category:** Percona XtraDB Cluster 8.x\
**Created:** [August 4, 2020, 12:02pm UTC](https://forums.percona.com/t/cant-start-percona-cluster-8-019-for-the-first-time/7844 "2020-08-04T12:02:32Z")\
**Posts on this page:** 10\
**Page:** 1

<div class="post-metadata">

**Author:** ![DBA100](https://avatars.discourse-cdn.com/v4/letter/d/b3f665/32.png) [@DBA100](https://forums.percona.com/u/DBA100)\
**Post date:** [August 4, 2020, 12:02pm UTC](https://forums.percona.com/t/cant-start-percona-cluster-8-019-for-the-first-time/7844/1 "2020-08-04T12:02:32Z")

</div>

I setup percona xtra cluster and I tried to bootstrap my cluster for the first time, and&nbsp;this is my my.cnf of primary node :  
  
# Template my.cnf for PXC  
  
# Edit to your requirements.  
  
[client]  
  
socket=/var/lib/mysql/mysql.sock  
  
  
  
[mysqld]  
  
server-id=1  
  
datadir=/var/lib/mysql  
  
socket=/var/lib/mysql/mysql.sock  
  
log-error=/var/log/mysqld.log  
  
pid-file=/var/run/mysqld/mysqld.pid  
  
  
  
#disable pxc-encrypt-cluster-traffic  
  
# pxc-encrypt-cluster-traffic=OFF  
  
  
  
user=mysql

## Each node of the cluster must use the same SSL certificates, instructed by percona 8.0.12 menu

#wsrep\_provider\_options=“socket.ssl\_key=server-key.pem;socket.ssl\_cert=server cert.pem;socket.ssl\_ca=ca.pem”  
  
  
  
#[sst]  
  
#encrypt=4  
  
#ssl-key=server-key.pem  
  
#ssl-ca=ca.pem  
  
#ssl-cert=server-cert.pem  
  
  
  
# Binary log expiration period is 604800 seconds, which equals 7 days  
binlog\_expire\_logs\_seconds=604800  
  
  
  
######## wsrep ###############  
  
# Path to Galera library  
  
wsrep\_provider=/usr/lib64/galera4/libgalera\_smm.so  
  
# Cluster name  
  
wsrep\_cluster\_name=pxc-cluster  
  
# Cluster connection URL contains IPs of nodes  
  
#If no IP is found, this implies that a new cluster needs to be created,  
  
#in order to do that you need to bootstrap this node  
  
#wsrep\_cluster\_address=gcomm://  
  
wsrep\_cluster\_address=gcomm://\<node 1 IP\>,\<node 2 IP\>,\<node 3 IP\>  
  
  
  
default\_storage\_engine=InnoDB  
  
  
  
# In order for Galera to work correctly binlog format should be ROW  
  
binlog\_format=ROW  
  
  
  
# Slave thread to use  
  
wsrep\_slave\_threads=8  
  
  
wsrep\_log\_conflicts  
  
  
  
# This changes how InnoDB autoincrement locks are managed and is a requirement for Galera  
innodb\_autoinc\_lock\_mode=2

# Node IP address

wsrep\_node\_address=192.168.x.x  
&nbsp;  
  
  
#If wsrep\_node\_name is not specified, &nbsp;then system hostname will be used. Changed to the name of the host!  
  
wsrep\_node\_name=perconanode1  
  
  
#pxc\_strict\_mode allowed values: DISABLED,PERMISSIVE,ENFORCING,MASTER  
pxc\_strict\_mode=ENFORCING  
  
  
  
# SST method  
  
wsrep\_sst\_method=xtrabackup-v2  
  
and I bootstrap using:  
&nbsp; systemctl start mysql@bootstrap.service  
  
the first node is ok but when second node just start and it expected to join the cluster automatically, but it can’t start with error message in the error log: /var/log/mysqld.log shown:  
  
“  
020-08-04T10:17:02.177175Z 0 [Note] [MY-000000] [Galera] PC protocol downgrade 1 -\> 0  
2020-08-04T10:17:02.177249Z 0 [Note] [MY-000000] [Galera] Current view of cluster as seen by this node  
view ((empty))  
2020-08-04T10:17:02.177444Z 0 [ERROR] [MY-000000] [Galera] failed to open gcomm backend connection: 110: failed to reach primary view (pc.wait\_prim\_timeout): 110 (Connection timed out)  
&nbsp; &nbsp; at gcomm/src/pc.cpp:connect():159  
2020-08-04T10:17:02.177477Z 0 [ERROR] [MY-000000] [Galera] gcs/src/gcs\_core.cpp:gcs\_core\_open():220: Failed to open backend connection: -110 (Connection timed out)  
2020-08-04T10:17:02.177789Z 0 [ERROR] [MY-000000] [Galera] gcs/src/gcs.cpp:gcs\_open():1700: Failed to open channel ‘pxc-cluster’ at ‘gcomm://\<IP address of 3 x nodes\>’: -110 (Connection timed out)  
2020-08-04T10:17:02.177824Z 0 [ERROR] [MY-000000] [Galera] gcs connect failed: Connection timed out  
2020-08-04T10:17:02.177854Z 0 [ERROR] [MY-000000] [WSREP] Provider/Node (gcomm://\<IP address of 3 x nodes\>) failed to establish connection with cluster (reason: 7)  
2020-08-04T10:17:02.177880Z 0 [ERROR] [MY-010119] [Server] Aborting  
2020-08-04T10:17:02.178213Z 0 [System] [MY-010910] [Server] /usr/sbin/mysqld: Shutdown complete (mysqld 8.0.19-10) &nbsp;Percona XtraDB Cluster (GPL), Release rel10, Revision 727f180, WSREP version 26.4.3.  
2020-08-04T10:17:02.178578Z 0 [Note] [MY-000000] [Galera] dtor state: CLOSED  
2020-08-04T10:17:02.178630Z 0 [Note] [MY-000000] [Galera] MemPool(TrxHandleSlave): hit ratio: 0, misses: 0, in use: 0, in pool: 0  
2020-08-04T10:17:02.181657Z 0 [Note] [MY-000000] [Galera] apply mon: entered 0  
2020-08-04T10:17:02.184854Z 0 [Note] [MY-000000] [Galera] apply mon: entered 0  
2020-08-04T10:17:02.188101Z 0 [Note] [MY-000000] [Galera] apply mon: entered 0  
2020-08-04T10:17:02.188150Z 0 [Note] [MY-000000] [Galera] cert index usage at exit 0  
2020-08-04T10:17:02.188165Z 0 [Note] [MY-000000] [Galera] cert trx map usage at exit 0  
2020-08-04T10:17:02.188177Z 0 [Note] [MY-000000] [Galera] deps set usage at exit 0  
2020-08-04T10:17:02.188198Z 0 [Note] [MY-000000] [Galera] avg deps dist 0  
2020-08-04T10:17:02.188212Z 0 [Note] [MY-000000] [Galera] avg cert interval 0  
2020-08-04T10:17:02.188224Z 0 [Note] [MY-000000] [Galera] cert index size 0  
2020-08-04T10:17:02.188272Z 0 [Note] [MY-000000] [Galera] Service thread queue flushed.  
2020-08-04T10:17:02.188313Z 0 [Note] [MY-000000] [Galera] wsdb trx map usage 0 conn query map usage 0  
2020-08-04T10:17:02.188332Z 0 [Note] [MY-000000] [Galera] MemPool(LocalTrxHandle): hit ratio: 0, misses: 0, in use: 0, in pool: 0  
2020-08-04T10:17:02.189323Z 0 [Note] [MY-000000] [Galera] Flushing memory map to disk…  
  
”  
why cluster can’t form?  
  
when I was doing mariaDB everything is easy including my.cnf, but not for percona, very hard to form a cluster, any reason for it?

---

<div class="post-metadata">

**Author:** ![MirSos](https://avatars.discourse-cdn.com/v4/letter/m/53a042/32.png) [@MirSos](https://forums.percona.com/u/MirSos)\
**Post date:** [August 5, 2020, 2:55am UTC](https://forums.percona.com/t/cant-start-percona-cluster-8-019-for-the-first-time/7844/2 "2020-08-05T02:55:09Z")

</div>

PXC-8.0 have pxc\_encrypt\_cluster\_traffic enable by default, and you have in your config:  
# pxc-encrypt-cluster-traffic=OFF

---

<div class="post-metadata">

**Author:** ![DBA100](https://avatars.discourse-cdn.com/v4/letter/d/b3f665/32.png) [@DBA100](https://forums.percona.com/u/DBA100)\
**Post date:** [August 5, 2020, 2:56am UTC](https://forums.percona.com/t/cant-start-percona-cluster-8-019-for-the-first-time/7844/3 "2020-08-05T02:56:30Z")

</div>

"PXC-8.0 have pxc\_encrypt\_cluster\_traffic enable by default,&nbsp;"  
if no specify , it will be ON ?  
“and you have in your config:  
# pxc-encrypt-cluster-traffic=OFF”  
so should I make it ON or OFF ?

---

<div class="post-metadata">

**Author:** ![DBA100](https://avatars.discourse-cdn.com/v4/letter/d/b3f665/32.png) [@DBA100](https://forums.percona.com/u/DBA100)\
**Post date:** [August 5, 2020, 3:01am UTC](https://forums.percona.com/t/cant-start-percona-cluster-8-019-for-the-first-time/7844/4 "2020-08-05T03:01:01Z")

</div>

what I found out is I have to set it off,&nbsp;pxc-encrypt-cluster-traffic=OFF, it make it works!&nbsp;  
any idea?&nbsp;  
What if I want to make it on? this is the encryption between percona MySQL or between application and percona MySQL ?

---

<div class="post-metadata">

**Author:** ![MirSos](https://avatars.discourse-cdn.com/v4/letter/m/53a042/32.png) [@MirSos](https://forums.percona.com/u/MirSos)\
**Post date:** [August 5, 2020, 4:15am UTC](https://forums.percona.com/t/cant-start-percona-cluster-8-019-for-the-first-time/7844/5 "2020-08-05T04:15:44Z")

</div>

If you want to make it, you will find help under this link :&nbsp;[https://www.percona.com/doc/percona-xtradb-cluster/8.0/security/encrypt-traffic.html](https://www.percona.com/doc/percona-xtradb-cluster/8.0/security/encrypt-traffic.html)

---

<div class="post-metadata">

**Author:** ![DBA100](https://avatars.discourse-cdn.com/v4/letter/d/b3f665/32.png) [@DBA100](https://forums.percona.com/u/DBA100)\
**Post date:** [August 5, 2020, 8:11am UTC](https://forums.percona.com/t/cant-start-percona-cluster-8-019-for-the-first-time/7844/6 "2020-08-05T08:11:29Z")

</div>

but doing this can’t bootstrap the cluster at all, as you can see from my.cnf, I remark that.

```auto
wsrep_provider_options=”socket.ssl_key=server-key.pem;socket.ssl_cert=server-cert.pem;socket.ssl_ca=ca.pem”

[sst]
encrypt=4
ssl-key=server-key.pem
ssl-ca=ca.pem
ssl-cert=server-cert.pem<br>

```

---

<div class="post-metadata">

**Author:** ![MirSos](https://avatars.discourse-cdn.com/v4/letter/m/53a042/32.png) [@MirSos](https://forums.percona.com/u/MirSos)\
**Post date:** [August 6, 2020, 10:34am UTC](https://forums.percona.com/t/cant-start-percona-cluster-8-019-for-the-first-time/7844/7 "2020-08-06T10:34:13Z")

</div>

sorry, my mistake

---

<div class="post-metadata">

**Author:** ![MirSos](https://avatars.discourse-cdn.com/v4/letter/m/53a042/32.png) [@MirSos](https://forums.percona.com/u/MirSos)\
**Post date:** [August 6, 2020, 3:21pm UTC](https://forums.percona.com/t/cant-start-percona-cluster-8-019-for-the-first-time/7844/8 "2020-08-06T15:21:07Z")

</div>

don’t use quotation mark&nbsp;

```auto
wsrep_provider_options=socket.ssl_key=server-key.pem;socket.ssl_cert=server-cert.pem;socket.ssl_ca=ca.pem

```

---

<div class="post-metadata">

**Author:** ![DBA100](https://avatars.discourse-cdn.com/v4/letter/d/b3f665/32.png) [@DBA100](https://forums.percona.com/u/DBA100)\
**Post date:** [August 10, 2020, 10:08pm UTC](https://forums.percona.com/t/cant-start-percona-cluster-8-019-for-the-first-time/7844/9 "2020-08-10T22:08:18Z")

</div>

as I said do not quote it can’t start at all.  
  
I now has no problem by remark more and more parameter

---

<div class="post-metadata">

**Author:** ![DBA100](https://avatars.discourse-cdn.com/v4/letter/d/b3f665/32.png) [@DBA100](https://forums.percona.com/u/DBA100)\
**Post date:** [August 10, 2020, 10:08pm UTC](https://forums.percona.com/t/cant-start-percona-cluster-8-019-for-the-first-time/7844/10 "2020-08-10T22:08:35Z")

</div>

this one close
