# Can't install percona-mongodb on oraclelinux and ubuntu

**URL:** <https://forums.percona.com/t/cant-install-percona-mongodb-on-oraclelinux-and-ubuntu/17987>\
**Category:** Percona Server for MongoDB\
**Tags:** mongodb\
**Created:** [October 13, 2022, 10:47am UTC](https://forums.percona.com/t/cant-install-percona-mongodb-on-oraclelinux-and-ubuntu/17987 "2022-10-13T10:47:16Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![hieu\_nguyen](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/hieu_nguyen/32/6616_2.png) [@hieu\_nguyen](https://forums.percona.com/u/hieu_nguyen)\
**Post date:** [October 13, 2022, 10:47am UTC](https://forums.percona.com/t/cant-install-percona-mongodb-on-oraclelinux-and-ubuntu/17987/1 "2022-10-13T10:47:16Z")

</div>

i followed the instructions on the percona homepage and got the results when installing on oraclelinux : [Overview - Percona Server for MongoDB 5.0](https://docs.percona.com/percona-server-for-mongodb/5.0/install/index.html)

 ![Screenshot_303](https://us1.discourse-cdn.com/flex019/uploads/percona1/original/2X/e/edcd34397585e4b144692eec18baf46ac7e734ce.png)

then i start and get the result again

 ![Screenshot_304](https://us1.discourse-cdn.com/flex019/uploads/percona1/original/2X/6/643fa91daec1cb6bd80142a23768e507c632de90.png)

when I check in /var/log/mongo/ I don’t see anything

![Screenshot_305](https://us1.discourse-cdn.com/flex019/uploads/percona1/original/2X/4/4300ec300cdcc00481af4efa05353f13f8296a55.png)

---

<div class="post-metadata">

**Author:** ![Ivan\_Groenewold](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/ivan_groenewold/32/6299_2.png) [@Ivan\_Groenewold](https://forums.percona.com/u/Ivan_Groenewold)\
**Post date:** [October 13, 2022, 2:47pm UTC](https://forums.percona.com/t/cant-install-percona-mongodb-on-oraclelinux-and-ubuntu/17987/2 "2022-10-13T14:47:01Z")

</div>

Hello, anything logged in the journal?  
`journalctl -e -u mongod.service`  
you can try starting mongod process manually also to see if there’s any output

---

<div class="post-metadata">

**Author:** ![hieu\_nguyen](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/hieu_nguyen/32/6616_2.png) [@hieu\_nguyen](https://forums.percona.com/u/hieu_nguyen)\
**Post date:** [October 14, 2022, 1:34am UTC](https://forums.percona.com/t/cant-install-percona-mongodb-on-oraclelinux-and-ubuntu/17987/3 "2022-10-14T01:34:13Z")

</div>

this is what its output

```auto
Oct 13 15:08:05 vnpt.vn systemd[1]: Starting High-performance, schema-free document-oriented database...
Oct 13 15:08:06 vnpt.vn systemd-coredump[8314]: Process 8312 (mongod) of user 975 dumped core.
Oct 13 15:08:06 vnpt.vn systemd[1]: mongod.service: Control process exited, code=exited status=132
Oct 13 15:08:06 vnpt.vn systemd[1]: mongod.service: Failed with result 'exit-code'.
Oct 13 15:08:06 vnpt.vn systemd[1]: Failed to start High-performance, schema-free document-oriented database.
Oct 13 15:08:59 vnpt.vn systemd[1]: Starting High-performance, schema-free document-oriented database...
Oct 13 15:08:59 vnpt.vn systemd-coredump[8395]: Process 8393 (mongod) of user 975 dumped core.
Oct 13 15:08:59 vnpt.vn systemd[1]: mongod.service: Control process exited, code=exited status=132
Oct 13 15:08:59 vnpt.vn systemd[1]: mongod.service: Failed with result 'exit-code'.
Oct 13 15:08:59 vnpt.vn systemd[1]: Failed to start High-performance, schema-free document-oriented database.
Oct 13 15:11:46 vnpt.vn systemd[1]: Starting High-performance, schema-free document-oriented database...
Oct 13 15:11:46 vnpt.vn systemd-coredump[8445]: Process 8443 (mongod) of user 975 dumped core.
Oct 13 15:11:46 vnpt.vn systemd[1]: mongod.service: Control process exited, code=exited status=132
Oct 13 15:11:46 vnpt.vn systemd[1]: mongod.service: Failed with result 'exit-code'.
Oct 13 15:11:46 vnpt.vn systemd[1]: Failed to start High-performance, schema-free document-oriented database.
Oct 13 15:35:58 vnpt.vn systemd[1]: Starting High-performance, schema-free document-oriented database...
Oct 13 15:35:58 vnpt.vn systemd-coredump[10982]: Process 10980 (mongod) of user 975 dumped core.
Oct 13 15:35:58 vnpt.vn systemd[1]: mongod.service: Control process exited, code=exited status=132
Oct 13 15:35:58 vnpt.vn systemd[1]: mongod.service: Failed with result 'exit-code'.
Oct 13 15:35:58 vnpt.vn systemd[1]: Failed to start High-performance, schema-free document-oriented database.
Oct 14 08:31:46 vnpt.vn systemd[1]: Starting High-performance, schema-free document-oriented database...
Oct 14 08:31:46 vnpt.vn systemd-coredump[20181]: Process 20179 (mongod) of user 975 dumped core.
Oct 14 08:31:46 vnpt.vn systemd[1]: mongod.service: Control process exited, code=exited status=132
Oct 14 08:31:46 vnpt.vn systemd[1]: mongod.service: Failed with result 'exit-code'.
Oct 14 08:31:46 vnpt.vn systemd[1]: Failed to start High-performance, schema-free document-oriented database.

```

---

<div class="post-metadata">

**Author:** ![coldmoney](https://avatars.discourse-cdn.com/v4/letter/c/91b2a8/32.png) [@coldmoney](https://forums.percona.com/u/coldmoney)\
**Post date:** [December 27, 2022, 3:56am UTC](https://forums.percona.com/t/cant-install-percona-mongodb-on-oraclelinux-and-ubuntu/17987/4 "2022-12-27T03:56:22Z")

</div>

I Found the same error after install Percona lastest version on ubuntu

coldmoney@tumlay:~$ sudo systemctl status mongod  
[sudo] password for coldmoney:  
× mongod.service - High-performance, schema-free document-oriented database  
Loaded: loaded (/lib/systemd/system/mongod.service; enabled; vendor preset: enabled)  
Active: failed (Result: exit-code) since Tue 2022-12-27 00:39:24 UTC; 12min ago  
Process: 843 ExecStartPre=/usr/bin/percona-server-mongodb-helper.sh (code=exited, status=0/SUCCESS)  
Process: 938 ExecStart=/usr/bin/env bash -c ${NUMACTL} /usr/bin/mongod ${OPTIONS} \> ${STDOUT} 2\> ${STDERR} (code=exited, status=132)  
CPU: 296ms

Dec 27 00:39:22 tumlay systemd[1]: Starting High-performance, schema-free document-oriented database…  
Dec 27 00:39:24 tumlay env[938]: bash: line 1: 941 Illegal instruction (core dumped) /usr/bin/mongod -f /etc/mongod.conf \> /var/log/mongodb/mongod\>  
Dec 27 00:39:24 tumlay systemd[1]: mongod.service: Control process exited, code=exited, status=132/n/a  
Dec 27 00:39:24 tumlay systemd[1]: mongod.service: Failed with result ‘exit-code’.  
Dec 27 00:39:24 tumlay systemd[1]: Failed to start High-performance, schema-free document-oriented database.  
lines 1-12/12 (END)

---

<div class="post-metadata">

**Author:** ![Ivan\_Groenewold](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/ivan_groenewold/32/6299_2.png) [@Ivan\_Groenewold](https://forums.percona.com/u/Ivan_Groenewold)\
**Post date:** [December 27, 2022, 11:07am UTC](https://forums.percona.com/t/cant-install-percona-mongodb-on-oraclelinux-and-ubuntu/17987/5 "2022-12-27T11:07:58Z")

</div>

Hi, is this a brand new install? in that case most likely there are leftover files in /var/lib/mongo which need to be removed.

---

<div class="post-metadata">

**Author:** ![oleksandr.havryliak](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/oleksandr.havryliak/32/5703_2.png) [@oleksandr.havryliak](https://forums.percona.com/u/oleksandr.havryliak)\
**Post date:** [January 3, 2023, 1:53pm UTC](https://forums.percona.com/t/cant-install-percona-mongodb-on-oraclelinux-and-ubuntu/17987/6 "2023-01-03T13:53:02Z")

</div>

Hi!  
Look’s like your hardware doesn’t meet the system requirements:  
@hieu_nguyen MongoDB only supports Oracle Linux running the Red Hat Compatible Kernel (RHCK). MongoDB does not support the Unbreakable Enterprise Kernel (UEK).  
@coldmoney MongoDB 5.0 requires use of the AVX instruction set (Intel Sandy Bridge or later Core processor, Intel Tiger Lake or later Celeron or Pentium, AMD Bulldozer or later processor.)
