# Cannot start server after upgrading to 4.0

**URL:** https://forums.percona.com/t/cannot-start-server-after-upgrading-to-4-0/7018
**Category:** Percona Server for MongoDB
**Created:** [May 16, 2019, 3:40am UTC](https://forums.percona.com/t/cannot-start-server-after-upgrading-to-4-0/7018 "2019-05-16T03:40:12Z")
**Posts on this page:** 2
**Page:** 1

<div class="post-metadata">

### Author: ![danb](https://avatars.discourse-cdn.com/v4/letter/d/f05b48/32.png) [@danb](https://forums.percona.com/u/danb)
#### Post date: [May 16, 2019, 3:40am UTC](https://forums.percona.com/t/cannot-start-server-after-upgrading-to-4-0/7018/1 "2019-05-16T03:40:12Z")

</div>

I upgraded from 3.4 to 3.6 and to 4.0  
The upgrade to 3.6 secceded bu when upgrading to 4.0 it fails with the following error:

I STORAGE [initandlisten] exception in initAndListen: 28574 Cannot start server. Detected data files in /var/lib/mongo created by storage engine ‘wiredTiger’. The configured storage engine is ‘mmapv1’., terminating

---

<div class="post-metadata">

### Author: ![Doug\_Duncan](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/doug_duncan/32/16898_2.png) [@Doug\_Duncan](https://forums.percona.com/u/Doug_Duncan)
#### Post date: [May 16, 2019, 10:00am UTC](https://forums.percona.com/t/cannot-start-server-after-upgrading-to-4-0/7018/2 "2019-05-16T10:00:03Z")

</div>

Hi [danb@storenext](https://percona.vanillacommunities.com/profile/x/x/42906) it looks like a setting in your process.

It could also be that you have the MMAPv1 data located at a different path than what the data files.

Let us know if you have any other questions.

~Doug
