# Cannot create users on a fresh deployment of percona operator and percona server via helm

**URL:** <https://forums.percona.com/t/cannot-create-users-on-a-fresh-deployment-of-percona-operator-and-percona-server-via-helm/18373>\
**Category:** Percona Operator for MySQL\
**Created:** [November 4, 2022, 10:51am UTC](https://forums.percona.com/t/cannot-create-users-on-a-fresh-deployment-of-percona-operator-and-percona-server-via-helm/18373 "2022-11-04T10:51:24Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![tobias.radszuweit](https://avatars.discourse-cdn.com/v4/letter/t/a88e4f/32.png) [@tobias.radszuweit](https://forums.percona.com/u/tobias.radszuweit)\
**Post date:** [November 4, 2022, 10:51am UTC](https://forums.percona.com/t/cannot-create-users-on-a-fresh-deployment-of-percona-operator-and-percona-server-via-helm/18373/1 "2022-11-04T10:51:24Z")

</div>

Hi,

hope this is the right place to ask. I’m currently trying to setup a Percona Server async cluster via Percona Operator on AWS EKS. Installation seems to work fine, kubectl get ps -n percona shows the cluster running in a healthy state. I can connect via the created root user and create databases and tables, but adding application users fails.

GRANT ALL PRIVILEGES ON _._ to ‘app1’@‘%’ IDENTIFIED BY ‘abcdefg’;  
returns ERROR 1064 (42000): You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near ‘IDENTIFIED BY ‘abcdefg’’ at line 1

CREATE USER ‘app1’@‘%’ IDENTIFIED WITH caching\_sha2\_password BY ‘abcdefg’;  
fails with ERROR 1227 (42000): Access denied; you need (at least one of) the SYSTEM\_USER privilege(s) for this operation

Could you please point me on what I’m missing out?

Best thanks!

---

<div class="post-metadata">

**Author:** ![tobias.radszuweit](https://avatars.discourse-cdn.com/v4/letter/t/a88e4f/32.png) [@tobias.radszuweit](https://forums.percona.com/u/tobias.radszuweit)\
**Post date:** [November 23, 2022, 12:56pm UTC](https://forums.percona.com/t/cannot-create-users-on-a-fresh-deployment-of-percona-operator-and-percona-server-via-helm/18373/2 "2022-11-23T12:56:27Z")

</div>

Hi again,

Problem solved. Seems it was caused by some former helm-install with standard credentials being left after uninstall. Deleting and recreating the namespace worked, now root can create users. Still somehow strange and in my opinion a bug, since the new root password from the secret worked for login but not for grants.
