# Can Not install Percona Server 5.6 on 512 RAM Server??

**URL:** https://forums.percona.com/t/can-not-install-percona-server-5-6-on-512-ram-server/3779
**Category:** Percona Server for MySQL 5.6
**Created:** [September 26, 2014, 8:29am UTC](https://forums.percona.com/t/can-not-install-percona-server-5-6-on-512-ram-server/3779 "2014-09-26T08:29:23Z")
**Posts on this page:** 3
**Page:** 1

<div class="post-metadata">

### Author: ![Harshad](https://avatars.discourse-cdn.com/v4/letter/h/97f17d/32.png) [@Harshad](https://forums.percona.com/u/Harshad)
#### Post date: [September 26, 2014, 8:29am UTC](https://forums.percona.com/t/can-not-install-percona-server-5-6-on-512-ram-server/3779/1 "2014-09-26T08:29:23Z")

</div>

Hi ,  
I am trying to install Percona Server 5.6 on Server having 512 MB RAM.  
My System Info  
Distributor ID: Ubuntu  
Description: Ubuntu 14.04 LTS  
Release: 14.04  
Codename: trusty

I am getting this error

[B]Setting up percona-server-server-5.6 (5.6.20-68.0-656.trusty) …

- Stopping MySQL (Percona Server) mysqld [OK]

- Percona Server is distributed with several useful UDF (User Defined Function) from Percona Toolkit.

- Run the following commands to create these functions:

mysql -e “CREATE FUNCTION fnv1a\_64 RETURNS INTEGER SONAME ‘libfnv1a\_udf.so’”  
mysql -e “CREATE FUNCTION fnv\_64 RETURNS INTEGER SONAME ‘libfnv\_udf.so’”  
mysql -e “CREATE FUNCTION murmur\_hash RETURNS INTEGER SONAME ‘libmurmur\_udf.so’”

- See [url][http://www.percona.com/doc/percona-server/5.6/management/udf\_percona\_toolkit.html[/url]](http://www.percona.com/doc/percona-server/5.6/management/udf_percona_toolkit.html%5B/url%5D) for more details

- Starting MySQL (Percona Server) database server mysqld [fail]  
invoke-rc.d: initscript mysql, action “start” failed.  
dpkg: error processing package percona-server-server-5.6 (–configure):  
subprocess installed post-installation script returned error exit status 1  
Errors were encountered while processing:  
percona-server-server-5.6  
E: Sub-process /usr/bin/dpkg returned an error code (1)[/B]

But When I create 1 GB swap space it gets installed properly.

I guess the failure because of overallocated buffers size, can you suggest me recommended we to install percona server 5.6 without creating swap on 512MB RAM server.

---

<div class="post-metadata">

### Author: ![scott.nemes](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/scott.nemes/32/5_2.png) [@scott.nemes](https://forums.percona.com/u/scott.nemes)
#### Post date: [September 26, 2014, 9:55am UTC](https://forums.percona.com/t/can-not-install-percona-server-5-6-on-512-ram-server/3779/2 "2014-09-26T09:55:03Z")

</div>

Hi Harshad;

Is this just a testing server? You can reduce the memory footprint of MySQL, but you will not be able to do a whole lot with 512MB of memory for the entire server as the OS itself will take up quite a bit of that. On that note, you should try and shut down any processes you can to reduce the amount of memory taken up by the OS / other non-MySQL programs/services.

The easiest thing you can try is set innodb\_buffer\_pool\_size to 6MB which is about the lowest it can go. The default value for 5.6 is about 134MB, so that will give you around 128MB more to work with. If that is not enough, then you will need to start tuning other parameters that already use a small amount of memory but can be set even lower.

Below is a list of settings you can change to lower values (copied from: [http://www.tocker.ca/2014/03/10/configuring-mysql-to-use-minimal-memory.html](http://www.tocker.ca/2014/03/10/configuring-mysql-to-use-minimal-memory.html)). Note that reducing everything to the minimum will of course reduce performance, so keep that in mind:

innodb\_buffer\_pool\_size=6M  
innodb\_log\_buffer\_size=256K  
query\_cache\_size=0  
max\_connections=10  
key\_buffer\_size=8  
thread\_cache\_size=0  
host\_cache\_size=0  
innodb\_ft\_cache\_size=1600000  
innodb\_ft\_total\_cache\_size=32000000

# per thread or per operation settings

thread\_stack=131072  
sort\_buffer\_size=32K  
read\_buffer\_size=8200  
read\_rnd\_buffer\_size=8200  
max\_heap\_table\_size=16K  
tmp\_table\_size=1K  
bulk\_insert\_buffer\_size=0  
join\_buffer\_size=128  
net\_buffer\_length=1K  
innodb\_sort\_buffer\_size=64K

#settings that relate to the binary log (if enabled)  
binlog\_cache\_size=4K  
binlog\_stmt\_cache\_size=4K

-Scott

---

<div class="post-metadata">

### Author: ![scott.nemes](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/scott.nemes/32/5_2.png) [@scott.nemes](https://forums.percona.com/u/scott.nemes)
#### Post date: [September 29, 2014, 11:59am UTC](https://forums.percona.com/t/can-not-install-percona-server-5-6-on-512-ram-server/3779/3 "2014-09-29T11:59:28Z")

</div>

Hi Harshad;

What is the error in the log now? Might be hitting something else. Also try shutting down nginx and anything else you can to see if MySQL will start then or not.

If you cannot get it going due to memory after setting everything above, then I would just run the swap space as you did initially for testing.

-Scott
