# Broken install debian lenny percona 5.1.53-rel11.7-log

**URL:** <https://forums.percona.com/t/broken-install-debian-lenny-percona-5-1-53-rel11-7-log/1586>\
**Category:** Other MySQL® Questions\
**Created:** [December 22, 2010, 4:19am UTC](https://forums.percona.com/t/broken-install-debian-lenny-percona-5-1-53-rel11-7-log/1586 "2010-12-22T04:19:28Z")\
**Posts on this page:** 1\
**Page:** 1

<div class="post-metadata">

**Author:** ![vincus](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/vincus/32/843_2.png) [@vincus](https://forums.percona.com/u/vincus)\
**Post date:** [December 22, 2010, 4:19am UTC](https://forums.percona.com/t/broken-install-debian-lenny-percona-5-1-53-rel11-7-log/1586/1 "2010-12-22T04:19:28Z")

</div>

Hello,

I have upgraded a mysql 5.1 to the percona edition 5.1.53-rel11.7-log. The old server config was:

[client]  
port=3306

[mysql]  
default-character-set=utf8

[mysqld]  
port=3306  
datadir=/db\_vol/mysql  
tmpdir=/db\_vol/mysql\_tmp  
default-character-set=utf8  
default-storage-engine=InnoDB  
sql-mode=" STRICT\_TRANS\_TABLES,NO\_AUTO\_CREATE\_USER,NO\_ENGINE\_SUBSTITUTI ON "

innodb\_buffer\_pool\_size=8192M  
innodb\_additional\_mem\_pool\_size=20M  
innodb\_flush\_log\_at\_trx\_commit=0  
innodb\_log\_file\_size=256M  
innodb\_log\_buffer\_size=8M  
innodb\_file\_per\_table

max\_allowed\_packet=256M

query\_cache\_limit=1M  
query\_cache\_size=64M

log-bin=mysql-bin  
server-id=10  
sync\_binlog=0  
binlog\_format=ROW

## skip-name-resolve

THe install went wrong.  
First it was not able to shutdown the existing server and was waiting for it (could not find the pid file)  
From another console I helped him a bit, but unfortunately i was only able to shutdown the old mysql with kill -9.  
By the time I halted the mysql, percona tried to start and as the db was locked it was waiting continously.  
I havce restarted the installation process and it ran into fail with the following message:

–  
Dec 21 10:14:38 prod-db mysqld\_safe[31282]: InnoDB: remove old data files which contain your precious data!  
Dec 21 10:14:38 prod-db mysqld\_safe[31282]: 101221 10:14:38 [ERROR] Plugin ‘InnoDB’ init function returned error.  
Dec 21 10:14:38 prod-db mysqld\_safe[31282]: 101221 10:14:38 [ERROR] Plugin ‘InnoDB’ registration as a STORAGE ENGINE failed.  
Dec 21 10:14:38 prod-db mysqld\_safe[31282]: 101221 10:14:38 [ERROR] Unknown/unsupported table type: InnoDB  
Dec 21 10:14:38 prod-db mysqld\_safe[31282]: 101221 10:14:38 [ERROR] Aborting  
Dec 21 10:14:38 prod-db mysqld\_safe[31282]:  
Dec 21 10:14:38 prod-db mysqld\_safe[31282]: 101221 10:14:38 [Note] /usr/sbin/mysqld: Shutdown complete  
Dec 21 10:14:38 prod-db mysqld\_safe[31282]:  
Dec 21 10:15:43 prod-db mysqld\_safe[31753]: 101221 10:15:43 [Warning] ‘–default-character-set’ is deprecated and will be removed in a future release. Please use ‘–character-set-server’ instead.  
Dec 21 10:15:43 prod-db mysqld\_safe[31753]: 101221 10:15:43 [Warning] ‘–default-character-set’ is deprecated and will be removed in a future release. Please use ‘–character-set-server’ instead.  
Dec 21 10:15:43 prod-db mysqld\_safe[31753]: 101221 10:15:43 [Note] Plugin ‘FEDERATED’ is disabled.  
Dec 21 10:15:43 prod-db mysqld\_safe[31753]: InnoDB: The InnoDB memory heap is disabled  
Dec 21 10:15:43 prod-db mysqld\_safe[31753]: InnoDB: Mutexes and rw\_locks use GCC atomic builtins  
Dec 21 10:15:43 prod-db mysqld\_safe[31753]: InnoDB: Compressed tables use zlib 1.2.3.3  
Dec 21 10:15:44 prod-db mysqld\_safe[31753]: 101221 10:15:44 InnoDB: highest supported file format is Barracuda.  
Dec 21 10:15:44 prod-db mysqld\_safe[31753]: InnoDB: Log scan progressed past the checkpoint lsn 1319833900756  
Dec 21 10:15:44 prod-db mysqld\_safe[31753]: 101221 10:15:44 InnoDB: Database was not shut down normally!  
Dec 21 10:15:44 prod-db mysqld\_safe[31753]: InnoDB: Starting crash recovery.  
Dec 21 10:15:44 prod-db mysqld\_safe[31753]: InnoDB: Reading tablespace information from the .ibd files…  
Dec 21 10:15:49 prod-db mysqld\_safe[31753]: InnoDB: Restoring possible half-written data pages from the doublewrite  
Dec 21 10:15:49 prod-db mysqld\_safe[31753]: InnoDB: buffer…  
Dec 21 10:15:53 prod-db mysqld\_safe[31840]: 101221 10:15:53 [Warning] ‘–default-character-set’ is deprecated and will be removed in a future release. Please use ‘–character-set-server’ instead.  
Dec 21 10:15:53 prod-db mysqld\_safe[31840]: 101221 10:15:53 [Warning] ‘–default-character-set’ is deprecated and will be removed in a future release. Please use ‘–character-set-server’ instead.  
Dec 21 10:15:53 prod-db mysqld\_safe[31840]: 101221 10:15:53 [Warning] ‘–default-character-set’ is deprecated and will be removed in a future release. Please use ‘–character-set-server’ instead.  
Dec 21 10:15:53 prod-db mysqld\_safe[31840]: 101221 10:15:53 [Warning] ‘–default-character-set’ is deprecated and will be removed in a future release. Please use ‘–character-set-server’ instead.  
Dec 21 10:15:53 prod-db mysqld\_safe[31840]:  
Dec 21 10:15:53 prod-db mysqld\_safe[31840]: PLEASE REMEMBER TO SET A PASSWORD FOR THE MySQL root USER !  
Dec 21 10:15:53 prod-db mysqld\_safe[31840]: To do so, start the server, then issue the following commands:  
Dec 21 10:15:53 prod-db mysqld\_safe[31840]:  
Dec 21 10:15:53 prod-db mysqld\_safe[31840]: /usr/bin/mysqladmin -u root password ‘new-password’  
Dec 21 10:15:53 prod-db mysqld\_safe[31840]: /usr/bin/mysqladmin -u root -h password ‘new-password’  
Dec 21 10:15:53 prod-db mysqld\_safe[31840]:  
Dec 21 10:15:53 prod-db mysqld\_safe[31840]: Alternatively you can run:  
Dec 21 10:15:53 prod-db mysqld\_safe[31840]: /usr/bin/mysql\_secure\_installation  
Dec 21 10:15:53 prod-db mysqld\_safe[31840]:  
Dec 21 10:15:53 prod-db mysqld\_safe[31840]: which will also give you the option of removing the test  
Dec 21 10:15:53 prod-db mysqld\_safe[31840]: databases and anonymous user created by default. This is  
Dec 21 10:15:53 prod-db mysqld\_safe[31840]: strongly recommended for production servers.  
Dec 21 10:15:53 prod-db mysqld\_safe[31840]:  
Dec 21 10:15:53 prod-db mysqld\_safe[31840]: See the manual for more instructions.  
Dec 21 10:15:53 prod-db mysqld\_safe[31840]:  
Dec 21 10:15:53 prod-db mysqld\_safe[31840]: Please report any problems with the /usr/bin/mysqlbug script!  
Dec 21 10:15:53 prod-db mysqld\_safe[31840]:  
Dec 21 10:15:53 prod-db mysqld\_safe[31840]: For commercial support please contact Percona at [http://www.percona.com/contacts.html](http://www.percona.com/contacts.html)  
Dec 21 10:15:53 prod-db mysqld\_safe[31880]: 101221 10:15:53 [Warning] ‘–default-character-set’ is deprecated and will be removed in a future release. Please use ‘–character-set-server’ instead.  
Dec 21 10:15:53 prod-db mysqld\_safe[31880]: 101221 10:15:53 [Warning] ‘–default-character-set’ is deprecated and will be removed in a future release. Please use ‘–character-set-server’ instead.  
Dec 21 10:15:53 prod-db mysqld\_safe[31880]: 101221 10:15:53 [Note] Plugin ‘FEDERATED’ is disabled.  
Dec 21 10:15:53 prod-db mysqld\_safe[31880]: InnoDB: The InnoDB memory heap is disabled  
Dec 21 10:15:53 prod-db mysqld\_safe[31880]: InnoDB: Mutexes and rw\_locks use GCC atomic builtins  
Dec 21 10:15:53 prod-db mysqld\_safe[31880]: InnoDB: Compressed tables use zlib 1.2.3.3  
Dec 21 10:15:54 prod-db mysqld\_safe[31880]: InnoDB: Unable to lock ./ibdata1, error: 11  
Dec 21 10:15:54 prod-db mysqld\_safe[31880]: InnoDB: Check that you do not already have another mysqld process  
Dec 21 10:15:54 prod-db mysqld\_safe[31880]: InnoDB: using the same InnoDB data or log files.  
Dec 21 10:15:55 prod-db mysqld\_safe[31880]: InnoDB: Unable to lock ./ibdata1, error: 11  
Dec 21 10:15:55 prod-db mysqld\_safe[31880]: InnoDB: Check that you do not already have another mysqld process  
Dec 21 10:15:55 prod-db mysqld\_safe[31880]: InnoDB: using the same InnoDB data or log files.  
Dec 21 10:15:56 prod-db mysqld\_safe[31880]: InnoDB: Unable to lock ./ibdata1, error: 11  
Dec 21 10:15:56 prod-db mysqld\_safe[31880]: InnoDB: Check that you do not already have another mysqld process  
Dec 21 10:15:56 prod-db mysqld\_safe[31880]: InnoDB: using the same InnoDB data or log files.  
Dec 21 10:15:57 prod-db mysqld\_safe[31880]: InnoDB: Unable to lock ./ibdata1, error: 11  
Dec 21 10:15:57 prod-db mysqld\_safe[31880]: InnoDB: Check that you do not already have another mysqld process  
Dec 21 10:15:57 prod-db mysqld\_safe[31880]: InnoDB: using the same InnoDB data or log files.  
Dec 21 10:15:58 prod-db mysqld\_safe[31880]: InnoDB: Unable to lock ./ibdata1, error: 11  
Dec 21 10:15:58 prod-db mysqld\_safe[31880]: InnoDB: Check that you do not already have another mysqld process  
Dec 21 10:15:58 prod-db mysqld\_safe[31880]: InnoDB: using the same InnoDB data or log files.  
Dec 21 10:15:59 prod-db mysqld\_safe[31880]: InnoDB: Unable to lock ./ibdata1, error: 11

–  
OK, I saw that two percona server were running so I killed them and restarted the install again.

Dec 21 10:17:21 prod-db mysqld\_safe[32085]: InnoDB: The InnoDB memory heap is disabled  
Dec 21 10:17:21 prod-db mysqld\_safe[32085]: InnoDB: Mutexes and rw\_locks use GCC atomic builtins  
Dec 21 10:17:21 prod-db mysqld\_safe[32085]: InnoDB: Compressed tables use zlib 1.2.3.3  
Dec 21 10:17:22 prod-db mysqld\_safe[32085]: 101221 10:17:22 InnoDB: highest supported file format is Barracuda.  
Dec 21 10:17:22 prod-db mysqld\_safe[32085]: InnoDB: Log scan progressed past the checkpoint lsn 1319833900756  
Dec 21 10:17:22 prod-db mysqld\_safe[32085]: 101221 10:17:22 InnoDB: Database was not shut down normally!  
Dec 21 10:17:22 prod-db mysqld\_safe[32085]: InnoDB: Starting crash recovery.  
Dec 21 10:17:22 prod-db mysqld\_safe[32085]: InnoDB: Reading tablespace information from the .ibd files…  
Dec 21 10:17:22 prod-db mysqld\_safe[32085]: InnoDB: Restoring possible half-written data pages from the doublewrite  
Dec 21 10:17:22 prod-db mysqld\_safe[32085]: InnoDB: buffer…  
Dec 21 10:17:23 prod-db mysqld\_safe[32085]: InnoDB: Doing recovery: scanned up to log sequence number 1319839143424  
Dec 21 10:17:23 prod-db mysqld\_safe[32085]: InnoDB: Doing recovery: scanned up to log sequence number 1319844386304  
Dec 21 10:17:24 prod-db mysqld\_safe[32085]: InnoDB: Doing recovery: scanned up to log sequence number 1319849629184  
Dec 21 10:17:24 prod-db mysqld\_safe[32085]: InnoDB: Doing recovery: scanned up to log sequence number 1319854872064  
Dec 21 10:17:25 prod-db mysqld\_safe[32085]: InnoDB: Doing recovery: scanned up to log sequence number 1319860114944  
Dec 21 10:17:25 prod-db mysqld\_safe[32085]: InnoDB: Doing recovery: scanned up to log sequence number 1319865357824  
Dec 21 10:17:26 prod-db mysqld\_safe[32085]: InnoDB: Doing recovery: scanned up to log sequence number 1319870600704  
Dec 21 10:17:27 prod-db mysqld\_safe[32085]: InnoDB: Doing recovery: scanned up to log sequence number 1319875843584  
Dec 21 10:17:27 prod-db mysqld\_safe[32085]: InnoDB: Doing recovery: scanned up to log sequence number 1319881086464  
Dec 21 10:17:27 prod-db mysqld\_safe[32085]: InnoDB: Doing recovery: scanned up to log sequence number 1319886329344  
Dec 21 10:17:28 prod-db mysqld\_safe[32085]: InnoDB: Doing recovery: scanned up to log sequence number 1319891572224  
Dec 21 10:17:28 prod-db mysqld\_safe[32085]: InnoDB: Doing recovery: scanned up to log sequence number 1319896815104  
Dec 21 10:17:29 prod-db mysqld\_safe[32085]: InnoDB: Doing recovery: scanned up to log sequence number 1319902057984  
Dec 21 10:17:29 prod-db mysqld\_safe[32085]: InnoDB: Doing recovery: scanned up to log sequence number 1319907300864  
[..]

Dec 21 10:17:42 prod-db mysqld\_safe[32085]: 101221 10:17:42 InnoDB: Starting an apply batch of log records to the database…  
Dec 21 10:19:19 prod-db mysqld\_safe[32085]: InnoDB: Progress in percents: 0 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99  
Dec 21 10:19:19 prod-db mysqld\_safe[32085]: InnoDB: Apply batch completed  
Dec 21 10:19:20 prod-db mysqld\_safe[32085]: InnoDB: Last MySQL binlog file position 0 706245386, file name ./mysql-bin.000529  
Dec 21 10:19:20 prod-db mysqld\_safe[32085]: 101221 10:19:20 Percona XtraDB ([http://www.percona.com](http://www.percona.com)) 1.0.13-11.7 started; log sequence number 1320102267974  
Dec 21 10:19:20 prod-db mysqld\_safe[32085]: #007/usr/sbin/mysqld: File ‘./mysql-bin.000535’ not found (Errcode: 13)  
Dec 21 10:19:20 prod-db mysqld\_safe[32085]: 101221 10:19:20 [ERROR] Failed to open log (file ‘./mysql-bin.000535’, errno 13)  
Dec 21 10:19:20 prod-db mysqld\_safe[32085]: 101221 10:19:20 [ERROR] Could not open log file  
Dec 21 10:19:20 prod-db mysqld\_safe[32085]: 101221 10:19:20 [ERROR] Can’t init tc log  
Dec 21 10:19:20 prod-db mysqld\_safe[32085]: 101221 10:19:20 [ERROR] Aborting  
Dec 21 10:19:20 prod-db mysqld\_safe[32085]:  
Dec 21 10:19:20 prod-db mysqld\_safe[32085]: 101221 10:19:20 InnoDB: Starting shutdown…  
Dec 21 10:19:47 prod-db mysqld\_safe[32085]: 101221 10:19:47 InnoDB: Shutdown completed; log sequence number 1320102270860  
Dec 21 10:19:47 prod-db mysqld\_safe[32085]: 101221 10:19:47 [Note] /usr/sbin/mysqld: Shutdown complete

–  
I found on a forum to remove entries from the binlog index file, so I chose this method to fix it.

Then it went this way:

Dec 21 10:20:02 prod-db mysqld\_safe[32376]: 101221 10:20:02 InnoDB: highest supported file format is Barracuda.  
Dec 21 10:20:03 prod-db mysqld\_safe[32376]: 101221 10:20:03 InnoDB: Warning: allocated tablespace 219, old maximum was 9  
Dec 21 10:20:03 prod-db mysqld\_safe[32376]: 101221 10:20:03 Percona XtraDB ([http://www.percona.com](http://www.percona.com)) 1.0.13-11.7 started; log sequence number 1320102270860  
Dec 21 10:20:03 prod-db mysqld\_safe[32376]: #007/usr/sbin/mysqld: File ‘./mysql-bin.000535’ not found (Errcode: 13)  
Dec 21 10:20:03 prod-db mysqld\_safe[32376]: 101221 10:20:03 [ERROR] Failed to open log (file ‘./mysql-bin.000535’, errno 13)  
Dec 21 10:20:03 prod-db mysqld\_safe[32376]: 101221 10:20:03 [ERROR] Could not open log file  
Dec 21 10:20:03 prod-db mysqld\_safe[32376]: 101221 10:20:03 [ERROR] Can’t init tc log  
Dec 21 10:20:03 prod-db mysqld\_safe[32376]: 101221 10:20:03 [ERROR] Aborting  
Dec 21 10:20:03 prod-db mysqld\_safe[32376]:  
Dec 21 10:20:03 prod-db mysqld\_safe[32376]: 101221 10:20:03 InnoDB: Starting shutdown…  
Dec 21 10:20:15 prod-db mysqld\_safe[32376]: 101221 10:20:15 InnoDB: Shutdown completed; log sequence number 1320102270860

–  
Not fun ☹

Next run:

## Dec 21 10:25:21 prod-db mysqld\_safe[2170]: #007/usr/sbin/mysqld: File ‘./mysql-bin.index’ not found (Errcode: 13)

As the index file was there I realized that new binlogs since the upgrade started were created with root privileges as well the index file.

I chowned 'em to mysql and restarted percona server again.

Now it started well but the installation is broken.  
Should I remove the post-inst script and fix on dpkg or am I gonna miss something on the server?

It seems xtradb is ok, information shchema table contains percona extensions.

What did I do wrong?

Thx in advance for any help.

Vincus
