# Backup not working with Percona Distribution for MongoDB Operator

**URL:** <https://forums.percona.com/t/backup-not-working-with-percona-distribution-for-mongodb-operator/11120>\
**Category:** Percona Backup for MongoDB\
**Created:** [June 30, 2021, 10:05am UTC](https://forums.percona.com/t/backup-not-working-with-percona-distribution-for-mongodb-operator/11120 "2021-06-30T10:05:54Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![jamoser](https://avatars.discourse-cdn.com/v4/letter/j/b2d939/32.png) [@jamoser](https://forums.percona.com/u/jamoser)\
**Post date:** [June 30, 2021, 10:05am UTC](https://forums.percona.com/t/backup-not-working-with-percona-distribution-for-mongodb-operator/11120/1 "2021-06-30T10:05:54Z")

</div>

Hello

I have a well running installation (default). Now the backup is enabled but there is the following error

{

insertId: “qxtqwiwpxbklc9ug”

jsonPayload: {

PBM name: “2021-06-30T09:45:15Z”

backup: “cron-\*\*\*-clus-20210630094505-dwtjv”

level: “info”

logger: “controller\_perconaservermongodbbackup”

msg: “Waiting for backup metadata”

ts: 1625046331.3845007

}

labels: {

[compute.googleapis.com/resource\_name:](http://compute.googleapis.com/resource_name:) “\*\*\*-pool-2be4e257-rqck”

k8s-pod/name: “percona-server-mongodb-operator”

k8s-pod/pod-template-hash: “5db7545547”

}

logName: “projects/\*\*\*/logs/stderr”

receiveTimestamp: “2021-06-30T09:45:32.452610567Z”

resource: {

labels: {

cluster\_name: “\*\*\*”

container\_name: “percona-server-mongodb-operator”

location: “\*\*\*”

namespace\_name: “\*\*\*”

pod\_name: “percona-server-mongodb-operator-5db7545547-d2ws5”

project\_id: “\*\*\*”

}

type: “k8s\_container”

}

severity: “ERROR”

timestamp: “2021-06-30T09:45:31.384755767Z”

}

According to

kubectl -n \*\*\* get psmdb-backup

cron-luz-mongodb-clus-20210630093002-47dwk \*\*\*cluster \*\*\*-storage \*\*\*2021-06-30T09:30:12Z error 14m  
cron-luz-mongodb-clus-20210630093503-hcqgh \*\*\*-cluster \*\*\*-storage \*\*\*/2021-06-30T09:35:13Z error 9m40s  
cron-luz-mongodb-clus-20210630094004-n47bt \*\*\*-cluster \*\*\*-storage \*\*\*/2021-06-30T09:40:14Z error 4m39s

the backup job scheduling works but the backup creation itself not.

Anyone could give a hint ?

Thanks & Regards  
John

---

<div class="post-metadata">

**Author:** ![Ege\_Gunes](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/ege_gunes/32/4595_2.png) [@Ege\_Gunes](https://forums.percona.com/u/Ege_Gunes)\
**Post date:** [June 30, 2021, 10:29am UTC](https://forums.percona.com/t/backup-not-working-with-percona-distribution-for-mongodb-operator/11120/2 "2021-06-30T10:29:23Z")

</div>

Hi @jamoser,

Could you please share the output of `kubectl -n <namespace> describe psmdb-backup <backup_name>`? It should have more descriptive error message there.

---

<div class="post-metadata">

**Author:** ![jamoser](https://avatars.discourse-cdn.com/v4/letter/j/b2d939/32.png) [@jamoser](https://forums.percona.com/u/jamoser)\
**Post date:** [June 30, 2021, 11:13am UTC](https://forums.percona.com/t/backup-not-working-with-percona-distribution-for-mongodb-operator/11120/3 "2021-06-30T11:13:15Z")

</div>

Hi @Ege_Gunes

Thanks a lot for the kubectl cmd. It turned out that the keys were in the wrong format.
