# Apt-get Error  installing  Percona-Server on Ubuntu Lucid

**URL:** <https://forums.percona.com/t/apt-get-error-installing-percona-server-on-ubuntu-lucid/1577>\
**Category:** Other MySQL® Questions\
**Created:** [December 9, 2010, 10:52am UTC](https://forums.percona.com/t/apt-get-error-installing-percona-server-on-ubuntu-lucid/1577 "2010-12-09T10:52:38Z")\
**Posts on this page:** 7\
**Page:** 1

<div class="post-metadata">

**Author:** ![robmorin](https://avatars.discourse-cdn.com/v4/letter/r/8491ac/32.png) [@robmorin](https://forums.percona.com/u/robmorin)\
**Post date:** [December 9, 2010, 10:52am UTC](https://forums.percona.com/t/apt-get-error-installing-percona-server-on-ubuntu-lucid/1577/1 "2010-12-09T10:52:38Z")

</div>

Hello all, my first post here , so be gentle. 🙂

I am trying to install Percona server 5.1 on a Dev machine, Ubuntu Lucid 64 bit. I installed the repos, and followed all instructions as per Percona website, however no matter what i do i always get the below error…

Any ideas?? What logs if any would i check?

Thanks to all

root@D9:/usr/local# apt-get install percona-server-server-5.1

Reading package lists… Done  
Building dependency tree  
Reading state information… Done  
percona-server-server-5.1 is already the newest version.  
The following packages were automatically installed and are no longer required:  
libsensors4 libsnmp15 dbconfig-common linux-headers-2.6.32-24-server libsnmp-base libmcrypt4 snmp linux-headers-2.6.32-24 radiusclient1 lm-sensors  
libradius1 fancontrol php5-mcrypt libperl5.10 wwwconfig-common javascript-common libjs-mootools  
Use ‘apt-get autoremove’ to remove them.  
0 upgraded, 0 newly installed, 0 to remove and 6 not upgraded.  
1 not fully installed or removed.  
After this operation, 0B of additional disk space will be used.  
Setting up percona-server-server-5.1 (5.1.52-11.6-140.lucid) …

- Stopping MySQL database server mysqld [OK]
- Starting MySQL database server mysqld [fail]  
invoke-rc.d: initscript mysql, action “start” failed.  
dpkg: error processing percona-server-server-5.1 (–configure):  
subprocess installed post-installation script returned error exit status 1  
Errors were encountered while processing:  
percona-server-server-5.1  
E: Sub-process /usr/bin/dpkg returned an error code (1)

---

<div class="post-metadata">

**Author:** ![Michael\_Schueler](https://avatars.discourse-cdn.com/v4/letter/m/a5b964/32.png) [@Michael\_Schueler](https://forums.percona.com/u/Michael_Schueler)\
**Post date:** [December 12, 2010, 3:58pm UTC](https://forums.percona.com/t/apt-get-error-installing-percona-server-on-ubuntu-lucid/1577/2 "2010-12-12T15:58:23Z")

</div>

/var/log/syslog

/var/log/messages

dpkg -l | egrep -i ‘percona|mysql’

---

<div class="post-metadata">

**Author:** ![umutbesler](https://avatars.discourse-cdn.com/v4/letter/u/bcef8e/32.png) [@umutbesler](https://forums.percona.com/u/umutbesler)\
**Post date:** [December 13, 2010, 3:43am UTC](https://forums.percona.com/t/apt-get-error-installing-percona-server-on-ubuntu-lucid/1577/3 "2010-12-13T03:43:13Z")

</div>

Try

apt-get remove mysql-server-core-5.1

---

<div class="post-metadata">

**Author:** ![robmorin](https://avatars.discourse-cdn.com/v4/letter/r/8491ac/32.png) [@robmorin](https://forums.percona.com/u/robmorin)\
**Post date:** [December 13, 2010, 7:47am UTC](https://forums.percona.com/t/apt-get-error-installing-percona-server-on-ubuntu-lucid/1577/4 "2010-12-13T07:47:44Z")

</div>

Here is syslog

Dec 13 08:07:14 D9 mysqld\_safe[9786]:  
Dec 13 08:07:14 D9 mysqld\_safe[9786]: PLEASE REMEMBER TO SET A PASSWORD FOR THE MySQL root USER !  
Dec 13 08:07:14 D9 mysqld\_safe[9786]: To do so, start the server, then issue the following commands:  
Dec 13 08:07:14 D9 mysqld\_safe[9786]:  
Dec 13 08:07:14 D9 mysqld\_safe[9786]: /usr/bin/mysqladmin -u root password ‘new-password’  
Dec 13 08:07:14 D9 mysqld\_safe[9786]: /usr/bin/mysqladmin -u root -h D9 password ‘new-password’  
Dec 13 08:07:14 D9 mysqld\_safe[9786]:  
Dec 13 08:07:14 D9 mysqld\_safe[9786]: Alternatively you can run:  
Dec 13 08:07:14 D9 mysqld\_safe[9786]: /usr/bin/mysql\_secure\_installation  
Dec 13 08:07:14 D9 mysqld\_safe[9786]:  
Dec 13 08:07:14 D9 mysqld\_safe[9786]: which will also give you the option of removing the test  
Dec 13 08:07:14 D9 mysqld\_safe[9786]: databases and anonymous user created by default. This is  
Dec 13 08:07:14 D9 mysqld\_safe[9786]: strongly recommended for production servers.  
Dec 13 08:07:14 D9 mysqld\_safe[9786]:  
Dec 13 08:07:14 D9 mysqld\_safe[9786]: See the manual for more instructions.  
Dec 13 08:07:14 D9 mysqld\_safe[9786]:  
Dec 13 08:07:14 D9 mysqld\_safe[9786]: Please report any problems with the /usr/scripts/mysqlbug script!  
Dec 13 08:07:14 D9 mysqld\_safe[9786]:  
Dec 13 08:07:14 D9 mysqld\_safe[9786]: For commercial support please contact Percona at [URL][http://www.percona.com/contacts.html[/URL]](http://www.percona.com/contacts.html%5B/URL%5D)  
Dec 13 08:07:14 D9 mysqld\_safe[9786]:  
Dec 13 08:07:14 D9 mysqld\_safe[9786]: For commercial support please contact Percona at [URL][http://www.percona.com/contacts.html[/URL]](http://www.percona.com/contacts.html%5B/URL%5D)  
Dec 13 08:07:14 D9 mysqld\_safe[9786]:  
Dec 13 08:07:14 D9 mysqld\_safe[9831]: 101213 8:07:14 [Note] Plugin ‘FEDERATED’ is disabled.  
Dec 13 08:07:14 D9 mysqld\_safe[9831]: InnoDB: The InnoDB memory heap is disabled  
Dec 13 08:07:14 D9 mysqld\_safe[9831]: InnoDB: Mutexes and rw\_locks use GCC atomic builtins  
Dec 13 08:07:14 D9 mysqld\_safe[9831]: InnoDB: Compressed tables use zlib 1.2.3.3  
Dec 13 08:07:14 D9 mysqld\_safe[9831]: InnoDB: The first specified data file ./ibdata1 did not exist:  
Dec 13 08:07:14 D9 mysqld\_safe[9831]: InnoDB: a new database to be created!  
Dec 13 08:07:14 D9 mysqld\_safe[9831]: 101213 8:07:14 InnoDB: Setting file ./ibdata1 size to 10 MB  
Dec 13 08:07:14 D9 mysqld\_safe[9831]: InnoDB: Database physically writes the file full: wait…  
Dec 13 08:07:15 D9 mysqld\_safe[9831]: 101213 8:07:15 InnoDB: Log file ./ib\_logfile0 did not exist: new to be created  
Dec 13 08:07:15 D9 mysqld\_safe[9831]: InnoDB: Setting log file ./ib\_logfile0 size to 5 MB  
Dec 13 08:07:15 D9 mysqld\_safe[9831]: InnoDB: Database physically writes the file full: wait…  
Dec 13 08:07:15 D9 mysqld\_safe[9831]: 101213 8:07:15 InnoDB: Log file ./ib\_logfile1 did not exist: new to be created  
Dec 13 08:07:15 D9 mysqld\_safe[9831]: InnoDB: Setting log file ./ib\_logfile1 size to 5 MB  
Dec 13 08:07:15 D9 mysqld\_safe[9831]: InnoDB: Database physically writes the file full: wait…  
Dec 13 08:07:15 D9 mysqld\_safe[9831]: InnoDB: Doublewrite buffer not found: creating new  
Dec 13 08:07:15 D9 mysqld\_safe[9831]: InnoDB: Doublewrite buffer created  
Dec 13 08:07:15 D9 mysqld\_safe[9831]: InnoDB: Creating foreign key constraint system tables  
Dec 13 08:07:15 D9 mysqld\_safe[9831]: InnoDB: Foreign key constraint system tables created  
Dec 13 08:07:15 D9 mysqld\_safe[9831]: 101213 8:07:15 Percona XtraDB ([http://www.percona.com](http://www.percona.com)) 1.0.13-11.6 started; log sequence number 0  
Dec 13 08:07:15 D9 mysqld\_safe[9831]: 101213 8:07:15 InnoDB: Starting shutdown…  
Dec 13 08:07:27 D9 mysqld\_safe[9831]: 101213 8:07:27 InnoDB: Shutdown completed; log sequence number 45342  
Dec 13 08:07:38 D9 mysqld\_safe[9884]: 101213 8:07:38 [Note] Plugin ‘FEDERATED’ is disabled.  
Dec 13 08:07:38 D9 mysqld\_safe[9884]: InnoDB: The InnoDB memory heap is disabled  
Dec 13 08:07:38 D9 mysqld\_safe[9884]: InnoDB: Mutexes and rw\_locks use GCC atomic builtins  
Dec 13 08:07:38 D9 mysqld\_safe[9884]: InnoDB: Compressed tables use zlib 1.2.3.3  
Dec 13 08:07:38 D9 mysqld\_safe[9884]: 101213 8:07:38 InnoDB: highest supported file format is Barracuda.  
Dec 13 08:07:38 D9 mysqld\_safe[9884]: 101213 8:07:38 Percona XtraDB ([http://www.percona.com](http://www.percona.com)) 1.0.13-11.6 started; log sequence number 45356  
Dec 13 08:07:38 D9 mysqld\_safe[9884]: ERROR: 1064 You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'ALTER TABLE user ADD column Show\_view\_priv enum(‘N’,‘Y’) CHARACTER SET utf8 NOT ’ at line 1  
Dec 13 08:07:38 D9 mysqld\_safe[9884]: 101213 8:07:38 [ERROR] Aborting  
Dec 13 08:07:38 D9 mysqld\_safe[9884]:  
Dec 13 08:07:38 D9 mysqld\_safe[9884]: 101213 8:07:38 InnoDB: Starting shutdown…  
Dec 13 08:07:50 D9 mysqld\_safe[9884]: 101213 8:07:50 InnoDB: Shutdown completed; log sequence number 45356  
Dec 13 08:07:50 D9 mysqld\_safe[9884]: 101213 8:07:50 [Note] /usr/sbin/mysqld: Shutdown complete  
Dec 13 08:07:50 D9 mysqld\_safe[9884]:  
Dec 13 08:07:50 D9 mysqld\_safe[9907]: 101213 8:07:50 [Note] Plugin ‘FEDERATED’ is disabled.  
Dec 13 08:07:50 D9 mysqld\_safe[9907]: InnoDB: The InnoDB memory heap is disabled  
Dec 13 08:07:50 D9 mysqld\_safe[9907]: InnoDB: Mutexes and rw\_locks use GCC atomic builtins  
Dec 13 08:07:50 D9 mysqld\_safe[9907]: InnoDB: Compressed tables use zlib 1.2.3.3  
Dec 13 08:07:50 D9 mysqld\_safe[9907]: 101213 8:07:50 InnoDB: highest supported file format is Barracuda.  
Dec 13 08:07:50 D9 mysqld\_safe[9907]: 101213 8:07:50 Percona XtraDB ([http://www.percona.com](http://www.percona.com)) 1.0.13-11.6 started; log sequence number 45356  
Dec 13 08:07:50 D9 mysqld\_safe[9907]: 101213 8:07:50 InnoDB: Starting shutdown…  
Dec 13 08:08:01 D9 mysqld\_safe[9907]: 101213 8:08:01 InnoDB: Shutdown completed; log sequence number 45356  
Dec 13 08:08:01 D9 mysqld\_safe[9930]: 101213 8:08:01 [Note] Plugin ‘FEDERATED’ is disabled.  
Dec 13 08:08:01 D9 mysqld\_safe[9930]: InnoDB: The InnoDB memory heap is disabled  
Dec 13 08:08:01 D9 mysqld\_safe[9930]: InnoDB: Mutexes and rw\_locks use GCC atomic builtins  
Dec 13 08:08:01 D9 mysqld\_safe[9930]: InnoDB: Compressed tables use zlib 1.2.3.3  
Dec 13 08:08:01 D9 mysqld\_safe[9930]: 101213 8:08:01 InnoDB: highest supported file format is Barracuda.  
Dec 13 08:08:02 D9 mysqld\_safe[9930]: 101213 8:08:02 Percona XtraDB ([http://www.percona.com](http://www.percona.com)) 1.0.13-11.6 started; log sequence number 45356  
Dec 13 08:08:02 D9 mysqld\_safe[9930]: ERROR: 1050 Table ‘plugin’ already exists  
Dec 13 08:08:02 D9 mysqld\_safe[9930]: 101213 8:08:02 [ERROR] Aborting  
Dec 13 08:08:02 D9 mysqld\_safe[9930]:  
Dec 13 08:08:02 D9 mysqld\_safe[9930]: 101213 8:08:02 InnoDB: Starting shutdown…  
Dec 13 08:08:13 D9 mysqld\_safe[9930]: 101213 8:08:13 InnoDB: Shutdown completed; log sequence number 45356  
Dec 13 08:08:13 D9 mysqld\_safe[9930]: 101213 8:08:13 [Note] /usr/sbin/mysqld: Shutdown complete  
Dec 13 08:08:13 D9 mysqld\_safe[9930]:  
Dec 13 08:08:13 D9 mysqld\_safe: Starting mysqld daemon with databases from /var/lib/mysql  
Dec 13 08:08:13 D9 mysqld: 101213 8:08:13 [Note] Plugin ‘FEDERATED’ is disabled.  
Dec 13 08:08:13 D9 mysqld: InnoDB: The InnoDB memory heap is disabled  
Dec 13 08:08:13 D9 mysqld: InnoDB: Mutexes and rw\_locks use GCC atomic builtins  
Dec 13 08:08:13 D9 mysqld: InnoDB: Compressed tables use zlib 1.2.3.3  
Dec 13 08:08:13 D9 mysqld: 101213 8:08:13 InnoDB: highest supported file format is Barracuda.  
Dec 13 08:08:13 D9 mysqld: 101213 8:08:13 Percona XtraDB ([http://www.percona.com](http://www.percona.com)) 1.0.13-11.6 started; log sequence number 45356  
Dec 13 08:08:13 D9 mysqld: 101213 8:08:13 [ERROR] Can’t start server: Bind on TCP/IP port: Address already in use  
Dec 13 08:08:13 D9 mysqld: 101213 8:08:13 [ERROR] Do you already have another mysqld server running on port: 3306 ?  
Dec 13 08:08:13 D9 mysqld: 101213 8:08:13 [ERROR] Aborting  
Dec 13 08:08:13 D9 mysqld:  
Dec 13 08:08:13 D9 mysqld: 101213 8:08:13 InnoDB: Starting shutdown…  
Dec 13 08:08:25 D9 mysqld: 101213 8:08:25 InnoDB: Shutdown completed; log sequence number 45356  
Dec 13 08:08:25 D9 mysqld: 101213 8:08:25 [Note] /usr/sbin/mysqld: Shutdown complete  
Dec 13 08:08:25 D9 mysqld:  
Dec 13 08:08:25 D9 mysqld\_safe: mysqld from pid file /var/run/mysqld/mysqld.pid ended  
Dec 13 08:08:27 D9 /etc/init.d/mysql[10293]: error: ‘Can’t connect to local MySQL server through socket ‘/var/run/mysqld/mysqld.sock’ (2)’  
Dec 13 08:08:27 D9 /etc/init.d/mysql[10293]: Check that mysqld is running and that the socket: ‘/var/run/mysqld/mysqld.sock’ exists!

Nothing in messages log

dpkg results

root@D9:~# dpkg -l | egrep -i ‘percona|mysql’  
ii libmysqlclient16 5.1.52-11.6-140.lucid Percona Server database client library  
ii percona-server-client-5.1 5.1.52-11.6-140.lucid Percona Server database client binaries  
ii percona-server-common 5.1.52-11.6-140.lucid Percona Server database common files (e.g. /  
iF percona-server-server-5.1 5.1.52-11.6-140.lucid Percona Server database server binaries

Anything else ?  
I removed all mysql before install percona

Thanks…

---

<div class="post-metadata">

**Author:** ![robmorin](https://avatars.discourse-cdn.com/v4/letter/r/8491ac/32.png) [@robmorin](https://forums.percona.com/u/robmorin)\
**Post date:** [December 13, 2010, 8:01am UTC](https://forums.percona.com/t/apt-get-error-installing-percona-server-on-ubuntu-lucid/1577/5 "2010-12-13T08:01:36Z")

</div>

Another bit of info…

when i did a ps -ax i found this

root@D9:/var/lib# ps -ax|grep mysql  
Warning: bad ps syntax, perhaps a bogus ‘-’? See [URL][http://procps.sf.net/faq.html[/URL]](http://procps.sf.net/faq.html%5B/URL%5D)  
12313 ? Ssl 0:00 /usr/sbin/mysqld

SO i killed it with a kill -9

Then i did another ps -ax right away and saw this…

12313 ? Ssl 0:00 /usr/sbin/mysqld  
12339 ? S 0:00 /bin/bash /etc/mysql/debian-start  
12341 ? S 0:00 /usr/bin/mysql\_upgrade --defaults-extra-file=/etc/mysql/debian.cnf  
12343 ? S 0:00 logger -p daemon.warn -i -t/etc/mysql/debian-start  
12354 ? S 0:00 sh -c ‘/usr/bin/mysql’ ‘–no-defaults’ ‘–port=3306’ ‘–socket=/var/run/mysqld/mysqld.sock’ ‘–host=localhost’ ‘–user=debian-sys-maint’ ‘–password=jLYtvEEuMdEwpGrL’ ‘–socket=/var/run/mysqld/mysqld.sock’ ‘–host=localhost’ ‘–user=debian-sys-maint’ ‘–password=jLYtvEEuMdEwpGrL’ ‘–socket=/var/run/mysqld/mysqld.sock’ ‘–user=debian-sys-maint’ ‘–database=mysql’ ‘–batch’ ‘–force’ ‘–silent’ \< /tmp/sqlaBFcvs 2\>&1  
12355 ? S 0:00 /usr/bin/mysql --no-defaults --port=3306 --socket=/var/run/mysqld/mysqld.sock --host=localhost --user=debian-sys-maint --password=x xxxxxxxxxxxxxx --socket=/var/run/mysqld/mysqld.sock --host=localhost --user=debian-sys-maint --password=x xxxxxxxxxxxxxx --socket=/var/run/mysqld/mysqld.sock --user=debian-sys-maint --database=mysql --batch --force --silent  
12357 pts/0 S+ 0:00 grep --color=auto mysql

Then i did another ps -aux about 5 seconds later and saw this…

root@D9:/var/lib# ps -ax|grep mysql  
Warning: bad ps syntax, perhaps a bogus ‘-’? See [URL][http://procps.sf.net/faq.html[/URL]](http://procps.sf.net/faq.html%5B/URL%5D)  
12313 ? Ssl 0:00 /usr/sbin/mysqld

It would seem the start up script is broken somehow, maybe? Or its a debian related thing?

I am starting and stopping with /etc/init.d/mysql

---

<div class="post-metadata">

**Author:** ![Michael\_Schueler](https://avatars.discourse-cdn.com/v4/letter/m/a5b964/32.png) [@Michael\_Schueler](https://forums.percona.com/u/Michael_Schueler)\
**Post date:** [December 13, 2010, 11:05am UTC](https://forums.percona.com/t/apt-get-error-installing-percona-server-on-ubuntu-lucid/1577/6 "2010-12-13T11:05:34Z")

</div>

according to the log file below, your server started up succesfully but then was restarted – was that from you? did you try just ignoring the error message and using the db?

apt-get reinstall percona-server-server-5.1  
tail -f /var/log/syslog  
ps auxw | grep mysql  
/etc/init.d/mysql start if needed  
mysql -uroot

---

<div class="post-metadata">

**Author:** ![robmorin](https://avatars.discourse-cdn.com/v4/letter/r/8491ac/32.png) [@robmorin](https://forums.percona.com/u/robmorin)\
**Post date:** [December 14, 2010, 9:55am UTC](https://forums.percona.com/t/apt-get-error-installing-percona-server-on-ubuntu-lucid/1577/7 "2010-12-14T09:55:30Z")

</div>

For some odd reason after a reboot all is fine???

Weird…

It starts and stops just fine…

Thanks for all your help…
