# After upgrade, PMM2 container fails to start with "Fatal glibc error: CPU does not support x86-64-v2"

**URL:** <https://forums.percona.com/t/after-upgrade-pmm2-container-fails-to-start-with-fatal-glibc-error-cpu-does-not-support-x86-64-v2/24059>\
**Category:** PMM 2.x\
**Created:** [July 31, 2023, 12:32pm UTC](https://forums.percona.com/t/after-upgrade-pmm2-container-fails-to-start-with-fatal-glibc-error-cpu-does-not-support-x86-64-v2/24059 "2023-07-31T12:32:59Z")\
**Posts on this page:** 6\
**Page:** 1

<div class="post-metadata">

**Author:** ![steffen](https://avatars.discourse-cdn.com/v4/letter/s/df788c/32.png) [@steffen](https://forums.percona.com/u/steffen)\
**Post date:** [July 31, 2023, 12:32pm UTC](https://forums.percona.com/t/after-upgrade-pmm2-container-fails-to-start-with-fatal-glibc-error-cpu-does-not-support-x86-64-v2/24059/1 "2023-07-31T12:32:59Z")

</div>

## Description:

I upgraded PMM2 container V2.37.1 to the latest version (“docker pull percona/pmm-server:2”).  
After that the container fails to start. Only error msg from “docker logs …” is  
Fatal glibc error: CPU does not support x86-64-v2

I see there’s a (new?) requirement “Your CPU must support the SSE4.2 instruction set… If your CPU is lacking this instruction set you won’t be able to use Query Analytics.”  
In /proc/cpuinfo the flags show “sse2”, but not “sse4\_2”.

But the requirement only states that QA requires SSE4.2. Is it correct that all of PMM2 refuses to run?

## Version:

2.38.1

## Additional Information:

OS is Debian 11, running in a ProxMox VM

---

<div class="post-metadata">

**Author:** ![steve.hoffman](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/steve.hoffman/32/66_2.png) [@steve.hoffman](https://forums.percona.com/u/steve.hoffman)\
**Post date:** [July 31, 2023, 12:57pm UTC](https://forums.percona.com/t/after-upgrade-pmm2-container-fails-to-start-with-fatal-glibc-error-cpu-does-not-support-x86-64-v2/24059/2 "2023-07-31T12:57:22Z")

</div>

As of PMM 2.38.0, the base image for the PMM docker container is RHEL9 which requires x86-64-v2. While it is possible your underlying CPU doesn’t support this, it’s more likely your virtualization (KVM?) is limiting it. I’m not really familiar with ProxMox but some googling shows you can change the driver or just allow direct passthrough of the hosts capabilities. What I found online suggested you change your cpu type from `kvm64` to `max` but far from an expert so maybe setup a test system first!

---

<div class="post-metadata">

**Author:** ![steffen](https://avatars.discourse-cdn.com/v4/letter/s/df788c/32.png) [@steffen](https://forums.percona.com/u/steffen)\
**Post date:** [July 31, 2023, 1:06pm UTC](https://forums.percona.com/t/after-upgrade-pmm2-container-fails-to-start-with-fatal-glibc-error-cpu-does-not-support-x86-64-v2/24059/3 "2023-07-31T13:06:53Z")

</div>

Hi Steve, thanks for the quick reply. We already changed the cpu emulation in ProxMox and that fixed it.  
But maybe you want to check the docs about that requirement. To me it sounded like only Query Analytics requires it, but if the container itself needs it, maybe that should be noted somewhere.

---

<div class="post-metadata">

**Author:** ![steve.hoffman](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/steve.hoffman/32/66_2.png) [@steve.hoffman](https://forums.percona.com/u/steve.hoffman)\
**Post date:** [July 31, 2023, 2:03pm UTC](https://forums.percona.com/t/after-upgrade-pmm2-container-fails-to-start-with-fatal-glibc-error-cpu-does-not-support-x86-64-v2/24059/4 "2023-07-31T14:03:56Z")

</div>

Can you point me to the docs and I’ll edit (you also can edit it by clicking the little pencil icon at the top of the page and submitting a PR). I agree we need consistency…this may have been true (only impacting Query Analytics) prior to moving from CentOS7 to Oracle Linux 9 but now it impacts everything!

---

<div class="post-metadata">

**Author:** ![steffen](https://avatars.discourse-cdn.com/v4/letter/s/df788c/32.png) [@steffen](https://forums.percona.com/u/steffen)\
**Post date:** [July 31, 2023, 2:09pm UTC](https://forums.percona.com/t/after-upgrade-pmm2-container-fails-to-start-with-fatal-glibc-error-cpu-does-not-support-x86-64-v2/24059/5 "2023-07-31T14:09:33Z")

</div>

Sure: [Server - Percona Monitoring and Management](https://docs.percona.com/percona-monitoring-and-management/setting-up/server/index.html) under “Architecture” mentions the requirement für Clickhouse/Query Analytics.  
And the chapter [Docker - Percona Monitoring and Management](https://docs.percona.com/percona-monitoring-and-management/setting-up/server/docker.html) doesn’t mention the requirement at all. A hint there could be helpful.

---

<div class="post-metadata">

**Author:** ![steve.hoffman](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/steve.hoffman/32/66_2.png) [@steve.hoffman](https://forums.percona.com/u/steve.hoffman)\
**Post date:** [July 31, 2023, 2:57pm UTC](https://forums.percona.com/t/after-upgrade-pmm2-container-fails-to-start-with-fatal-glibc-error-cpu-does-not-support-x86-64-v2/24059/6 "2023-07-31T14:57:46Z")

</div>

Just submitted hints on both pages!

Thanks for pointing it out!
