# After mysql.5.6.28 upgrade to 8.0.23, percona-xtrabackup-8.0.23 could not be used with mysql 8.0.23

**URL:** <https://forums.percona.com/t/after-mysql-5-6-28-upgrade-to-8-0-23-percona-xtrabackup-8-0-23-could-not-be-used-with-mysql-8-0-23/11054>\
**Category:** Percona XtraBackup\
**Tags:** percona\
**Created:** [June 27, 2021, 4:22am UTC](https://forums.percona.com/t/after-mysql-5-6-28-upgrade-to-8-0-23-percona-xtrabackup-8-0-23-could-not-be-used-with-mysql-8-0-23/11054 "2021-06-27T04:22:11Z")\
**Posts on this page:** 5\
**Page:** 1

<div class="post-metadata">

**Author:** ![zhouke](https://avatars.discourse-cdn.com/v4/letter/z/3bc359/32.png) [@zhouke](https://forums.percona.com/u/zhouke)\
**Post date:** [June 27, 2021, 4:22am UTC](https://forums.percona.com/t/after-mysql-5-6-28-upgrade-to-8-0-23-percona-xtrabackup-8-0-23-could-not-be-used-with-mysql-8-0-23/11054/1 "2021-06-27T04:22:11Z")

</div>

HELP!  
after I Upgrade mysql from 5.6.28 to 8.0.23,i used percona-xtrabackup-8.0.23-16 to backup mysql8.0.23’s data, but an error occurred when use the --prepare command with percona-xtrabackup-8.0.23-16,the error message is

InnoDB: Assertion failure: os0file.cc:2907  
InnoDB: thread 140477846411648InnoDB: We intentionally generate a memory trap.  
InnoDB: Submit a detailed bug report to [https://jira.percona.com/projects/PXB](https://jira.percona.com/projects/PXB).  
InnoDB: If you get repeated assertion failures or crashes, even  
InnoDB: immediately after the mysqld startup, there may be  
InnoDB: corruption in the InnoDB tablespace. Please refer to  
InnoDB: [MySQL :: MySQL 8.0 Reference Manual :: 15.21.3 Forcing InnoDB Recovery](http://dev.mysql.com/doc/refman/8.0/en/forcing-innodb-recovery.html)  
InnoDB: about forcing recovery.  
07:03:37 UTC - mysqld got signal 6 ;  
Most likely, you have hit a bug, but this error can also be caused by malfunctioning hardware.  
Thread pointer: 0x0  
Attempting backtrace. You can use the following information to find out  
where mysqld died. If you see no messages after this, something went  
terribly wrong…  
stack\_bottom = 0 thread\_stack 0x46000  
/tmp/percona-xtrabackup-8.0.23-16-Linux-x86\_64.glibc2.12-minimal/bin/xtrabackup(my\_print\_stacktrace(unsigned char const\*, unsigned long)+0x2e) [0x23d14ce]  
/tmp/percona-xtrabackup-8.0.23-16-Linux-x86\_64.glibc2.12-minimal/bin/xtrabackup(handle\_fatal\_signal+0x2f3) [0x1205733]  
/lib64/libpthread.so.0(+0xf630) [0x7fc38be11630]  
/lib64/libc.so.6(gsignal+0x37) [0x7fc389c0a3d7]  
/lib64/libc.so.6(abort+0x148) [0x7fc389c0bac8]  
/tmp/percona-xtrabackup-8.0.23-16-Linux-x86\_64.glibc2.12-minimal/bin/xtrabackup(ut\_dbg\_assertion\_failed(char const\*, char const\*, unsigned long)+0xb2) [0x1686402]  
/tmp/percona-xtrabackup-8.0.23-16-Linux-x86\_64.glibc2.12-minimal/bin/xtrabackup(os\_file\_flush\_func(int)+0x93) [0x155b483]  
/tmp/percona-xtrabackup-8.0.23-16-Linux-x86\_64.glibc2.12-minimal/bin/xtrabackup(os\_file\_set\_size(char const\*, pfs\_os\_file\_t, unsigned long, unsigned long, bool, bool)+0x728) [0x1564638]  
/tmp/percona-xtrabackup-8.0.23-16-Linux-x86\_64.glibc2.12-minimal/bin/xtrabackup() [0xca525a]  
/tmp/percona-xtrabackup-8.0.23-16-Linux-x86\_64.glibc2.12-minimal/bin/xtrabackup() [0xca559b]  
/tmp/percona-xtrabackup-8.0.23-16-Linux-x86\_64.glibc2.12-minimal/bin/xtrabackup(srv\_start(bool, unsigned long)+0x1a70) [0x16314a0]  
/tmp/percona-xtrabackup-8.0.23-16-Linux-x86\_64.glibc2.12-minimal/bin/xtrabackup() [0xcecd8b]  
/tmp/percona-xtrabackup-8.0.23-16-Linux-x86\_64.glibc2.12-minimal/bin/xtrabackup() [0xceeba9]  
/tmp/percona-xtrabackup-8.0.23-16-Linux-x86\_64.glibc2.12-minimal/bin/xtrabackup(main+0xca9) [0xcab749]  
/lib64/libc.so.6(\_\_libc\_start\_main+0xf5) [0x7fc389bf6555]  
/tmp/percona-xtrabackup-8.0.23-16-Linux-x86\_64.glibc2.12-minimal/bin/xtrabackup() [0xcda599]  
I want to sure if there is a bug that percona-xtrabackup-8.0.23-16 could’t be used with mysql8.0.23 version ,if this mysql 8.0.23 version was upgraded from other versions

---

<div class="post-metadata">

**Author:** ![Marcelo\_Altmann](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/marcelo_altmann/32/11299_2.png) [@Marcelo\_Altmann](https://forums.percona.com/u/Marcelo_Altmann)\
**Post date:** [June 28, 2021, 10:47am UTC](https://forums.percona.com/t/after-mysql-5-6-28-upgrade-to-8-0-23-percona-xtrabackup-8-0-23-could-not-be-used-with-mysql-8-0-23/11054/2 "2021-06-28T10:47:13Z")

</div>

HI There,

Are you preparing a backup stored on a network mount point. If so can you try to copy it to local disk then prepare it?

The error you are getting is because fsync operation returned an error. This error is recognized by Xtrabackup as safe to retry the operation, so it aborts.

---

<div class="post-metadata">

**Author:** ![zhouke](https://avatars.discourse-cdn.com/v4/letter/z/3bc359/32.png) [@zhouke](https://forums.percona.com/u/zhouke)\
**Post date:** [June 28, 2021, 2:25pm UTC](https://forums.percona.com/t/after-mysql-5-6-28-upgrade-to-8-0-23-percona-xtrabackup-8-0-23-could-not-be-used-with-mysql-8-0-23/11054/3 "2021-06-28T14:25:47Z")

</div>

Hi, Marcelo\_Altman  
Thanks for your reply on time,in fact I did’t run --prepare command on a network mount point with Xtrabackup,i tried run --prepare command with Xtrabackup on the local disk many times, and the same error occurred at every time.

I upgrade oracle mysql from 5.6.28 to 8.0.24 just server hours ago and using percona-xtrabackup-8.0.25-17 to backup mysql 8.0.24’s data and run --prepare command, i did’t find the same error,Xtrabackup works normal. the error I experienced is very easy to repeat,maybe it’s a bug of mysql8.0.23?,I look forward to your reply.

---

<div class="post-metadata">

**Author:** ![Marcelo\_Altmann](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/marcelo_altmann/32/11299_2.png) [@Marcelo\_Altmann](https://forums.percona.com/u/Marcelo_Altmann)\
**Post date:** [June 28, 2021, 2:49pm UTC](https://forums.percona.com/t/after-mysql-5-6-28-upgrade-to-8-0-23-percona-xtrabackup-8-0-23-could-not-be-used-with-mysql-8-0-23/11054/4 "2021-06-28T14:49:53Z")

</div>

The stack trace you posted is related to a failure on fsync system call. So that has something to deal with the underlining disk returning error to xtrabackup fsync call.

We did have an issue at PXB 8.0.23 that was fixed on 8.0.25 but that is not related to the stack trace you posted - [[PXB-2455] xtrabackup prepare fails if checkpoint lsn is more than the last lsn - Percona JIRA](https://jira.percona.com/browse/PXB-2455)

---

<div class="post-metadata">

**Author:** ![zhouke](https://avatars.discourse-cdn.com/v4/letter/z/3bc359/32.png) [@zhouke](https://forums.percona.com/u/zhouke)\
**Post date:** [June 28, 2021, 3:46pm UTC](https://forums.percona.com/t/after-mysql-5-6-28-upgrade-to-8-0-23-percona-xtrabackup-8-0-23-could-not-be-used-with-mysql-8-0-23/11054/5 "2021-06-28T15:46:47Z")

</div>

Hi, Marcelo\_Altman  
thanks for your reply,I will try to repeat this situation in different disk environment.thank you very much.
