# "access denied" failure

**URL:** https://forums.percona.com/t/access-denied-failure/3608
**Category:** Percona Cloud Tools
**Created:** [July 10, 2014, 12:11pm UTC](https://forums.percona.com/t/access-denied-failure/3608 "2014-07-10T12:11:50Z")
**Posts on this page:** 5
**Page:** 1

<div class="post-metadata">

### Author: ![pblazek](https://avatars.discourse-cdn.com/v4/letter/p/f08c70/32.png) [@pblazek](https://forums.percona.com/u/pblazek)
#### Post date: [July 10, 2014, 12:11pm UTC](https://forums.percona.com/t/access-denied-failure/3608/1 "2014-07-10T12:11:50Z")

</div>

I have just removed 1.0.3 and installed 1.0.4 on a server. I get:

Warning 2014-07-10 13:16:09 [mm-mysql-db1.towxchange.net](http://mm-mysql-db1.towxchange.net) Failed to connect to MySQL after 1 tries (Error 1045: Access denied for user ‘percona-agent’@‘localhost’ (using password: YES))

every couple of minutes in the log. Here is a snippet from the install:

Create MySQL user for agent? (‘N’ to use existing user) (Y):  
Specify a root/super MySQL user to create a user for the agent  
MySQL username: root  
MySQL password:  
MySQL host[: port] or socket file (localhost): 127.0.0.1  
Testing MySQL connection root:…@tcp(127.0.0.1:3306)…  
MySQL connection OK  
Creating new MySQL user for agent…  
Agent MySQL user: percona-agent:0xc2080297a02596996162@tcp(127.0.0.1:3306)/?parseTime=true

As you can see, I specified 127.0.0.1 as the host. The installer created a user [percona-agent&#64;127.0.0.1](mailto:percona-agent&#64;127.0.0.1), which I modified to [percona-agent&#64;localhost](mailto:percona-agent&#64;localhost) due to the error message I was receiving. I have verified the password hash. I have also added a duplicate user [percona-agent&#64;127.0.0.1](mailto:percona-agent&#64;127.0.0.1) with the same password hash and privileges (SUPER, PROCESS). What have I missed?

---

<div class="post-metadata">

### Author: ![kamil-dziedzic](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/kamil-dziedzic/32/16873_2.png) [@kamil-dziedzic](https://forums.percona.com/u/kamil-dziedzic)
#### Post date: [July 11, 2014, 10:24am UTC](https://forums.percona.com/t/access-denied-failure/3608/2 "2014-07-11T10:24:59Z")

</div>

Hi pblazek,

Could you request support from our web interface on [cloud.percona.com](http://cloud.percona.com)? After you login, please use a “Support” button which is at the bottom of the page and include all above details in the message.

---

<div class="post-metadata">

### Author: ![pblazek](https://avatars.discourse-cdn.com/v4/letter/p/f08c70/32.png) [@pblazek](https://forums.percona.com/u/pblazek)
#### Post date: [July 11, 2014, 1:45pm UTC](https://forums.percona.com/t/access-denied-failure/3608/3 "2014-07-11T13:45:55Z")

</div>

Done - thanks.

---

<div class="post-metadata">

### Author: ![Ruskicowboy](https://avatars.discourse-cdn.com/v4/letter/r/71c47a/32.png) [@Ruskicowboy](https://forums.percona.com/u/Ruskicowboy)
#### Post date: [August 16, 2014, 7:18pm UTC](https://forums.percona.com/t/access-denied-failure/3608/4 "2014-08-16T19:18:38Z")

</div>

I’m getting the same thing. Will request support.

---

<div class="post-metadata">

### Author: ![aleoycdv](https://avatars.discourse-cdn.com/v4/letter/a/c6cbf5/32.png) [@aleoycdv](https://forums.percona.com/u/aleoycdv)
#### Post date: [August 27, 2014, 5:30pm UTC](https://forums.percona.com/t/access-denied-failure/3608/5 "2014-08-27T17:30:14Z")

</div>

Maybe is because the root permissions have been lost… you would have to check it,
