# 5.5.21 Crash  then  auto recovery again and again ,but always failed.

**URL:** <https://forums.percona.com/t/5-5-21-crash-then-auto-recovery-again-and-again-but-always-failed/3428>\
**Category:** Other MySQL® Questions\
**Created:** [April 27, 2014, 2:25am UTC](https://forums.percona.com/t/5-5-21-crash-then-auto-recovery-again-and-again-but-always-failed/3428 "2014-04-27T02:25:58Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![lzp888127](https://avatars.discourse-cdn.com/v4/letter/l/bbe5ce/32.png) [@lzp888127](https://forums.percona.com/u/lzp888127)\
**Post date:** [April 27, 2014, 2:25am UTC](https://forums.percona.com/t/5-5-21-crash-then-auto-recovery-again-and-again-but-always-failed/3428/1 "2014-04-27T02:25:58Z")

</div>

I had occurred many times, error like this:

140427 14:11:04 InnoDB: Assertion failure in thread 139751980574464 in file row0sel.c line 4619  
InnoDB: Failing assertion: trx-\>isolation\_level == TRX\_ISO\_READ\_UNCOMMITTED  
InnoDB: We intentionally generate a memory trap.  
InnoDB: Submit a detailed bug report to [http://bugs.mysql.com](http://bugs.mysql.com).  
InnoDB: If you get repeated assertion failures or crashes, even  
InnoDB: immediately after the mysqld startup, there may be  
InnoDB: corruption in the InnoDB tablespace. Please refer to  
InnoDB: [url][http://dev.mysql.com/doc/refman/5.5/en/forcing-innodb-recovery.html[/url]](http://dev.mysql.com/doc/refman/5.5/en/forcing-innodb-recovery.html%5B/url%5D)  
InnoDB: about forcing recovery.  
06:11:04 UTC - mysqld got signal 6 ;  
This could be because you hit a bug. It is also possible that this binary  
or one of the libraries it was linked against is corrupt, improperly built,  
or misconfigured. This error can also be caused by malfunctioning hardware.  
We will try our best to scrape up some info that will hopefully help  
diagnose the problem, but since we have already crashed,  
something is definitely wrong and this may fail.

key\_buffer\_size=33554432  
read\_buffer\_size=131072  
max\_used\_connections=540  
max\_threads=2000  
thread\_count=193  
connection\_count=193  
It is possible that mysqld could use up to  
key\_buffer\_size + (read\_buffer\_size + sort\_buffer\_size)\*max\_threads = 4409252 K bytes of memory  
Hope that’s ok; if not, decrease some variables in the equation.

Thread pointer: 0x5796d0a0  
Attempting backtrace. You can use the following information to find out  
where mysqld died. If you see no messages after this, something went  
terribly wrong…  
stack\_bottom = 7f1a8b289e60 thread\_stack 0x40000  
/usr/local/Percona-Server-5.5.21-rel25.1-234.Linux.x86\_64/bin/mysqld(my\_print\_stacktrace+0x35)[0x7d3d45]  
/usr/local/Percona-Server-5.5.21-rel25.1-234.Linux.x86\_64/bin/mysqld(handle\_fatal\_signal+0x3e1)[0x68fdf1]  
/lib64/libpthread.so.0[0x32d260f500]  
/lib64/libc.so.6(gsignal+0x35)[0x32d22328a5]  
/lib64/libc.so.6(abort+0x175)[0x32d2234085]  
/usr/local/Percona-Server-5.5.21-rel25.1-234.Linux.x86\_64/bin/mysqld[0x80e0ca]  
/usr/local/Percona-Server-5.5.21-rel25.1-234.Linux.x86\_64/bin/mysqld[0x7e17bb]  
/usr/local/Percona-Server-5.5.21-rel25.1-234.Linux.x86\_64/bin/mysqld[0x7e17bb]  
/usr/local/Percona-Server-5.5.21-rel25.1-234.Linux.x86\_64/bin/mysqld(\_ZN7handler18index\_read\_idx\_mapEPhjPKhm16ha\_rkey\_function+0x71)[0x690891]  
/usr/local/Percona-Server-5.5.21-rel25.1-234.Linux.x86\_64/bin/mysqld[0x59f49b]  
/usr/local/Percona-Server-5.5.21-rel25.1-234.Linux.x86\_64/bin/mysqld[0x5aa82e]  
/usr/local/Percona-Server-5.5.21-rel25.1-234.Linux.x86\_64/bin/mysqld[0x5ae3a5]  
/usr/local/Percona-Server-5.5.21-rel25.1-234.Linux.x86\_64/bin/mysqld(\_ZN4JOIN8optimizeEv+0x55d)[0x5b133d]  
/usr/local/Percona-Server-5.5.21-rel25.1-234.Linux.x86\_64/bin/mysqld(\_Z12mysql\_selectP3THDPPP4ItemP10TABLE\_LISTjR4ListIS1\_ES2\_jP8st\_orderSB\_S2\_SB\_yP13select\_resultP18st\_select\_lex\_unitP13st\_select\_lex+0xd2)[0x5bb472]  
/usr/local/Percona-Server-5.5.21-rel25.1-234.Linux.x86\_64/bin/mysqld(\_Z13handle\_selectP3THDP3LEXP13select\_resultm+0x1ce)[0x5bbeae]  
/usr/local/Percona-Server-5.5.21-rel25.1-234.Linux.x86\_64/bin/mysqld[0x57905d]  
/usr/local/Percona-Server-5.5.21-rel25.1-234.Linux.x86\_64/bin/mysqld(\_Z21mysql\_execute\_commandP3THD+0x2cde)[0x57c20e]  
/usr/local/Percona-Server-5.5.21-rel25.1-234.Linux.x86\_64/bin/mysqld(\_Z11mysql\_parseP3THDPcjP12Parser\_state+0x3c3)[0x57f9c3]  
/usr/local/Percona-Server-5.5.21-rel25.1-234.Linux.x86\_64/bin/mysqld(\_Z16dispatch\_command19enum\_server\_commandP3THDPcj+0x14a1)[0x580e81]  
/usr/local/Percona-Server-5.5.21-rel25.1-234.Linux.x86\_64/bin/mysqld(\_Z10do\_commandP3THD+0x106)[0x581216]  
/usr/local/Percona-Server-5.5.21-rel25.1-234.Linux.x86\_64/bin/mysqld(\_Z24do\_handle\_one\_connectionP3THD+0x111)[0x61c611]  
/usr/local/Percona-Server-5.5.21-rel25.1-234.Linux.x86\_64/bin/mysqld(handle\_one\_connection+0x54)[0x61c704]  
/lib64/libpthread.so.0[0x32d2607851]  
/lib64/libc.so.6(clone+0x6d)[0x32d22e890d]

---

<div class="post-metadata">

**Author:** ![niljoshi](https://sea1.discourse-cdn.com/flex019/user_avatar/forums.percona.com/niljoshi/32/16889_2.png) [@niljoshi](https://forums.percona.com/u/niljoshi)\
**Post date:** [April 29, 2014, 12:56am UTC](https://forums.percona.com/t/5-5-21-crash-then-auto-recovery-again-and-again-but-always-failed/3428/2 "2014-04-29T00:56:00Z")

</div>

Hi,

Can you provide full error log and output of pt-mysql-summary of this server? Are you getting this error while running some specific statement like update/alter table or something? There are few bugs related to this but I’m not sure if anyone is related to your case.

[url][MySQL Bugs: #64680: InnoDB: Assertion failure in thread \*\*\*\* in file row0sel.c line 2441](http://bugs.mysql.com/bug.php?id=64680%5B/url%5D)  
[url][https://bugs.launchpad.net/percona-xtradb-cluster/+bug/1206097[/url]](https://bugs.launchpad.net/percona-xtradb-cluster/+bug/1206097%5B/url%5D)  
[url][https://bugs.launchpad.net/percona-server/+bug/1071243[/url]](https://bugs.launchpad.net/percona-server/+bug/1071243%5B/url%5D)  
[url][MySQL Bugs: #62037: assert fails in row\_search\_for\_mysql on TRX\_ISO\_READ\_UNCOMMITTED](http://bugs.mysql.com/bug.php?id=62037%5B/url%5D)
