# 3 Nodes will not start Mysql Percona Xtradb Cluster

**URL:** <https://forums.percona.com/t/3-nodes-will-not-start-mysql-percona-xtradb-cluster/3016>\
**Category:** Percona XtraDB Cluster 5.x\
**Created:** [October 18, 2013, 5:43pm UTC](https://forums.percona.com/t/3-nodes-will-not-start-mysql-percona-xtradb-cluster/3016 "2013-10-18T17:43:55Z")\
**Posts on this page:** 3\
**Page:** 1

<div class="post-metadata">

**Author:** ![scjmoore](https://avatars.discourse-cdn.com/v4/letter/s/c0e974/32.png) [@scjmoore](https://forums.percona.com/u/scjmoore)\
**Post date:** [October 18, 2013, 5:43pm UTC](https://forums.percona.com/t/3-nodes-will-not-start-mysql-percona-xtradb-cluster/3016/1 "2013-10-18T17:43:55Z")

</div>

Hello All,

for some reasson none of my 3 nodes will start the Mysql Percona XtraDB server there logs say this I have only included the last 30 lines or so it was working until I rebooted all 3 servers and now they will not start. I would apractiate any help.

one thing is it will work if I remove /etc/my.cnf then mysql server will start as soon as I had back /etc/my.cnf with the cluster settings for each node it will not start.

131018 22:59:47 [Note] WSREP: gcomm: connecting to group ‘webpack\_cluster’, peer ‘213.146.173.233:,5.254.161.101:,5.254.161.104:’  
131018 22:59:47 [Warning] WSREP: (fc8c10cf-3848-11e3-b378-8387ce3182f5, ‘tcp://0.0.0.0:4567’) address ‘tcp://5.254.161.104:4567’ points to own listening address, blacklisting  
131018 22:59:50 [Warning] WSREP: no nodes coming from prim view, prim not possible  
131018 22:59:50 [Note] WSREP: view(view\_id(NON\_PRIM,fc8c10cf-3848-11e3-b378-8387ce3182f5,1) memb {  
fc8c10cf-3848-11e3-b378-8387ce3182f5,  
} joined {  
} left {  
} partitioned {  
})  
131018 22:59:51 [Warning] WSREP: last inactive check more than PT1.5S ago (PT3.50306S), skipping check  
131018 23:00:20 [Note] WSREP: view((empty))  
131018 23:00:20 [ERROR] WSREP: failed to open gcomm backend connection: 110: failed to reach primary view: 110 (Connection timed out)  
at gcomm/src/pc.cpp:connect():139  
131018 23:00:20 [ERROR] WSREP: gcs/src/gcs\_core.c:gcs\_core\_open():195: Failed to open backend connection: -110 (Connection timed out)  
131018 23:00:20 [ERROR] WSREP: gcs/src/gcs.c:gcs\_open():1291: Failed to open channel ‘webpack\_cluster’ at ‘gcomm://213.146.173.233,5.254.161.101,5.254.161.104’: -110 (Connection timed out)  
131018 23:00:20 [ERROR] WSREP: gcs connect failed: Connection timed out  
131018 23:00:20 [ERROR] WSREP: wsrep::connect() failed: 6  
131018 23:00:20 [ERROR] Aborting

131018 23:00:20 [Note] WSREP: Service disconnected.  
131018 23:00:21 [Note] WSREP: Some threads may fail to exit.  
131018 23:00:21 [Note] /usr/sbin/mysqld: Shutdown complete

131018 23:00:21 mysqld\_safe mysqld from pid file /var/lib/mysql/wp-web3.macace.net.pid ended

Many thanks

Joe

---

<div class="post-metadata">

**Author:** ![karileh](https://avatars.discourse-cdn.com/v4/letter/k/bb73d2/32.png) [@karileh](https://forums.percona.com/u/karileh)\
**Post date:** [October 19, 2013, 7:10am UTC](https://forums.percona.com/t/3-nodes-will-not-start-mysql-percona-xtradb-cluster/3016/2 "2013-10-19T07:10:31Z")

</div>

Hi, did you reboot all nodes at the same time? If so, maybe you must bootstrap a new cluster from one of the hosts.

---

<div class="post-metadata">

**Author:** ![scjmoore](https://avatars.discourse-cdn.com/v4/letter/s/c0e974/32.png) [@scjmoore](https://forums.percona.com/u/scjmoore)\
**Post date:** [October 21, 2013, 9:22am UTC](https://forums.percona.com/t/3-nodes-will-not-start-mysql-percona-xtradb-cluster/3016/3 "2013-10-21T09:22:14Z")

</div>

@karileh Many thanks This seems to have done the tick
