Not the answer you need?
Register and ask your own question!

PXC 5.5.28 Pb with multiple addresses

aziguiazigui ContributorCurrent User Role Beginner
Hi,

I upgrade my PXC in 5.5.28 but I have a problem with wsrep_cluster_address variable for multiple addresses in the first node.
With wsrep-url, my values was :
wsrep_url = gcomm://ip_node2:4567,gcomm://ip_node3:4567,gcom://

How can I apply this values with wsrep_cluster_address.
At the moment I put like this :
wsrep_cluster_address = gcomm://,ip_node2:4567,ip_node3:4567.
The problem is if I restart the first node is in like a split brain, the wsrep_cluster_size's equal to 1 instead to 3. And the others nodes are equal to 2.

Thx for your help

Best regards

Comments

  • lefredlefred Contributor Inactive User Role Beginner
    Hi,

    wsrep_cluster_address syntax doesn't require the port (and should be in [mysqld] and not in [mysqld_slave], just to confirm).

    So could you try with (I put some random ip's):

    wsrep_cluster_address=[URL]gcomm://192.168.70.2,192.168.70.3[/URL]

    And watch out the first comma in your setting, this is incorrect, with wsrep_cluster_address, you don't have anymore the empty gcomm://

    so you need to start the first time your cluster with:
    wsrep_cluster_address=gcomm://

    and then modify that setting in my.cnf and never have the empty gcomm anymore (until all your nodes are off)

    regards,
  • aziguiazigui Contributor Current User Role Beginner
    Hi,

    Thanks for your help but my cluster is in service for a long time.
    I'm afraid if I stop all nodes and I want restart first node it doesn't work with your second config modification

    How can I obtain like this wsrep_urls=[URL="gcomm://192.168.60.12:4567,gcomm://192.168.60.13:4567,gcomm://"] gcomm://192.168.60.12:4567,gcomm://192.168.60.13:4567,gcomm: //[/URL] but with wsrep_cluster_address variable

    Best regards,
  • aziguiazigui Contributor Current User Role Beginner
    Hi lefred,

    have you find a solution for my problem, because my first node is crashed impossible to start it.
    So it's impossible to start PXC on my 2 and 3 node.
    With this upgrade I lose my HA availability because multiple adress function doesn't work

    Best regards
  • lefredlefred Contributor Inactive User Role Beginner
    The only solution you currently have is:

    in my.cnf, set something like :
    wsrep_cluster_address=[URL]gcomm://192.1.1.1,192.1.1.2,192.1.1.3[/URL]

    and the first node that you will start you need (it works on redhat like distro, no idea yet on debian like) to start the first node like this :

    /etc/init.d/mysql start --wsrep-cluster-address="gcomm://"
Sign In or Register to comment.

MySQL, InnoDB, MariaDB and MongoDB are trademarks of their respective owners.
Copyright ©2005 - 2020 Percona LLC. All rights reserved.