Not the answer you need?
Register and ask your own question!

innobackupex: Error: mysql child process has died

hi_irfhi_irf ContributorCurrent User Role Beginner
Hello,

I am getting following error when calling innobackupex from shell script.

innobackupex: Error: mysql child process has died: at /usr/bin/innobackupex line 1051.

Although when running same command from shell prompt. It executes without any error.

perl /usr/bin/innobackupex-1.5.1 --slave-info --user=XXXXX --password=XXXXX --databases=XXXXX --defaults-file=/etc/my.cnf --no-timestamp /home/fullbackup

I tried xtrabackup-1.6.4.tar.gz & xtrabackup-1.6.5.tar.gz but same error in both of the versions.

Comments

  • xaprbxaprb Mentor Inactive User Role Beginner
    A lot of times this happens due to the wrong working directory, or due to the MySQL wait_timeout being exceeded.
  • hi_irfhi_irf Contributor Current User Role Beginner
    I sorted out. I were using PATH variable in my shell script, as soon as i changed the name of variable. It's working fine.

    I thought it is reserved word, environmental variable conflicting with the innobackupex script.
Sign In or Register to comment.

MySQL, InnoDB, MariaDB and MongoDB are trademarks of their respective owners.
Copyright ©2005 - 2020 Percona LLC. All rights reserved.