Not the answer you need?
Register and ask your own question!

Innobackupex windows version Invalid version format (non-numeric data)

fineman8fineman8 EntrantCurrent User Role Beginner
hi

I did the following

1. downloaded - http://www.percona.com/redir/downloads/XtraBackup/XtraBackup -1.6/Windows-alpha/64bit/xtrabackup-1.6.64bit.zip

2. environment- windows server 2008 R2 Datacenter, 64Bit operating system, Active pearl 5.12.4.1205

3 Execute Innobackupex - $ "C:/Program Files/xtrabackup-1.6.64bit/innobackupex.pl" --defaults-file="C:/Program Files/MySQL/MySQLInstance2/my.ini" --user=root --password=admin D:/Xtrabackup/13306_1


4. response - Invalid version format (non-numeric data) at C:/Program Files/xtrabackup-1.6.64bit/innobackupex.pl line 1780.


Line 1780
# check the version of the perl we are running
if (!defined $^V) {
# this perl is prior to 5.6.0 and uses old style version string
my $required_version = $required_perl_version_old_style;
if ($] lt $required_version) {
print STDERR "$prefix Warning: " .
"Your perl is too old! Innobackup requires\n";
print STDERR "$prefix Warning: perl $required_version or newer!\n";
}
} else {
$perl_version = chr($required_perl_version[0])
. chr($required_perl_version[1])
. chr($required_perl_version[2]);
if ($^V lt $perl_version) {
my $version = chr(48 + $required_perl_version[0])
. "." . chr(48 + $required_perl_version[1])
. "." . chr(48 + $required_perl_version[2]);
print STDERR "$prefix Warning: " .
"Your perl is too old! Innobackup requires\n";
print STDERR "$prefix Warning: perl $version or newer!\n";
}
}

Question
has anybody any idea as to what i should do? is there any known pearl version that works with the software on windows?

Comments

Sign In or Register to comment.

MySQL, InnoDB, MariaDB and MongoDB are trademarks of their respective owners.
Copyright ©2005 - 2020 Percona LLC. All rights reserved.