Not the answer you need?
Register and ask your own question!
Many Forum changes were implemented on Tue 22 Sep. Read about new Ranks, Scoring, and Reactions.
Email [email protected] for any comments or concerns.

Adding pmm-client and accessing Prometheus UI without authentication

Hi everyone,
I'm currently testing the v2.4.0 running in docker which works fine.
I have an "old" pmm v1 which was configured without authentication and I cannot reproduce this behavior in the v2.
If I disable the authentication on v2, my client cannot join the server (permission denied). Same behavior when I create an "Editor" user.
I can only add a client if I use an Admin user.
Is it a normal behavior, or is there a way to do it ? At least, is it possible to disable the authentication for the prometheus interface?
Any help would be appreciated, thanks !

Answers

  • adivinhoadivinho Percona Percona Staff Role
    Hi,
    Directive "auth_request off" can be used in nginx configuration file (/etc/nginx/conf.d/pmm.conf) for the location /prometheus 

  • Chr0myChr0my Current User Role Contributor
    @adivinho
     Thank you for your quick answer, it works well. 
    Can you tell me if it's possible also to deactivate authentication for pmm-client to join the server ? Or at least confirm me that only Admin credentials must be used ?
  • adivinhoadivinho Percona Percona Staff Role
    Hi @Chr0my,
    It can't be deactivated. Any account with role "admin" can be used for connecting to pmm server.

  • Chr0myChr0my Current User Role Contributor
    Thank you that's what I thought.
Sign In or Register to comment.

MySQL, InnoDB, MariaDB and MongoDB are trademarks of their respective owners.
Copyright ©2005 - 2020 Percona LLC. All rights reserved.